Solved XFCE4: No shutdown and restart buttons, only logout

I cannot reboot or shut down my system (12.1-STABLE r360336 AMD64) via main menu from xfce4 session, there are no such buttons, a logout button only.
I use sddm as a display manager and have the following lines in /etc/rc.conf:
Code:
dog@dog:~ % egrep "sddm|dbus" /etc/rc.conf
dbus_enable="YES"
sddm_enable="YES"
My user is in operator and wheel groups:
Code:
dog@dog:~ % groups
dog wheel operator video cups vboxusers
I also added a .rules file to the /usr/local/etc/polkit-1/rules.d/ directory as mentioned in the xfce4-session package description:
Code:
dog@dog:~ % sudo cat /usr/local/etc/polkit-1/rules.d/60-xfce.rules
polkit.addRule(function (action, subject) {
  if ((action.id == "org.freedesktop.consolekit.system.restart" ||
      action.id == "org.freedesktop.consolekit.system.stop")
      && subject.isInGroup("operator")) {
    return polkit.Result.YES;
  }
});
I tried to reboot the machine after I made that settings, but it doesn't help. I tried to find an appropriate item in the graphical settings manager but there are nothing like that.
 
I made oldschool-style investigation - renamed the directory ~/.config/xfce4, started xfce from scratch, found that everything works alright and made configs comparison. The thing was that a boolean value " PromptOnLogout" was set to false.
I'm new to this DE, can't remember if I set it on purpose, probably it was a disastrous result of one of my tuning experiments. I'm sorry. The issue has been solved.
 
Top