Xfce xfce4-appfinder does not run

mauror

New Member


Messages: 13

Hi all, after installed and personalized Freebsd 13 (these are my first Freebsd days), solved some config matters thanks to the precious help that I'm receiving in this forum, I'm still facing an issue with xfce4-appfinder utility: I never succeeded to run it.
Tried first clicking the menu item nothing appears on the desktop, then from the terminal it does nothing, no answering messages, the cursor just remains below without any prompt return.
Can you suggest a way to resolve this oddity? Maybe some of you already experienced this issue.
Thank you
 

tingo

Son of Beastie

Reaction score: 628
Messages: 2,526

You don't get any output, not even like this?
Code:
tingo@kg-core2$ xfce4-appfinder --version
xfce4-appfinder 4.16.1 (Xfce 4.16)

Copyright (c) 2004-2020
    The Xfce development team. All rights reserved.

Please report bugs to <https://gitlab.xfce.org/xfce/xfce4-appfinder/>.
If this doesn't work, then most likeley something is broken with your installation.
 

bsduck

Active Member

Reaction score: 136
Messages: 179

Works fine here (FreeBSD 13.0 amd64 with quarterly packages).
 
OP
M

mauror

New Member


Messages: 13

You don't get any output, not even like this?
Code:
tingo@kg-core2$ xfce4-appfinder --version
xfce4-appfinder 4.16.1 (Xfce 4.16)

Copyright (c) 2004-2020
    The Xfce development team. All rights reserved.

Please report bugs to <https://gitlab.xfce.org/xfce/xfce4-appfinder/>.
If this doesn't work, then most likeley something is broken with your installation.

yes, I get this output
 

tingo

Son of Beastie

Reaction score: 628
Messages: 2,526

Ok, what happens if your run just xfce4-appfinder from a Terminal / xterm?
Here is what it looks like for me: xfce4-appfinder_Screenshot_2021-05-04_23-26-33.png
 

bsduck

Active Member

Reaction score: 136
Messages: 179

Are you using quarterly or latest packages?

You may try to reinstall it: # pkg install -f xfce4-appfinder

Is dbus enabled?
 
OP
M

mauror

New Member


Messages: 13

Ok, what happens if your run just xfce4-appfinder from a Terminal / xterm?
Here is what it looks like for me:View attachment 9791
ok, now I've better discovered how it behaves : as said in my first post, just running it by terminal does nothing, it remains like in execution but nothing appears. At this point, if I try to run it by the menu item (with the Terminal window still active) the appfinder runs! Viceversa, if I try to run it first from the app menu it does nothing, at this point if I open a Terminal and give xfce4-appfinder command...it runs. Seems like I have to invoke it twice, both by Terminal command and from the menu item (does not matter which one first) to make it work. Well, not really perfect but better than nothing :)
 
OP
M

mauror

New Member


Messages: 13

Are you using quarterly or latest packages?

You may try to reinstall it: # pkg install -f xfce4-appfinder

Is dbus enabled?

I have installed Freebsd 13 stable few days ago. How can I check dbus enabled? However there is something more I've just learned about this behaviour (see my last observation just posted )
Thank you
 
Top