XFCE Unable to Login from KDM


I have not found a satisfactory answer to this on the web. I have FreeBSD-8 RELEASE p-2 and have installed Xfce from the ports. I am using kdm to login to the kde4 sessions. After installing Xfce there is a login choice for Xfce in kdm, so I assume that it is a valid option. However, when I choose Xfce I get a black screen like it is trying to start but it immediately comes back to the kdm login. I have the same issue with two different users.

I do have hald and dbus enabled in rc.conf. I have also identified the local host correctly in /etc/hosts. Any other suggestions on how I can track this down?

Thanks very much.
I'm seeing this in the kdm-bin.log:
kdmgreet: Fatal IO error: client killed
KCrash: Application 'kdmgreet' crashing...
QThread::wait: Thread tried to wait on itself
QThread: Destroyed while thread is still running
drkonqi: cannot connect to X server :0.0
shutdown: [pid 1397]
Shutdown NOW!
Shutdown NOW!

There are not dates or times associated with this, but judging by what is around it I suspect it to be the xfce login attempt.
Sorry for the question, but have you installed x11/xfce or x11/xfce4?
xfce port is for version 3.8, that i could not start with same-just-client-killed.
Again, try .xinitrc way to see if it's kdm problem or xfce one.
Xfce works if I use a window manager other than KDE and login. I type [CMD="startxfce4"]&[/CMD] and xfce comes up and works fine.


aorchid said:
I suspect this is the same issue that I am having:
and I see there is currently no happy fix.

You can try this:

Move .config to a backup directory.
startxfce4 should now work every time. Try it several times.
There'll be a new .config directory that was created. Delete it and restore the old .config.
After this, xfce4 should start every time.

This has worked for me on two machines, but other people have not had the same success.