Xfce starts with blank screen and unmovable mouse

I'm just going to start with the post, and the pertinent part of the Xorg.0.log file, which is:
config/devd: device /dev/ums0 already opened
config/devd: devd socket is lost
config/devd: fail to connect to devd
/config/devd terminating backend....

xfce just hangs at this point and I have to to a hard shutdown. No Alt-Ctl-Backspace.

Followed the installation instructions to a tee - but I'm trying to use a Asus X555U Geforce 940m optimus chipset laptop, and the latest NVidia drivers. I've heard this can cause problems with GUIs, but I've had it work with KDE. Not sure what I'm doing wrong with xfce.
What version of FreeBSD? And can you post the whole Xorg.0.log? (Preferably on something like pastebin).
Freshly installed 10.3, off a bootable netimage. Here it is:

And something of note. I was real hesitant about signing up for the forums and posting this, becuase its kind of been a saga of problems, but here's the details:

I've had it work before on this machine, using various tons of different xorg.conf files.

What I think got it working before was using the lspci command to see the BusID of the approprite video card(since optimus technically is dual intel/nvidia video) and putting that the appropriate BusID/driver line in xorg.conf.

Unfortunately, its not working this time, and I had to wipe the system and can't remember which one worked.

So, I've generated dozens of different xorg.conf and Xorg.0.log files - this just happens to be the one that gets me into a graphical screen with the nvidia driver this time, but freezes.

Sorry for so many edits for people who have read this, but I wanted to make the info consolidated and easy to read.
Hi BoggledByBSD,

Is moused(8) running when you start X? Since ums(4) is a mouse driver and moused(8) manages mice, X and moused(8) could be fighting for control of the mouse. This has happened to me before with my laptop's touchpad and I resolved it by telling X to use /dev/sysmouse (which is managed by moused(8)). You can accomplish this with something like the following in /usr/local/etc/X11/xorg.conf.d/10-mouse.conf (you can name the file whatever you like):
Section "InputDevice"
    Identifier      "Mouse0"
    Driver          "mouse"
    Option          "Protocol"      "auto"
    Option          "Device"        "/dev/sysmouse"
I already had that idea when I looked at the logs before, and tried it. It does change the error, but something still stops. I got the idea for what what you suggested after fervent googling on another BSD thread here.

What really bothered me about the Xorg.0.logs is no matter what I did, I would get this -
(WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
So alas, I gave up and swapped the laptop with a friend for an older one with an integrated Intel grahpics chipset, after deciding that *nix systems, maybe because of Xorg or drivers, do not, and might not for a while have support for Optimus multi-card chipsets, and are better suited for integrated intel or possibly ati.

So while I can't say my problem is "solved", i can't figure out how to mark this thread as closed, since I've pretty much given up.