Xfce Xfce 4.14 - Problems with power management

Zequinha

New Member

Reaction score: 1
Messages: 5

Hi,

I am new to FreeBSD.

I am having issues with the hibernation settings on XFCE 4.14 - basically when my pc "goes to sleep", it doesn't wake up again. The only solution, once it goes into hibernation, is to press the power button and turn off the machine. When I used Xfce 4.12 in September, I don't think this happened.


I installed xfce4-power-manager 1.6.5, but that did not do much: the option "lock screen when system is going to sleep" is grayed out. If i change "Hibernate" to "Suspend" nothing good happens either.

I wanted to take a screenshot of the power manager but I when i press the print screen key I get a Failed to launchshorcut "Print" error - but i leave this for another post.

Any ideas on how to proceed about the hibernation/suspension issue?



Thanks!



System specs:

FreeBSD 12.1, Xfce 4.14,
Desktop: Dell OptiPlex 790, i7-2600 64 bit
Graphics:
vendor = 'Intel Corporation'
device = '2nd Generation Core Processor Family Integrated Graphics Controller'
class = display
subclass = VGA
 

tedbell

Active Member

Reaction score: 103
Messages: 220

Did you say the suspend buttons are greyed out? Did you add the lines for polkit as instructed in the post installation message of xfce?

EDIT:

Code:
To be able to shutdown or reboot your system, you'll have to add .rules
files in /usr/local/etc/polkit-1/rules.d directory. Which looks
like this (replace PUTYOURGROUPHERE by your group):

polkit.addRule(function (action, subject) {
  if ((action.id == "org.freedesktop.consolekit.system.restart" ||
      action.id == "org.freedesktop.consolekit.system.stop")
      && subject.isInGroup("PUTYOURGROUPHERE")) {
    return polkit.Result.YES;
  }
});

For those who have working suspend/resume:

polkit.addRule(function (action, subject) {
  if (action.id == "org.freedesktop.consolekit.system.suspend"
      && subject.isInGroup("PUTYOURGROUPHERE")) {
    return polkit.Result.YES;
  }
});
 
OP
Z

Zequinha

New Member

Reaction score: 1
Messages: 5

tedbell,

Thanks - Now the buttons aren't grayed out. I even unchecked the option "lock screen when system is going to sleep".

However, the problem remains:

When the pc goes to suspension, it does not wake back up.

Doing
cd /usr/local/etc/polkit-1/rules.d
cat .rules

results in:

Code:
polkit.addRule(function (action, subject) {
  if ((action.id == "org.freedesktop.consolekit.system.restart" ||
      action.id == "org.freedesktop.consolekit.system.stop")
      && subject.isInGroup("wheel")) {
    return polkit.Result.YES;
  }
});

polkit.addRule(function (action, subject) {
  if (action.id == "org.freedesktop.consolekit.system.suspend"
      && subject.isInGroup("wheel")) {
    return polkit.Result.YES;
  }
});
 
OP
Z

Zequinha

New Member

Reaction score: 1
Messages: 5

Which intel driver are you using? i915kms or xf86-video-intel?
I've installed xf86-video-intel when I installed Xfce and Xorg.

How do I check which graphics drivers are installed/running on a FreeBSD system?
 

tedbell

Active Member

Reaction score: 103
Messages: 220

I've installed xf86-video-intel when I installed Xfce and Xorg.

How do I check which graphics drivers are installed/running on a FreeBSD system?
I can't remember at the moment how to check. Why not try using the intel modesetting driver with the appropriate entries in your /boot/loader.conf or /etc/rc.conf.
The thing is I have been told that suspend resume in FreeBSD doesn't work with Nvidia drivers. So I dunno if I can help you. Maybe also try using those legacy DRM kmod drivers if they still exist. Your device seems a bit old.
 
OP
Z

Zequinha

New Member

Reaction score: 1
Messages: 5

tedbell Thanks for hinting in the right direction. I think the problem is solved now! :)

Basically i installed the driver drm-kmod (I also made sure my user account belonged to the video group). Now I habve both drm-kmod and xf86-video-intel installed.
 

tedbell

Active Member

Reaction score: 103
Messages: 220

tedbell Thanks for hinting in the right direction. I think the problem is solved now! :)

Basically i installed the driver drm-kmod (I also made sure my user account belonged to the video group). Now I habve both drm-kmod and xf86-video-intel installed.
Glad to hear it's working! Your system will use one or the other driver so you don't really need to have the xf86 version. Most people say that it's better to use the built in Intel modesetting driver. The xf86 driver loads automatically with Xorg but the modesetting one requires configuration:

/etc/rc.conf
Code:
kld_list="/boot/modules/i915kms.ko"
 
Top