Xfce xfcd4-screensaver 4.16.0_1 disables keyboard and mouse

ko56

Member

Reaction score: 2
Messages: 43

Hi, I am running 13.0 RELEASE and Xfce 4.16. xfce4-screensaver behaves in a weird way.

When the screen locks, either because I do it explicitly by hand, or because the time I've configured is reached, no screensaver actually appears on the screen. (It is supposed to blank the screen.) Instead, whatever was on the screen is still displayed, but
(1) the keyboard is disabled (i.e. no keystroke has any effect), and
(2) the mouse pointer can be moved, but clicking on any menubar, on any window, right-clicking, etc, has no effect.

I've downgraded the screensaver to 0.1.11_1, and the problem persists.

In fact this problem was there on FreeBSD 12.2 RELEASE, with Xfce 4.16 also. But on 12.2 it went away when I downgraded the screensaver to 0.1.18_1.
Any help would be welcome.
 
OP
K

ko56

Member

Reaction score: 2
Messages: 43

My problem report wasn't entirely accurate. Here is what is happening in more detail:

[ko@wiley ~]$ xfce4-screensaver --debug
[gs_debug_init] gs-debug.c:115 (08:23:40.423): Debugging enabled
[main] xfce4-screensaver.c:95 (08:23:40.424): Initializing xfce4-screensaver 4.16.0
[init_session_id] gs-listener-dbus.c:2192 (08:23:40.440): Got session-id: /org/freedesktop/ConsoleKit/Session8
[gs_listener_init] gs-listener-dbus.c:2218 (08:23:40.440): Acquiring logind sleep inhibitor lock
[gs_listener_x11_set_timeouts] gs-listener-x11.c:322 (08:23:40.443): Saver timeout updated to 300 seconds
[gs_listener_x11_set_timeouts] gs-listener-x11.c:328 (08:23:40.443): Lock timeout updated to 360 seconds
[gs_listener_x11_acquire] gs-listener-x11.c:298 (08:23:40.502): ScreenSaver Registered

In another window, at this point I activate the screensaver:
ko@wiley ~]$ xfce4-screensaver-command -a
[ko@wiley ~]$


[gs_grab_grab_root] gs-grab-x11.c:347 (08:24:16.910): Grabbing the root window
[gs_grab_get] gs-grab-x11.c:104 (08:24:16.911): Grabbing devices for window=50F
[gs_manager_create_windows_for_display] gs-manager.c:1178 (08:24:16.911): Creating 1 windows for display :0.0
[add_overlays] gs-manager.c:1015 (08:24:16.911): Reconfiguring monitors, adding overlays
[gs_listener_send_signal_active_changed] gs-listener-dbus.c:225 (08:24:16.911): Sending the ActiveChanged(TRUE) signal on the session bus
[remove_overlays] gs-manager.c:1046 (08:24:19.324): Done reconfiguring monitors, removing overlays

Now here, pressing any key on the keyboard has no effect. Further, the mouse pointer can be moved, but clicking on anything has no effect.

Finally here I ssh into the machine and kill the screensaver.


Killed
[ko@wiley ~]$
[ko@wiley ~]$
[ko@wiley ~]$
 

Tieks

Active Member

Reaction score: 66
Messages: 157

File /usr/ports/x11/xfce4-screensaver/pkg-descr says this: This is a beta version, not recommended for production machines. I tried to use it a few years ago and ran into similar problems. Now I run this script from a launcher on the panel to switch off the screen:

Code:
#!/bin/sh
sleep 1
/usr/local/bin/xset dpms force off

The builtin Power Manager (under Applications, Settings) in Xfce4 v4.16 works too.
 
OP
K

ko56

Member

Reaction score: 2
Messages: 43

Thanks, I'm aware of what pkg-descr says. Nevertheless, as I mentioned, it used to work, and seems to have broken after 0.1.18.

I also use the power manager, and the demon, powerd, turns off the screen nicely.
But I've deactived xfce4-screensaver.
 
Top