Xfce X11VNC does not work as it should after upgrade from 11 to 12.1 version. Crashes every time after 2-3 days.

After upgrade FreeBSD from 11 version to 12.1- RELEASE, x11vnc does not work as it should and crashes every time after 2-3 days. Also, keyboard input in remove console on the remote desktop via VNC sometimes stuck. Under 11 BSD everything was fine.
I believe this is not because XFCE but I run it under XFCE.
When I tried to reinstall it from ports got this warning.
[root@freebsd /usr/ports/net/x11vnc]# make install
make: "/usr/ports/Mk/bsd.port.mk" line 1189: UNAME_r (12.1-RELEASE-p1) and OSVERSION (1102000) do not agree on major version number.


Staff member
You seem to have only done a partial upgrade. You still have a 11.2 userland running on a 12.1 kernel. You really need to finish the upgrade procedure.
You are actually absolutely right. I forgot about freebsd-update install
Thank you
But x11vnc still works not stable. Even after the whole system update and made it from scratch x11vnc crashes after 1-3 days... Any ideas?
I found out when the x11vnc crashes. As a fact, this is not a crash, but something works wrong. It happens unpredictably but always right after Ctrl-C and right after login to VNC. Never happened during using the VNC. So I guess somehow daemon x11vnc get to the front as a foreground process and accept this keyboard shortcut.
I have got some response while crashes of x11vnc happen:
05/07/2020 10:53:02 Using image quality level 6 for client
05/07/2020 10:53:02 Using JPEG subsampling 0, Q79 for client
05/07/2020 10:53:02 Enabling NewFBSize protocol extension for client
05/07/2020 10:53:02 Enabling LastRect protocol extension for client
05/07/2020 10:53:02 Enabling cursor position updates for client
05/07/2020 10:53:02 Enabling full-color cursor updates for client
05/07/2020 10:53:02 Using tight encoding for client
05/07/2020 10:53:03 client_set_net: 0.0023
caught XIO error:
05/07/2020 10:53:07 deleted 60 tile_row polling images.

And after this, the x11vnc server has crashed...
After update whole system from 12.1 to 12.2, still have same problem with x11vnc. It crashes with error "caught XIO error:".
I have even checked on new server. Created new VPS on the VirtualBox, then installed from scratch xorg, xfce, x11vnc, did whole setup of system and same glitch.
I found that this is a known issue https://askubuntu.com/questions/288...vnc-disconnects-immediately-after-valid-login
But nothing explained by URL does not work for FreeBSD.
Any thoughts ?
Have been installed 11.4 + xorg + xfce + x11vnc and same bug. Obviously this is not an OS version problem at all.
This may be a long shot, and I realize this thread is a bit old, but if you are still experiencing the problem, you might want to try the command line option '-noxdamage'. I had random VNC Client disconnects, and the x11vnc output would show me the same 'caught XIO error' on some Linux boxes running x11vnc recently and that fixed it for me there. I haven't experienced the problem on FreeBSD however.