x11/konsole says "Warning: Could not find an interactive shell to start." after pkg upgrade today

PaddyMac

Member

Reaction score: 13
Messages: 47

Just as the title says, after doing a "pkg update && pkg upgrade" today then rebooting, I see an error saying "Warning: Could not find an interactive shell to start." when I run konsole. A lot of packages totalling about a 1GB download were upgraded. I'm actually not sure if konsole itself was upgraded. 21.04.0_1 is the version currently available via pkg. So maybe there are some packages that haven't been built yet and there's a broken dependency chain? If that's the case, then maybe waiting a few days and upgrading again will fix it. But "pkg check -d" doesn't detect anything. Anyway, I didn't want to hastily file a bug, but I wondered if anyone else has encountered it and knows what happened.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 11,604
Messages: 37,927

So maybe there are some packages that haven't been built yet and there's a broken dependency chain?
The packages are all built in the same build run then copied to the repository mirrors as a whole. So this type of broken chain should never happen.

Check the obvious things like /var/log/messages and /var/log/Xorg.0.log for errors.
 

astyle

Aspiring Daemon

Reaction score: 250
Messages: 562

yeah, I had the same issue, and the above solution helps. One thing I'd like to add - make that Konsole profile the default, the Settings in Konsole should provide a button for that.

Hey - 21.04.0_1 is already available as packages??? mine was compiled from ports, with as many flags turned on as possible.
 

Mike G

New Member

Reaction score: 5
Messages: 9

I have had the same problem with the same version installed from pakages. I didn't have bash so I installed from packages and made a profile using bash, it worked all day yesterday. However, today I am back to the same problem, except now neither bash nor sh work with konsole. Fortunately XTerm still works file, otherwise I would have real problems. PS Konqeror also started playing up at the same time, sometimes it just dosent even seem try to load an web site, though with repreated attepts or by loading a different page on the site I can get it work properly. Don't know if this is related.
 

Mike G

New Member

Reaction score: 5
Messages: 9

Instead, try 21.04.1
I am fairly new to FreeBSD so I may have misinterpreted the version info as result of misinterpreting the underscore. My current version is Version 21.04.1 installed via PKG. It was working untill I did an update of all the packages via PKG a few days ago. I am not sure what the version was before the update. Since the original poster seemed also be using PKG and to have just done the sameupdate, I assumed we were usign the same packages. I have also foudn that the problems with Konqeror that started at the same time are persistant and real, whilst chrome still works fine, so I can't help suspecting that the is a common cause to both programs inabilty to make connections.
 

grahamperrin

Daemon

Reaction score: 366
Messages: 1,208

Thanks. For now, I suggest focusing this topic on Konsole. Now reported:


Which version of FreeBSD do you use?



For reference only, the routine through which I found times of updates:

Code:
% cd /var/log
% ls -ahlrt messages*
-rw-r--r--  1 root  wheel    53K 15 Apr 11:00 messages.4.bz2
-rw-r--r--  1 root  wheel    62K 26 Apr 06:00 messages.3.bz2
-rw-r--r--  1 root  wheel    74K  5 May 23:00 messages.2.bz2
-rw-r--r--  1 root  wheel    66K 12 May 09:00 messages.1.bz2
-rw-r--r--  1 root  wheel    66K 22 May 16:00 messages.0.bz2
-rw-r--r--  1 root  wheel    93K 25 May 12:05 messages
% grep 21.04.1 messages
May 25 03:30:23 mowa219-gjp4-8570p pkg[2328]: spectacle upgraded: 21.04.1 -> 21.04.1_1
% zcat messages.0.bz2 | grep 21.04.1 | grep -i konsole
May 16 23:58:36 mowa219-gjp4-8570p pkg[2674]: konsole upgraded: 21.04.0_1 -> 21.04.1
% zcat messages.1.bz2 | grep 21.04.0_1 | grep -i konsole
% zcat messages.2.bz2 | grep 21.04.0_1 | grep -i konsole
May  5 22:08:30 mowa219-gjp4-8570p pkg[3366]: konsole upgraded: 21.04.0 -> 21.04.0_1
% date ; freebsd-version ; uname -KU
Tue 25 May 2021 15:06:34 BST
14.0-CURRENT
1400013 1400013
%
 

Mike G

New Member

Reaction score: 5
Messages: 9

I have made some progress with this, I think. The problem seems to be with sh, and it seems that if you start a session with the default profile, which uses sh, then Konsole will not be able to change the profile; perhaps , I hypothesise, because it tries to use sh when issuing commands to change the profile. But, if you create a profile that uses bash, make that the default profile and then clolse the current session, then Konsole seems to work fine when you restart it with bash from the outset. If it will keep working is another question, as last time I set it to bach it only worked for a while, but then I did not change the default profile. Hope this work around keeps working and works for you as well.
 

Mike G

New Member

Reaction score: 5
Messages: 9

Certainly it involves /bin/sh

Via the FreeBSD bug, an upstream bug: <https://bugs.kde.org/show_bug.cgi?id=436242>



Not always true.

Probably true if you made it your default shell when (unrelated to Konsole or KDE Plasma) your user account was added to the system.
I would guess that if someone picked a diffferent shell they would not be having this particular problem, but being new to FreeBDS and Konsole (as I mentioned before) I had not twigged that the default command would depend on the shell selected when setting up my Freebsd user account.
 
Top