X - no screens found - error

zeising@

Developer
mate, I need to buy you a beer. that fixed it for me on two systems. of course i have pretty much stuffed my X setup by fiddling, trying to fix the problem myself, but at least now the GUI is back.

I'm not sure I deserve the beer, considering I probably broke stuff to begin with. :)
I've had several good reports with the patch, I'll push it to the ports tree as soon as possible, I just need to clear some other things off the TODO list first. It will then take some time (usually a couple of days) before it shows up as pre-built packages.
 
  • Thanks
Reactions: pez
The way this bug went from this Forum to Bugzilla, got reviewed, patched and tested by some end users and gets up into the tree -- for me it is just a Great Example of how things are managed over here to improve FreeBSD.

TNX to all that contributed!
 

zeising@

Developer
I have just committed the libpciaccess fix I posted here earlier. It will take some time before it shows up as pre-built packages.
 
Now I'm afraid to say anything, lest I get banned.

For better or for worse, saying stupid things is not enough of a reason for a ban. Obscuring the relevant information by sheer number and volume of contradicting posts as well as advertising random binaries of unknown origin in place of an existing workaround on other hand…
 
All the suggestions here, like many others on the Internet - Bugzilla, mailing list (https://lists.freebsd.org/pipermail/freebsd-questions/2014-August/260166.html), etc - never worked for the box here.

It's now over a week and I'm yet to fix it. No luck with other desktop environments using Xorg either.

I luckily got Wayland/Sway going. Checking hikari in freshports, there seems to be no bandwidth to try other compositors out, including sway. They're nice though. And there are just few apps running on Wayland.

I shall buy a new graphics card (Gigabyte GeForce GT 710)
tomorrow and see if Xorg would detect the device.

Sometimes, FBSD drains one.
 
Has this issue been resolved? I just finished installing a fresh copy of FreeBSD 12.2 on a HP Satellite Laptop with an AMD chip, RS880M Mobility Radeon 4225 GPU/Video Card. I was able to finish the install of the base system, Xorg, KDE, SDDM. However, when I try to run "startx" and I get the following error: "No Screen Found". Any tips/ideas on how to proceed would be greatly appreciated.
 
For better or worse, I'm back again with a fresh install of v13.1 on the same Dell Inspiron 8100 laptop and as soon as I install any nVidia driver for the GeForce4 440, startx returns the same ol' "No Screen Found" error.

After spending hours researching "No Screen Found" errors, I decided to wipe the Inspiron 8100, reinstall FreeBSD v12.3 and Spartrekus' old patch (which I archived on a DVD)....problem SOLVED again.

So there IS still some type of compatibility issue with these nVidia drivers/cards that hasn't been [officially] solved. Anyone else having this issue or a remedy that doesn't involve spending more hours reading man pages, development threads and other spurious black holes?
 
Top