Solved www/w3m wants perl5-16.3 installed

This is strange, since I'm trying to upgrade www/w3m. It wants me to install perl5-16.3, that is no longer in the system. It also makes a re-install of perl5-5.18 at the same time.

Getting the binary package pulls this in and does a downgrade.

pkg install www/w3m
Updating FreeBSD repository catalogue...
FreeBSD repository is up-to-date.
All repositories are up-to-date.
Checking integrity... done (1 conflicting)
Checking integrity... done (0 conflicting)
The following 5 package(s) will be affected (of 0 checked):

Installed packages to be REMOVED:

New packages to be INSTALLED:
  w3m: 0.5.3_5
  trousers-tddl: 0.3.10_7
  libvpx: 1.5.0_1

Installed packages to be DOWNGRADED:
  pkg: 1.8.3 -> 1.7.2

The process will require 6 MiB more space.
2 MiB to be downloaded.

I will try this, since correcting it should not be a complicated matter. It might even resolve few issues at best, at worst, this is only going to get a slightly more complicated.

Thanks for the help.
I solved this issue, turns out that an old configuration file connected to perl was creating this issue. I found the solution here.