Solved www/firefox with youtube

I have troubles viewing youtube clips in firefox (again). Is it me or google again? It says: "Wait a bit. If playback did not start, restart the device." (Or something like that, for me it writes in Russian, so I translated it.) Due to navigation bar in clips, they are loaded, but do not start.
I don't have problems running firefox-46.0.1,1 with the options listed below. I also don't have flash installed. Are there specific videos that cause problems? If so, can you share a link? This doesn't solve your problem, but www/youtube_dl can be a backup. It works on many sites other than YouTube.

pkg info firefox-46.0.1,1
Name           : firefox
Version        : 46.0.1,1
Installed on   : Wed May  4 13:10:37 2016 ADT
Origin         : www/firefox
Architecture   : freebsd:10:x86:64
Prefix         : /usr/local
Categories     : ipv6 www
Licenses       :
Maintainer     :
WWW            :
Comment        : Web browser based on the browser portion of Mozilla
Options        :
        ALSA           : on
        BUNDLED_CAIRO  : on
        CANBERRA       : off
        DBUS           : off
        DEBUG          : off
        DTRACE         : on
        FFMPEG         : on
        GCONF          : off
        GIO            : on
        GNOMEUI        : off
        GTK2           : on
        GTK3           : off
        INTEGER_SAMPLES: off
        LIBPROXY       : off
        PGO            : off
        PROFILE        : off
        PULSEAUDIO     : off
        RUST           : on
        TEST           : off
I have troubles viewing youtube clips in firefox (again)
I don't have problems with FF 46 either, would you tell more, please?
1. What does "again" mean?
2. Do you have Flash player installed?
3. What exactly it tells you in Russian?
"Again" means the problem was in the past (may be year or two) with YouTube, Firefox and FreeBSD.
Yes, I have Flash.
I used the most exact translation available. YouTube videos worked just nice until recently.
For what it's worth, I frequently get that. I then click the stop icon, then click the arrow that appears to start, and it plays without problems. (FreeBSD-10.3 not sure what version of Firefox, and I don't think I have flash--it's my work machine and I'm home today so can't be more specific.)
Just get rid of Flash, it's dying anyway, almost all websites have switched to HTML5...
Definitely far from all websites switched from Flash. More than that, some sites that can use HTML5 use it in a strange way, say it works only in a proprietary Chrome. And some content is still definitely better made with "dying Flash" than with HTML5.

What concerns my problem, you can see on screenshot, that no plugin activated for (no plugin sign is on the left of address line). (Unlike this forum, that asks Flash to be started, but I easily live with it being off.) I put Flash in "ask to activate" state rather long time ago.

...I then click the stop icon, then click the arrow that appears to start, and it plays without problems...
If it would be that simple, I haven't asked for a help ever. It just never starts. Stop many times, trying to start, reload page, Ctlr+reload page, restart browser... Nothing helps.
Well, the YouTube Flash controls are a bit different. And I have to use a special plugin to use the Flash playback for YouTube for a different computer (somehow, it appears that on my old Windows 1-core Celeron laptop the Flash player lags less than HTML5 one).
Now I had to install that plugin to allow playback for YouTube videos on my FreeBSD computer... I really do not like that, just as you. Thanks for asking, I have at least that workaround (besides from downloading videos and then watch them or loading another browser like Chromium).
The funny thing is that youtube first requests Flash player, then FF and/or youtube decide to go with HTML5 (since I don't have Flash player).
Below is my screen capture video slowed 6 times, you can notice that at 6th second (i.e. 1st second of real time) a message appears "A plugin is needed to display this content":
The problem is solved somehow. There was trouble with the ownership of some files in my home directory. And upgrade. Something helped.
This particular error is in my experience related to the soundcard, more specifically, the soundcard being taken up by another application. That is the usual culprit.