Wine + World of Warcraft

danb

New Member


Messages: 4

Hi,

I just recently installed FreeBSD 7.1-STABLE and am in the process of getting world of warcraft working. When I run "wine InstallWoW.exe" I receive an error that says "Failed to read information from the internet, please close all applications and try again".

Has anyone here seen that error message before, or know of a way to resolve it? FWIW, running wine InstallWoW.exe through wine on gentoo and fedora works fine.

Thanks
 
OP
D

danb

New Member


Messages: 4

I was able to resolve this, unfortunately I had to downgrade to 6.4 after trying out 7.0 as well.
 

Djn

Well-Known Member

Reaction score: 67
Messages: 392

It's unelegant, but copying a working WoW install from windows works fine as a workaround. (I'm running it in 8.0 right now after doing exactly that).

As for the actual error - is this the full version downloader?
It does this on windows as well, now and then. See here. I haven't read through the thread, so I don't know if there's some solution or workaround in it.

Just to start somewhere, the downloader creates a logfile (TryWoW.txt). What does it say?


edit: Ah, good that you got it working - but to be honest, I don't really think it was the downgrade that fixed it.
 
OP
D

danb

New Member


Messages: 4

I don't believe the downgrade fixed it either as I tried almost everything in that link you provided. Fortunately, I do have WoW almost fully functional using 7.1, minus sound. Any idea why sound would work out of the box on 6.4 and not in 7.1?

I've loaded all the correct modules in /boot/loader.conf but still no joy, perhaps it is an issue with me restoring my ~/.wine directory from backup. I'm sure I'll figure it out, but for now, I'm happy to have WoW running in FreeBSD with a better FPS than what I got in windows. :D
 

Djn

Well-Known Member

Reaction score: 67
Messages: 392

I take it sound works in native programs?

One thing to try (that you probably already have) is to run winecfg and mess with the audio settings. See if there's more than one output device available; try turning the acceleration up and down.

And no, I really have no idea why it only works in 6.4 - that's somewhat weird. :)

edit
Come to think of it, I have a weird issue in 8.0 as well. As soon as a wine program uses sound, it sets the volume to 0. I solved it by removing write access to /dev/mixer0 for everyone, and then setting all channels to max as root.
 
OP
D

danb

New Member


Messages: 4

Removing write access for all users did the trick. Thanks
 

Maledictus

Member

Reaction score: 7
Messages: 53

I just got a new Machine with a hda soundcard an frontpanel. Sound works for native programs and in winecfg but I can't hear anything in WoW. I tried every sound device in WoW's sound configuration.

edit: It works when I set Acceleration to Emulation!
 
Top