Solved WindowMaker, mount slice in fstab, and other things to get it setup.

userxbw

Member

Reaction score: 4
Messages: 65

A few questions on setting up WindowMaker.

I just installed WIndowMaker and a few dockapps. I have auto mount set and working in xfce4, but now that I got wmaker running it does not seem to be completely working, automount that is.

I have a multiboot system, windows 10, 2 Linux distros, and now FreeBSD on my laptop. The hdd that is holding FreeBSD is being shared with a data storage partiton (slice) it is ext4 due to Linux was here first. In xfce4 I can get to it via the file-manager pcmanfm, just click into filesystem/media/data1 where it is at via automount.

I do suppose the quick fix would be to mount it in fstab, but I have thus far had no luck mounting drives in here (FreeBSD) in a terminal. So I doubt I'll get that done in fstab without a little help to do so. If I click into pcmanfm in /meida when I am in wmaker I get nothing. well now I do, I just tried it again.
anyways, how would I just mount it in fstab to have it mounted read write so my user can just write to it when needed?
Code:
userx@FreeBSD64.net:~
$ ls /dev | awk '{print $1}'
acpi
ada0
ada0s1
ada0s1a
ada0s1b
ada0s2
ada1
ada1s1
ada1s2
ada1s3
ada1s5
ada1s6
ada1s7
ada1s8
ada0s1 would be the one to mount as ext4 labeled data1. that should just put that slice in the file manager when opening it up and gain read write access to it, yes? as it is in xfce4 I have to use su to get anything copied into that slice. In linux I mount it in /media but here in FreeBSD /media is a default for automount, would that case an issue if fstab mounts it in /media as well?

2. touchpad : how to turn it off? In Linux I use this in my autostart
Code:
#Shutoff touch pad and touch screen
    xinput set-prop $(xinput | awk '/TouchPad/ {print $6}' | cut -d= -f2) "Device Enabled" 0 &
    xinput set-prop $(xinput | awk '/Digitizer/ {print $7}' | cut -d= -f2) "Device Enabled" 0 &
in FreeBSD I don't see anything for a touchpad, or touch screen in xinput.
Code:
$ xinput
â¡ Virtual core pointer                        id=2    [master pointer  (3)]
â   â³ Virtual core XTEST pointer                    id=4    [slave  pointer  (2)]
â   â³ sysmouse                                      id=7    [slave  pointer  (2)]
â   â³ Mouse                                         id=8    [slave  pointer  (2)]
⣠Virtual core keyboard                       id=3    [master keyboard (2)]
    â³ Virtual core XTEST keyboard                     id=5    [slave  keyboard (3)]
    â³ kbdmux                                          id=6    [slave  keyboard (3)]
as the touchpad is hazardous, even when I started trying this, palm can slip over touch pad , menu pops up, selects text deletes text, user (me) gets upset, now everything I typed is gone, now i have to start over again.

with awk in here I seen that it does not print just the first collum if
Code:
 ls /dev | awk '{print $1}'
it just printed everything out in one line and what? so I installed gawk and it did the same, I have not looked in to ow to gawk only seen it is used in here too, that was just a shot in the dark try. anyways.

Updating Wmaker menu? what programs are there for that one? ( i have not looked into that one yet, just got wmaker installed):

Okay I just installed menumaker, but it just hangs when I use it.
Code:
userx@FreeBSD64.net:~
$ whereis mmaker
mmaker: /usr/local/bin/mmaker

....

$ mmaker -h

^C
$ mmaker -f wmaker
^C
 
Last edited:
OP
OP
userxbw

userxbw

Member

Reaction score: 4
Messages: 65

autostart file
Code:
    #FreeBSD
    #turn off touch-pad
    xinput set-prop 8 "Device Enabled" 0 &
 
OP
OP
userxbw

userxbw

Member

Reaction score: 4
Messages: 65

So, to mount the ext4 partition/slice, you'll need the sysutils/fusefs-ext4fuse package. Are you wanting to mount this partition on demand or at boot?
yea, what I have already done, and fuse might even already be installed, I seen something on that somewhere in some config file ( i think) when I was rummaging around in the system looking at things.

what I read ver 12 has read write on Linux drives, so in fstab I did this.
Code:
$ cat /etc/fstab
# Device        Mountpoint      FStype  Options Dump    Pass#
/dev/ada0s1a    /     ufs     rw      1       1
/dev/ada0s1b    none  swap    sw      0       0
#added by me 7aug 2019
/dev/ada0s2    /home/userx/data  ext2fs  rw      0       0
I know i have automount set up for USB mounts, and seems to be working properly (again) as it would not automount, and now it does, or has been as of late.

I just looked over it again, and added something to a file now it is now seemly working (fine) I believe without fuse.
17.4.2. Automounting Removable Media
 
Top