Will not automaticly connect wirelessly

So during an unknown time my FreeBSD installation stopped automatically connecting wirelessly.

I am able to connect manually via wpa_supplicant and then dhclient after I finish booting, however..

my /etc/wpa_supplicant.conf does contain valid info for connecting wirelessly as I am using it now.

I have tried 3 wireless cards for this and all 3 are the same,

I have my /etc/rc.conf like this ...

ifconfig_wlan0="WPA SYNCDHCP"

What can I do to make this connect automatically again? it's so annoying to wait for it to fail to connect every bootup so I can manually connect.
Thank you for replying.

I initially connected to my network with mgmt/networkmgr port" href="http://www.freshports.org/net-mgmt/networkmgr">net-mgmt/networkmgr and it would connect for me while booting afterwards.

I am running X11 and Mate, is mgmt/networkmgr port" href="http://www.freshports.org/net-mgmt/networkmgr">net-mgmt/networkmgr supposed to be responsible for the auto connecting? I have used it a few times since thinking that was the issue but it still did not persist through reboots.
aimeec1995 , it's not clear what you are trying to do. With your /etc/rc.conf you should be able to connect automatically after booting.
If it doesn't work, you should try finding the problem, so do not run networkmgr or other tools.
If you do run and it works for you, just remove ifconfig_wlan0 option from your rc.conf.