Wi-Fi Realtek RTL8191S WLAN Adapter not working

goshanecr

Active Member

Reaction score: 33
Messages: 208

Hi Friends!

I have a Intel Atom D2700 based nettop and FreeBSD 12.2 i386 fresh install.
That PC has a integrated Wi-Fi on a USB bus based on a RTL8191S chipset:
Code:
# usbconfig list
ugen2.1: <Intel UHCI root HUB> at usbus2, cfg=0 md=HOST spd=FULL (12Mbps) pwr=SAVE (0mA)
ugen3.1: <Intel UHCI root HUB> at usbus3, cfg=0 md=HOST spd=FULL (12Mbps) pwr=SAVE (0mA)
ugen5.1: <Intel EHCI root HUB> at usbus5, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE (0mA)
ugen0.1: <0x104c XHCI root HUB> at usbus0, cfg=0 md=HOST spd=SUPER (5.0Gbps) pwr=SAVE (0mA)
ugen1.1: <Intel UHCI root HUB> at usbus1, cfg=0 md=HOST spd=FULL (12Mbps) pwr=SAVE (0mA)
ugen4.1: <Intel UHCI root HUB> at usbus4, cfg=0 md=HOST spd=FULL (12Mbps) pwr=SAVE (0mA)
ugen5.2: <Manufacturer Realtek RTL8191S WLAN Adapter> at usbus5, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON (500mA)

lsusb -v
Bus /dev/usb Device /dev/ugen5.2: ID 13d3:3323 IMC Networks
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x13d3 IMC Networks
idProduct 0x3323
bcdDevice 2.00
iManufacturer 1 Manufacturer Realtek
iProduct 2 RTL8191S WLAN Adapter
iSerial 3 00e04c000001
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 46
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0x80
(Bus Powered)
MaxPower 500mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 4
bInterfaceClass 255 Vendor Specific Class
bInterfaceSubClass 255 Vendor Specific Subclass
bInterfaceProtocol 255 Vendor Specific Protocol
iInterface 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x83 EP 3 IN
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x04 EP 4 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x06 EP 6 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x0d EP 13 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Device Qualifier (for other device speed):
bLength 10
bDescriptorType 6
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
bNumConfigurations 1
Device Status: 0x0000
(Bus Powered)

I'm add options for if_rsu device
/boot/loader.conf
Code:
# Wi-Fi
if_rsu_load="YES"
rsu-rtl8712fw_load="YES"

/etc/rc.conf
Code:
# Wi-Fi
wlans_rsu0="wlan0"
ifconfig_wlan0="WPA SYNCDHCP"

Boot log info related to Wi-Fi:
dmesg | grep -iE "real|rsu|ugen5"
Code:
real memory  = 2147483648 (2048 MB)
atrtc0: <AT realtime clock> port 0x70-0x77 irq 8 on acpi0
re0: <RealTek 8168/8111 B/C/CP/D/DP/E/F/G PCIe Gigabit Ethernet> port 0xe000-0xe0ff mem 0xdfd04000-0xdfd04fff,0xdfd00000-0xdfd03fff irq 19 at device 0.0 on pci2
hdacc0: <Realtek ALC662 rev3 HDA CODEC> at cad 0 on hdac0
hdaa0: <Realtek ALC662 rev3 Audio Function Group> at nid 1 on hdacc0
pcm0: <Realtek ALC662 rev3 (Front Analog)> at nid 27 and 25 on hdaa0
ugen5.1: <Intel EHCI root HUB> at usbus5
ugen5.2: <Manufacturer Realtek RTL8191S WLAN Adapter> at usbus5

But ifcofig has no interface wlan0 and sysctl net.wlan.devices are empty.

How can I get it working?

PS. Also I'm tryin latest -CURRENT, with same results.
 

Alexander88207

Aspiring Daemon

Reaction score: 529
Messages: 754

The rsu(4) driver supports SU chips but not your S chip.

After a search i did not find anything else, i think it looks bad for you.
 
Top