wi-fi AP on ath

urusha

New Member


Messages: 3

Hi, all!
I have freebsd 7.1 on my gateway,samba-server,etc (celeron 1000 and etc) at home. I took TrendNet TEW-443PI with Atheros chip to make AP for my hp 550 with broadcom 4315, and create bridge between my internal rl0 and new ath0.
Well, at first sight all was ok. There was a connection between gateway(192.168.1.1), stationary computer(192.168.1.11), notebook(192.168.1.13) and all other hosts from internet. But there was waves of delay (every 10-15s) in www surfing and when i decided to watch some video on youtube, I got big-big delay. I wasn't able to watch it to the end.
I tried to ping notebook from gateway through ssh

ping 192.168.1.13

and got 70-90% lost packets, and delay in ssh output. Then i tried to ping gateway from notebook (i have kubuntu on it),

ping 192.168.1.1

all was perfect, 0% packets loss. Strange...
Then i tried to ping computers each other at the same time, and got 0% loss from both. So, when i ping gateway from notebook, my internet surfing was ok too. Also all works well if i just download-upload something from-to the gateway or any other server in my network or behind the gateway.
The same time, torrent, dc and samba uploads/downloads are ok without any pings (or other actions).

I tried to play with values from ifconfig -m ath0; tried to change channel, txpower, mtu, make AP without wpa, dhcpd and bridge. It's all the same. No result.
Why notebook is not gilty? I tried to switch to another open network and all worked fine.
It's bad and uncomfortable to run ping for surfing. So, what could be wrong with my AP?

My configuration:
I build kernel with:

device wlan
device wlan_acl
device wlan_ccmp
device wlan_wep
device wlan_tkip
device wlan_xauth
device wlan_scan_sta
device wlan_scan_ap
device ath
device ath_hal
device ath_rate_sample
device if_bridge

My hostapd.conf:

interface=ath0
driver=bsd
logger_syslog=-1
logger_syslog_level=2
logger_stdout=-1
logger_stdout_level=2
debug=0
dump_file=/tmp/hostapd.dump
ctrl_interface=/var/run/hostapd
ctrl_interface_group=0
ssid=urnet
wpa=3
wpa_passphrase=passssword
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP CCMP

and part of rc.conf:

ifconfig_rl0="up"
ifconfig_ath0="mediaopt hostap"
hostapd_enable="YES"
cloned_interfaces="bridge0"
ifconfig_bridge0="addm rl0 addm ath0 up"
ifconfig_bridge0_alias0="inet 192.168.1.1 netmask 255.255.255.0"
dhcpd_enable="YES"
dhcpd_flags="-q"
dhcpd_ifaces="bridge0"
dhcpd_chroot_enable="YES"

also i set sysctl variables
net.link.bridge.pfil_member=0
net.link.bridge.pfil_bridge=0

and... pf is my firewall

Thank you, and sorry for my english.
 
OP
OP
U

urusha

New Member


Messages: 3

I had a look into freebsd 7.2 release notes and noticed there was an update of ath_hal kernel module. After update of my gateway at 2009.05.04 all works fine till now and i'm happy with it:)
 

varda

Active Member

Reaction score: 23
Messages: 113

What's the reason that you enabled dhcp on bridge0 interface (dhcpd_enable="YES" dhcpd_ifaces="bridge0") if you have set IP adress on it directly (ifconfig_bridge0_alias0="inet 192.168.1.1 netmask 255.255.255.0") ??
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,755
Messages: 30,862

varda said:
What's the reason that you enabled dhcp on bridge0 interface (dhcpd_enable="YES" dhcpd_ifaces="bridge0") if you have set IP adress on it directly (ifconfig_bridge0_alias0="inet 192.168.1.1 netmask 255.255.255.0") ??
dhcpd_enable enables the DHCP server, not a DHCP client.
 
Top