why smbd not running on freebsd 13

freyone

New Member


Messages: 3

Code:
root@juggle:~ # service samba_server restart
Performing sanity check on Samba configuration: OK
Stopping winbindd.
smbd not running? (check /var/run/samba4/smbd.pid).
Stopping nmbd.
Performing sanity check on Samba configuration: OK
Starting nmbd.
Starting smbd.
Starting winbindd.
root@juggle:~ #
root@juggle:~ #
root@juggle:~ # service samba_server status
nmbd is running as pid 1035.
smbd is not running.
winbindd is running as pid 1049.
root@juggle:~ #

smb4.conf
Code:
root@juggle:~ # cat /usr/local/etc/smb4.conf
[global]
   printing = bsd
   printcap name = /etc/printcap
   load printers = no
   guest account = guest
   log file = /usr/local/samba/var/log.%m
   log level = 8

[homes]
   comment = Home Directories
   browseable = no
   read only = no
   create mode = 0750

[test]
   comment = test stuff
   path = /dept/mis/home/testacct
   valid users = testacct
   public = no
   writable = yes

[namespace]
   comment = DCE-DFS Global Root 
   path = /...
   public = no
   writable = yes

[oecdfs]
   comment = Corporate Cell
   path = /.../corp.boston.oec.com/fs
   browseable = no
   read only = no
   create mode = 0750

[develdfs]
   comment = Technology Development Cell
   path = /.../devel.boston.oec.com/fs
   browseable = no
   read only = no
   create mode = 0750
[root]
   comment = root's stuff
   path = /home
    public = no
    browseable = yes
    writable = yes
    printable = no
    create mask = 0755
root@juggle:~ #
rc.conf
Code:
root@juggle:~ # cat /etc/rc.conf
hostname="juggle"
ifconfig_em0="DHCP"
sshd_enable="YES"
ntpdate_enable="YES"
ntpd_enable="YES"
powerd_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
zfs_enable="YES"
ifconfig_em1="inet 192.168.56.3 netmask 255.255.255.0"
nmbd_enable="YES"
smbd_enbale="YES"
winbindd_enable="YES"
samba_enable="NO"
samba_server_enable="YES"
root@juggle:~ #
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,991
Messages: 36,924

Code:
nmbd_enable="YES" 
smbd_enbale="YES" 
winbindd_enable="YES" 
samba_enable="NO"
Remove these from rc.conf, you only need samba_server_enable="YES".
 
OP
F

freyone

New Member


Messages: 3

not worked as SirDice suggestion,the console printout :

1619140082073.png
 

VladiBG

Daemon

Reaction score: 482
Messages: 1,071

In FreeBSD there's no "guest" user, you can use "nobody" for that.
In FreeBSD the log files should be placed under /var/log if you need you can separate them in sub directories and grant proper permission to that directories to the user under which the service is running so it can create the log files.

So you can create a directory /var/log/samba/ then change your smb4.conf log file = /var/log/samba/log.%m this will fix the error that you get about missing /usr/local/samba/var/ directory

Then change your smb4.conf guest account = nobody which is valid user.
 
Top