Where to set charset in Filezilla?

Hi all,

I am wondering if anybody could help me troubleshoot an issue I have on my system related to charset.

System is running FreeBSD 11 p9 and I setup xrdp and Xfce - the latter is running version 4.12.
When I use the File Manager app in Xfce, I can see all special characters, I have some folders named used accentuated characters as well as special characters like '<<' '>>'.
I have no issue listing and browsing folders and opening up files.

When launching filezilla under Xfce and without even trying to connect anywhere, I have problems browsing local folders containing special characters.

Obviously, when I try to connect to a remote server with folders using these special characters, the download fails saying it cannot open that file.

If I try from a different operating system with a default filezilla install, I can browse remotely the same server and can download without any issue.

As I cannot even try browsing local folders on my FreeBSD system through filezilla but I can through the File Manager, would anybody know if there is any special settings anywhere in filezilla to get this working?

Note: renaming files/folders is not an option.

Any help would be welcome.

It looks to be a known issue issue.
Also, I don't know whether Filezilla uses Glib, but I remember playing with G_FILENAME_ENCODING and G_BROKEN_FILENAMES environment variables for the same purposes long time ago.