• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

When I am lost I come here for help and I need your help with CodeBlocks

golpemortal

Member

Thanks: 1
Messages: 48

#1
Since I updated my FreeBSD 11 updates now I have issues with CodeBlocks running here is what I get
Code:
$ codeblocks
Starting Code::Blocks Release 16.01  rev 10692 Sep  2 2017, 19:11:39 - wx2.8.12 (FreeBSD, unicode) - 64 bit
Initialize EditColourSet .....
Initialize EditColourSet: done.
Abort trap (core dumped)
I got another laptop and did a fresh installed FreeBSD 11 and still cannot open Code Block released 16.01

Please help me fix this problem an I ran out of ideas....
 
Last edited by a moderator:

golpemortal

Member

Thanks: 1
Messages: 48

#4
Ok, so far no solutions is giving and the updated version does not work; still same error
Will Codeblocks works on FreeBSD again ?
Does anyone have a temp fix for codeblocks?
 

lebarondemerde

Aspiring Daemon

Thanks: 372
Messages: 983

#5
Hi.

Looking at the bug reports, the current version have supposedly fixed PACKAGES available by the maintainer, outside of the FreeBSD infra (I don't know why). You would need to add that as a pkg repository.

Also, there is a new -devel port available in another (recent) bug report by the same maintainer of the previous one; however no one is currently assigned to handle that. The maintainer does no see to be a FreeBSD dev.

For the new -devel port you could either get it and add to your ports tree, and start using it now (assuming it is properly working); or ask in the ports mailing lists or at #freebsd-ports at Freenode, to try to get someone assigned to handle that new port.

Cheers!