What's the deal with dolphin and MTP devices?

I understand that KDE's file manager x11-fm/dolphin is supposed to be able to work with MTP devices like an android phone (set up for MTP file transfer) plugged into the USB port. The support for this seems to come from devel/kio-extras which has an MTP port option that is enabled by default and pulls in multimedia/libmtp as a dependency.

Running mtp-detect (which is installed as part of multimedia/libmtp) from the shell happily finds the plugged in device. Yet the device does not show up in dolphin and no mtp: URL I have tried succeeds in accessing the device. So what's missing here?

Hardware supports seems to be the responsibility of devel/kf5-solid which used sysutils/hal in the past, which is now gone for good. Now sysutils/bsdisks is used for detecting devices like harddisks and optical drives, but what about MTP devices that are by nature not even block oriented? I have the feeling that there are some bits and pieces missing here from either devel/kf5-solid and/or sysutils/bsdisks.
When I get errors from Dolphin mounting something, they were something from/about gvfs-fuse, iirc.
Maybe this is what is missing or needs to be configured?
When I get errors from Dolphin mounting something, they were something from/about gvfs-fuse, iirc.
gvfs is GNOME's way of doing things but not what KDE is or should be using. KDE uses devel/kf5-solid as a framework for device integration. A quick look at the source suggests that it indeed has some kind of udev backend for handling MTP devices, which probably requires such devices to be reported the udev way. My guess is that detecting and reporting MTP devices would be the task of sysutils/bsdisks but that such support does not currently exist.

Further reading:
Unfortunately, all this makes additions to Why FreeBSD is not ready for desktop. Together with Bluetooth not working easily out of the box & incomplete WLAN beyond 802.11a.
This is what the README file of kio-mtp (part of devel/kio-extras) has to say:
kio-mtp: KIO slave to access MTP devices

This KIO slave enables KDE applications to access
files stored on devices that provide access to them
via the MTP protocol.


To list all currently connected devices, just type
mtp:/ in the addressbar of your preferred KDE filebrowser.

Using the scheme mtp:udi=<udi> you can access the
device using their unique device identifier as provided
by Solid.

A Device Notificator Desktop-File is also provided that
enables you to access the device directly from there.
So I tried entering "mtp:/" into the address bar of dolphin and it comes up empty, which coincides with the output of solid-hardware5 list that only shows my various harddisk partitions, CD drive and stuff from /etc/fstab but not the connected android phone.

mtp-detect however has no problem in finding the device:
libmtp version: 1.1.18

Listing raw device(s)
Device 0 (VID=04e8 and PID=6860) is a Samsung Galaxy models (MTP).
   Found 1 device(s):
   Samsung: Galaxy models (MTP) (04e8:6860) @ bus 0, dev 3