what a hell is ghostscript8-8.62_5 ?

zeiz

Aspiring Daemon

Reaction score: 57
Messages: 691

Cannot install KDE from new DVD 6.4. First of all it tries to install ghostscript8-8.62_5 then fails and then KDE is not installed :\
Even Gnome first failed to install (never ever happened!).
Well installation media could be...though md5 and sha256 both are OK. I tried to install it from ports. "File doesn't exist..." I went to ports and indeed instead of ghostscript8-8.62_5 there is just ghostscript8 in Latest.
However the correct file is in many other places (and I found even version 8.63) BUT none wants to be copied to my HDD :(
That's too much: DVD failed and ports failed on the same postscript print helper, at the same time and place.
What a hell is this ghost �e if entire KDE depends on it?
 
OP
zeiz

zeiz

Aspiring Daemon

Reaction score: 57
Messages: 691

Thanks but I didn't find ghostscript-gpl in Latest.
I installed ghostscript8-8.62_5 by
#pkg_add -r ghostscript8
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6.4-release/Latest/ghostscript8.tbz... Done.
pkg_add: package 'ghostscript8-8.62_5' conflicts with ghostscript7-nox11-7.07_20
pkg_add: please use pkg_delete first to remove conflicting package(s) or -f to force installation
kerzpp2# pkg_delete ghostscript7-nox11-7.07_20
kerzpp2# pkg_add -r ghostscript8
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6.4-release/Latest/ghostscript8.tbz... Done.

A question: I don't really need any postscript programs since my usb printers don't have ppd and they don't work under FreeBSD.
So I didn't choose for installation neither ghostscript7 nor ghostscript8 those was added as dependencies and moreover KDE couldn't be installed without second one. If so why conflicting dependencies both are presented on the DVD?
 
Top