Webcam detected by skype for web but black box without images.

fufukauliza

Member

Reaction score: 3
Messages: 36

Hello to all,
i wanted to use skype so i installed chromium to use skype for web.
Failing to make him recognize webcam and microphone I followed this guide: https://www.davidschlachter.com/misc/freebsd-webcam-browser.
My Microsoft lifecam 5000 hd works fine, in fact chromium browser was detected by webcamtest.com site.
Unfortunately skype for web also by authorizing the site to use the webcam and microphone detects the model but shows me only a black box.

Any suggestions on how to do it?

Thanks.
 

grahamperrin

Daemon

Reaction score: 695
Messages: 2,213

… chromium to use skype for web. …

Not the answer that you want, but have you tried Firefox with any of the Skype for Web-oriented extensions?

I'm aware of two but (sorry) at the time of writing I can't test properly to tell whether they're enough to enable video calling:
 

Geezer

Aspiring Daemon

Reaction score: 379
Messages: 669

What version of Freebsd are you using?

I found that skype in chromium magically started working fully once I had upgraded to 13.0.
 

grahamperrin

Daemon

Reaction score: 695
Messages: 2,213

… skype for web … black box. …

Chromium 92.0.4515.159_2

HP HD Webcam [Fixed]

1632718124028.png

USB camera (Philips 27P12 display)

1632718398781.png

Firefox 92.0.1,2 with the web.skype.com for Firefox extension

Skype for Web

1632718717189.png

<https://teams.live.com/>

1632719895181.png



pwcview -d /dev/video0 also confirms that FreeBSD 14.0-CURRENT works with the HP camera.
 
OP
fufukauliza

fufukauliza

Member

Reaction score: 3
Messages: 36

Chromium 92.0.4515.159_2

HP HD Webcam [Fixed]

View attachment 11477

USB camera (Philips 27P12 display)

View attachment 11478

Firefox 92.0.1,2 with the web.skype.com for Firefox extension

Skype for Web

View attachment 11479

<https://teams.live.com/>

View attachment 11480



pwcview -d /dev/video0 also confirms that FreeBSD 14.0-CURRENT works with the HP camera.

Hi,

The webcam is also recognized to me but it remains as in your screenshot: webcam model recognized and black box.
 
OP
fufukauliza

fufukauliza

Member

Reaction score: 3
Messages: 36

When I run skype and go to the settings for audio and video, I get the black box too.

But if I actually call someone, video works perfectly.

Very interesting! I will try a video call with a friend as soon as possible.

Thanks.
 
Top