Solved Web failure after Parallels change

carlcaulkett

Member

Reaction score: 3
Messages: 85

macOS 10.13.3 High Sierra
Parallels 13
FreeBSD 11.1

Hello. My guest FreeBSD OS was working quite happily with a Shared Network config in Parallels. I foolishly changed the Parallels config to one of the Bridged options which cause FreeBSD not to connect to the internet. I then changed the Parallels config back to Shared and restarted the VM. Now I cannot connect to the web. I get the error: Error resolving `golang.org`: Non-recoverable failure in name resolution.
I also tried pinging Google (8.8.8.8) from the command line. That fails with: ping: send to: no route to host.

What can I do within FreeBSD to restore my internet connectivity? The Apple Mac host OS is connecting just file.
 
Last edited:

trev

Aspiring Daemon

Reaction score: 141
Messages: 752

What is the output of netstat -rn ?
What is the content of /etc/resolv.conf ?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,298
Messages: 29,745

Since nothing changed on the FreeBSD VM and you did all the changes on the host, which broke things, the most obvious place to look is on the host, not the VM.
 
OP
OP
carlcaulkett

carlcaulkett

Member

Reaction score: 3
Messages: 85

Since nothing changed on the FreeBSD VM and you did all the changes on the host, which broke things, the most obvious place to look is on the host, not the VM.
I've sent a crash report into Parallels so that their next level support team can take a look at it. It's just a question of time, I guess, unless I, or more likely someone else, has a bright idea!
 

ShelLuser

Son of Beastie

Reaction score: 1,703
Messages: 3,516

Solely based on the output above it would appear that you disabled your main network adapter. ifconfig -a should also show as much. So all there is left is the local loopback (lo0) and as its name implies that's only used for local connections.
 
OP
OP
carlcaulkett

carlcaulkett

Member

Reaction score: 3
Messages: 85

Solely based on the output above it would appear that you disabled your main network adapter. ifconfig -a should also show as much. So all there is left is the local loopback (lo0) and as its name implies that's only used for local connections.
Thanks for the reply.

This is my ifconfig -a. I'm not sure what it is telling me!

Screen Shot 2018-03-21 at 12.57.40.png


Any idea what, if anything, I can do within the FreeBSD OS to fix this?
 
OP
OP
carlcaulkett

carlcaulkett

Member

Reaction score: 3
Messages: 85

Solely based on the output above it would appear that you disabled your main network adapter. ifconfig -a should also show as much. So all there is left is the local loopback (lo0) and as its name implies that's only used for local connections.
It's worth pointing out that, at no stage did I deliberately or explicitly permanently disable my main network adaptor. If it has happened, it must have been as a by-product of my switching the Parallels networking option from Shared to Bridged and back again to Shared.
 

ShelLuser

Son of Beastie

Reaction score: 1,703
Messages: 3,516

Assign an IP address to em0 and optionally reset your routing table. The how depends on how you set this up in the first place. Either through DHCP (see dhclient) or static (see /etc/rc.conf).
 
OP
OP
carlcaulkett

carlcaulkett

Member

Reaction score: 3
Messages: 85

I tried changing /etc/rc.conf by adding the line

Screen Shot 2018-03-21 at 13.34.33.png


This resulted in the ifconfig output...

Screen Shot 2018-03-21 at 13.32.58.png


Still no internet access though.

I'm reasonably certain that 10.211.55.15 is my guest IP address from checking arp -an in my host macOS.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,298
Messages: 29,745

You may have also changed the network adapter type, VM software typically supports a number of network devices.
 
OP
OP
carlcaulkett

carlcaulkett

Member

Reaction score: 3
Messages: 85

I've got options similar to this...

Screen Shot 2018-03-21 at 14.32.38.png


Yes. As I mentioned, I changed the Type setting from Shared Network to Bridged and when that didn't work, I changed it back to Shared Netword. I haven't touched the NIC Type or the MAC Address settings.
 
OP
OP
carlcaulkett

carlcaulkett

Member

Reaction score: 3
Messages: 85

I can also confirm that the MAC address in my Parallels settings matches the ether and hwaddr addresses given by ifconfig in my FreeBSD.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,298
Messages: 29,745

Which network card is mentioned in /etc/rc.conf?
 
OP
OP
carlcaulkett

carlcaulkett

Member

Reaction score: 3
Messages: 85

This is my /etc/rc.conf. No sign of a network card. There wasn't one mentioned when it was working.

Screen Shot 2018-03-21 at 15.00.38.png
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,298
Messages: 29,745

Remove the vidcontrol(1) command from /etc/rc.conf, it doesn't belong there.

I suggest changing the network settings to this:
Code:
ifconfig_DEFAULT="DHCP"
The _DEFAULT will pick the first available network card. Then it won't matter if you change the NIC type in Parallels.
 
OP
OP
carlcaulkett

carlcaulkett

Member

Reaction score: 3
Messages: 85

Remove the vidcontrol(1) command from /etc/rc.conf, it doesn't belong there.
Sorry. Someone (it may have been you!) did warn me against having anything else but variable assignments in /etc/rc.conf, but did I listen??!!

I suggest changing the network settings to this:
Code:
ifconfig_DEFAULT="DHCP"
The _DEFAULT will pick the first available network card. Then it won't matter if you change the NIC type in Parallels.
I've just rebooted the VM and it still isn't working. Does the fact I am connecting using a WiFi USB dongle to a wireless network make any difference?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,298
Messages: 29,745

Not for the VM, all the VM sees is a virtual interface, not a real one. It does matter on the host though, your shared or bridged network needs to be connected to your wireless network.
 
OP
OP
carlcaulkett

carlcaulkett

Member

Reaction score: 3
Messages: 85

ifconfig is no longer showing the inet entry that I added in /etc/rc.conf earlier...

Before...

Screen Shot 2018-03-21 at 13.32.58.png


Now...

Screen Shot 2018-03-21 at 15.34.18.png
 
OP
OP
carlcaulkett

carlcaulkett

Member

Reaction score: 3
Messages: 85

I've now changed my /etc/rc.conf to...

Screen Shot 2018-03-21 at 16.50.23.png


So that my ipconfig again shows the inet entry. Still can't connect though...

Screen Shot 2018-03-21 at 16.53.25.png
 
OP
OP
carlcaulkett

carlcaulkett

Member

Reaction score: 3
Messages: 85

I amended the /etc/rc.conf slightly.

The last line now reads ifconfig_em0="inet 10.211.55.15 netmask 255.255.255.0"

I still cannot connect but now the error is given as "Could not connect: Network is unreachable."
 
OP
OP
carlcaulkett

carlcaulkett

Member

Reaction score: 3
Messages: 85

Interestingly my prompt has returned to displaying correctly.

Screen Shot 2018-03-21 at 17.48.29.png

Screen Shot 2018-03-21 at 17.50.00.png


Presumably, some of the changes described above have caused this. Perhaps this symptom can shed some light on the connectivity problem.
 

ShelLuser

Son of Beastie

Reaction score: 1,703
Messages: 3,516

"Network unreachable" hints at a broken routing table, something quite well explained in chapter 11.5 of the FreeBSD handbook.

So simply determine your gateway and set up a defaultrouter="" entry in /etc/rc.conf. Or use the route command I suppose.
 
Top