WARNING: the system temperature is too high, and the system shuts down!

teo

Aspiring Daemon

Reaction score: 29
Messages: 616

Attempting to update the vulnerable ports detected by the system through recompilation, the fan activity begins to scream, and the temperature begins to rise, automatically shutting down the system. Any solutions?


$ sysctl -a | grep temperature
Code:
hw.acpi.thermal.tz0.temperature: 46,1C
$
$ uname -mrs
Code:
FreeBSD 12.1-RELEASE-p9 amd64
$
 

ekvz

Well-Known Member

Reaction score: 180
Messages: 312

Generic recommendations: Clean out dust from the ventilation system and maybe replace the thermal paste on your CPU (i guess the sensor in question is related to the CPU?).

Side note: 46,1C doesn't seem to be all that bad but then the practical range pretty much depends on which CPU you are running.
 

mjollnir

Daemon

Reaction score: 756
Messages: 1,206

Carefully clean the heat exchanger. You have to take out the fan if you want to use a hoover, else it can burn through (a fan turns into a generator when you blow into it).
 
OP
T

teo

Aspiring Daemon

Reaction score: 29
Messages: 616

As you are attributing the problem to vulnerable ports, I'm not sure if you need a hotfix or just a cool answer.
I was trying to update this vulnerable multimedia/gstreamer-ffmpeg port that the system detects, and in the recompilation by the portupgrade -R command, it does not complete the task because it automatically turns off the Laptop due to the processing going up to 100% and the high activity of the fan raising the temperature

mjollnir said:
Carefully clean the heat exchanger. You have to take out the fan if you want to use a hoover, else it can burn through (a fan turns into a generator when you blow into it).
I cleaned up a few weeks ago back.

ekvz said:
Generic recommendations: Clean out dust from the ventilation system and maybe replace the thermal paste on your CPU (i guess the sensor in question is related to the CPU?).

Side note: 46,1C doesn't seem to be all that bad but then the practical range pretty much depends on which CPU you are running.
46,1C is the temperature of the Laptop without activity, I already cleaned a week ago back, and replaced the thermal paste.
 

ekvz

Well-Known Member

Reaction score: 180
Messages: 312

I was trying to update this vulnerable multimedia/gstreamer-ffmpeg port that the system detects, and in the recompilation by the portupgrade -R command, it does not complete the task because it automatically turns off the Laptop due to the processing going up to 100% and the high activity of the fan raising the temperature
In this case it comes down to either your cooling system not working in an optimal way (clean it) or the shutdown temperature being unreasonable (be very careful with adjusting this as the CPU can likely get hot enough to basically melt your laptop).
 

vigole

Well-Known Member

Reaction score: 584
Messages: 491

46 °C is high for HDD, but not for CPU. Also, the normal range of CPU's temperature while it's operating is depends on many factors such as number of cores and manufacturer. I didn't mention clock speed, sensor, fan, etc. because for the most part, you have control over it e.g. dev.cpu.*.freq in sysctl.conf.
 

kpedersen

Daemon

Reaction score: 1,053
Messages: 2,055

Is the machine fine during idle?

Perhaps just instruct powerd to keep it at a lower clock speed. It will take longer to compile the ports but it will actually compile the ports rather than shutting down.
 

vigole

Well-Known Member

Reaction score: 584
Messages: 491

I like to have manual control over CPU clock. This is my procedure. The script part is very amateurish (it's even not a script IMHO!) and you should write a well-though one for yourself. I just wanted to present you the whole shebang.
Personal setting/script for my Intel64:

/boot/loader.conf
Code:
coretemp_load="YES"
/etc/sysctl.conf
Code:
dev.cpu.0.freq=800
cpu.sh
Code:
#!/bin/sh
case $1 in
22) sysctl dev.cpu.0.freq=2200;;
20) sysctl dev.cpu.0.freq=2000;;
19) sysctl dev.cpu.0.freq=1900;;
18) sysctl dev.cpu.0.freq=1800;;
17) sysctl dev.cpu.0.freq=1700;;
16) sysctl dev.cpu.0.freq=1600;;
15) sysctl dev.cpu.0.freq=1500;;
14) sysctl dev.cpu.0.freq=1400;;
13) sysctl dev.cpu.0.freq=1300;;
12) sysctl dev.cpu.0.freq=1200;;
11) sysctl dev.cpu.0.freq=1100;;
10) sysctl dev.cpu.0.freq=1000;;
9)  sysctl dev.cpu.0.freq=900;;
8)  sysctl dev.cpu.0.freq=800;;
00) echo "22 20 19 18 17 16 15 14 13 12 11 9 8 00 0 _ ";;
0)  sysctl -a | grep temper | awk '{print $2}' | sort -ur;;
esac
sysctl dev.cpu.0.freq
sysctl -a | grep temper | awk '{print $2}' | sort -ur | head -n 1
 

shkhln

Daemon

Reaction score: 663
Messages: 1,647

46,1C is the temperature of the Laptop without activity
FYI, the cpu temp is represented by a different sysctl. You don't want to measure it at idle either, frequency scaling makes this completely meaningless.

I already cleaned a week ago back, and replaced the thermal paste.
If quality of your posts is any indicator, this is probably the culprit.
 
OP
T

teo

Aspiring Daemon

Reaction score: 29
Messages: 616

I like to have manual control over CPU clock. This is my procedure. The script part is very amateurish (it's even not a script IMHO!) and you should write a well-though one for yourself. I just wanted to present you the whole shebang.
Personal setting/script for my Intel64:

/boot/loader.conf
Code:
coretemp_load="YES"
/etc/sysctl.conf
Code:
dev.cpu.0.freq=800
cpu.sh
Code:
#!/bin/sh
case $1 in
22) sysctl dev.cpu.0.freq=2200;;
20) sysctl dev.cpu.0.freq=2000;;
19) sysctl dev.cpu.0.freq=1900;;
18) sysctl dev.cpu.0.freq=1800;;
17) sysctl dev.cpu.0.freq=1700;;
16) sysctl dev.cpu.0.freq=1600;;
15) sysctl dev.cpu.0.freq=1500;;
14) sysctl dev.cpu.0.freq=1400;;
13) sysctl dev.cpu.0.freq=1300;;
12) sysctl dev.cpu.0.freq=1200;;
11) sysctl dev.cpu.0.freq=1100;;
10) sysctl dev.cpu.0.freq=1000;;
9)  sysctl dev.cpu.0.freq=900;;
8)  sysctl dev.cpu.0.freq=800;;
00) echo "22 20 19 18 17 16 15 14 13 12 11 9 8 00 0 _ ";;
0)  sysctl -a | grep temper | awk '{print $2}' | sort -ur;;
esac
sysctl dev.cpu.0.freq
sysctl -a | grep temper | awk '{print $2}' | sort -ur | head -n 1
Thanks for the comments, in those files mentioned I have:

# vi /boot/loader.conf
Code:
kern.vty=vt
snd_hda_load="YES"
snd_driver_load="YES"
fuse_load="YES"
sound_load="YES"
coretemp_load="YES"
# vi /etc/sysctl.conf
Code:
net.local.stream.recvspace=65536
net.local.stream.sendspace=65536

kern.ipc.shm_allow_removed=1
vfs.usermount=1
kern.coredump=0
The cpu.sh file is that the directory? Or the entire directory to create is /etc/cpu.sh ?
 
OP
T

teo

Aspiring Daemon

Reaction score: 29
Messages: 616

FYI, the cpu temp is represented by a different sysctl. You don't want to measure it at idle either, frequency scaling makes this completely meaningless.



If quality of your posts is any indicator, this is probably the culprit.
That doesn't happen with other systems called Linux or windows installed on this old Laptop. The FreeBSD system just started testing on this old Laptop, and apparently it turns off automatically when you want to recompile a port trying to update raising the resources of the hardware to 100%.
 

ekvz

Well-Known Member

Reaction score: 180
Messages: 312

That doesn't happen with other systems called Linux or windows installed on this old Laptop. The FreeBSD system just started testing on this old Laptop, and apparently it turns off automatically when you want to recompile a port trying to update raising the resources of the hardware to 100%.
This is not overly surprising as those systems usually just install binary packages (Windows sure doesn't compile anything and source based Linux distributions can easily be counted on one hand). Actually compiling sources is bound to be extremely CPU intensive (there is applications that literally take hours at 100% CPU utilization to compile even on quite decent hardware). The reason for those systems not triggering the shutdown is probably just them not stressing the CPU all that much. I don't know what is responsible for setting the cut off temperature but i guess it actually comes from the BIOS so it would likely be the same across all of those systems.

If you absolutely don't want to investigate the base cause for your system overheating (which quite likely comes down to faulty cooling - if one is to rule out a general design error or wrong cutoff temperature) throttling your CPU as demonstrated by vigole seems like the most reasonable course of action.
 

T-Daemon

Daemon

Reaction score: 495
Messages: 1,041

That doesn't happen with other systems called Linux or windows installed on this old Laptop.
Which vendor/model is this laptop?

Not problem related:
I was trying to update this vulnerable multimedia/gstreamer-ffmpeg port that the system detects
Why are you trying to update that port? You asked about vulnerabilities in two ports in Thread 76966, one of them gstreamer-ffmpeg-0.10.13_7, but that port hasn't been updated since 7 months, graphics/jasper has. The currently installed package on your system is the same as the port.
 

shkhln

Daemon

Reaction score: 663
Messages: 1,647

Actually compiling sources is bound to be extremely CPU intensive (there is applications that literally take hours at 100% CPU utilization to compile even on quite decent hardware).
In reality compilation is pretty tame. For example, my i5 4670 stays around 55 °C with compilation vs 60 °C with video encoding. Specialized CPU benchmarks (Prime95, etc.) will get it into 70+ °C territory.
 

ekvz

Well-Known Member

Reaction score: 180
Messages: 312

In reality compilation is pretty tame. For example, my i5 4670 stays around 55 °C with compilation vs 60 °C with video encoding. Specialized CPU benchmarks (Prime95, etc.) will get it into 70+ °C territory.
It somewhat depends on the codebase/build system settings (and of course on having a functional cooling system) i guess. Actually the sources i am trying to get to build right now are very good at keeping all cores at a constant 100%. Compiling lot's of small sources files tends to be way less intensive from my experience though.

The box that i am compiling on has been at 100% pretty much for days now (every try to takes about 4h and it seems the code is VERY fragile...). Cores all showing something around 75C. It's not like i've taken much care with this system though so it might be a bit lower if i was to replace the thermal paste but i doubt any kind of benchmark would manage to push the temperature much higher.
 
OP
T

teo

Aspiring Daemon

Reaction score: 29
Messages: 616

In reality compilation is pretty tame. For example, my i5 4670 stays around 55 °C with compilation vs 60 °C with video encoding. Specialized CPU benchmarks (Prime95, etc.) will get it into 70+ °C territory.
Look at the almost 100% increase of the resource of the Laptop, trying to update the vulnerable multimedia/gstreamer-ffmpeg port on its recompilation, and why the laptop automatically shuts down.

Screen_2020-09-13_17-22-10.png


Screenn_2020-09-13_17-42-01.png
 

ekvz

Well-Known Member

Reaction score: 180
Messages: 312

I don't know what's the point in posting those screenshots is. It's already been established that your CPU is getting hot. shkhln simply shared his opinion that this shouldn't happen during compilation which i somewhat disagree with. It doesn't really matter anyways as it should not get to the point where your system shuts down. So if you think your cooling is 100% alright or don't want to deal with it any further your only option is to throttle the CPU (or install something that automatically throttles it when it gets to hot).
 

vigole

Well-Known Member

Reaction score: 584
Messages: 491

Can you reduce your CPU frequency? I think your CPU freq. has set to max, maybe it's working on Turbo Speed. For example an Intel Core i7-2670QM has the max Clockspeed of 2.2 GHz. But it also has the Turbo Speed technology. That means, it's possible that your CPU is working at 3.1 GHz speed. It's going to get very warm soon. It doesn't matter how many cores are engaged at any given time.
 

shkhln

Daemon

Reaction score: 663
Messages: 1,647

It somewhat depends on the codebase/build system settings (and of course on having a functional cooling system) i guess. Actually the sources i am trying to get to build right now are very good at keeping all cores at a constant 100%.
In my case the difference depends on AVX usage, not all 100% workloads are created equal.

It's already been established that your CPU is getting hot. shkhln simply shared his opinion that this shouldn't happen during compilation
No, I just wanted to mention this is not the most effective space heating method.
 

shkhln

Daemon

Reaction score: 663
Messages: 1,647

I think your CPU freq. has set to max, maybe it's working on Turbo Speed. For example an Intel Core i7-2670QM has the max Clockspeed of 2.2 GHz. But it also has the Turbo Speed technology. That means, it's possible that your CPU is working at 3.1 GHz speed. It's going to get very warm soon.
Turbo boost should throttle itself automatically.
 
OP
T

teo

Aspiring Daemon

Reaction score: 29
Messages: 616

Can you reduce your CPU frequency?
I have no idea, looking at the information you posted, what would be the procedure?

vigole said:
I think your CPU freq. has set to max, maybe it's working on Turbo Speed. For example an Intel Core i7-2670QM has the max Clockspeed of 2.2 GHz. But it also has the Turbo Speed technology. That means, it's possible that your CPU is working at 3.1 GHz speed. It's going to get very warm soon. It doesn't matter how many cores are engaged at any given time.
This happens when you try to compile or recompile a port on FreeBSD, for example, when watching video on youtube, the consumption of laptop resources is high. In case there is no solution, with which more powerful CPU would be compatible with the hardware?
 

vigole

Well-Known Member

Reaction score: 584
Messages: 491

teo I have same problem with both my laptops. I hate laptops! the only way I could managed my situation, very similar to yours (compile, video, etc):
reducing my CPU frequency to 800GHz. With this setting my CPU temperature is ranging from 40 to 65 in winter. 40 is the lowest I get and only on FreeBSD. Windows and most of Linux distro tend to press more pressure on my CPU. In summer, things are getting more complicated. As you may already guess, I hate summer too!
 
Top