Wacom Intuos Not Working in FreeBSD 13.0-RELEASE

rhysday

New Member


Messages: 14

Hi, I tried following the instructions here but pen/tablet is not working at all:

I did everything except compile xorg-server with Hal enabled, as Hal backend has been completely removed from the port as it's depreciated. So not sure how I would go about this?

I have webcamd, libwacom, xf86-input-wacom and xorg-server (without Hal) installed.

/boot/loader.conf:
Code:
cuse_load="YES"
/etc/rc.conf:
Code:
webcamd_enable="YES"
wacom_enable="YES"
User added to webcamd group.

I also tried to enable evdev support by adding the following to /etc/sysctl.conf
Code:
kern.evdev.rcpt_mask=6
When I run xsetwacom --list I get the result:
Code:
wacom stylus id: 6 type: STYLUS
wacom eraser id: 7 type: ERASER
wacom pad id: 8 type: PAD
 
OP
R

rhysday

New Member


Messages: 14

Also tried uninstalling:
xf86-input-wacom-0.39.0_2

And installing:
xf86-input-evdev

Doesn't fix anything.
 

dieselriot

Member

Reaction score: 23
Messages: 89

Have you made sure webcamd is attached to the wacom?
#webcamd -d ugenx.y

I had this problem with a joypad that uses webcamd but haven't tried with an wacom. I'll ask my girlfriend to bring hers over and see if I can get it to work. Would be pretty cool.
 

cmoerz

Member

Reaction score: 36
Messages: 90

What does you Xorg.log say? My Intuos S is still attached to a 12.2, but X11 at least clearly states what it's doing:
Code:
[    35.940] (II) config/udev: Adding input device Wacom Intuos S Pen (/dev/input/event10)
[    35.940] (**) Wacom Intuos S Pen: Applying InputClass "evdev tablet catchall"
[    35.940] (**) Wacom Intuos S Pen: Applying InputClass "Wacom USB tablet class"
[    35.940] (**) Wacom Intuos S Pen: Applying InputClass "Wacom tablet class"
[    35.940] (II) LoadModule: "wacom"
[    35.940] (II) Loading /usr/local/lib/xorg/modules/input/wacom_drv.so
[    35.947] (II) Module wacom: vendor="X.Org Foundation"
[    35.947]    compiled for 1.20.11, module version = 0.39.0
[    35.947]    Module class: X.Org XInput Driver
[    35.947]    ABI class: X.Org XInput driver, version 24.1
...

What I noticed with my tablet - it needs to be attached before the system boots. If I unplug it, no amount of plugging it back in helps - it doesn't get initialized properly anymore. Always needs a reboot to make it go again.
 
OP
R

rhysday

New Member


Messages: 14

Alright so I'm trying to get it to work via evdev though I noticed after reinstalling xf86-input-wacom it gives a note "moused may interfere with tablet input by attaching to fake /dev/ums*. To prevent that add a usb_quirk then detach and attach the tablet."
So I added usb_quirk_load="YES" to loader.conf... but I have no idea how to continue adding a usb_quirk?documentation seems limited. Looking at the xorg.0.log I've noticed both my mouse and wacom share event0? maybe conflict?

I've also copied the sample wacom.conf to /usr/local/etc/X11/xorg.conf.d/
Looks like I can change event numbers and what not

Xorg.0.log file attached.
 

Attachments

  • Xorg.0.log.txt
    27.8 KB · Views: 14

dieselriot

Member

Reaction score: 23
Messages: 89

I got it to work on 13.0-RELEASE but to be honest I don't know what else to tell you. Because all I had to do was issue the command I mentioned before and it started working. It doesn't work without it i.e. webcamd won't attach to it without intervention. You can also set it up on your rc.conf:

webcamd_flags="-d ugenx.y"

This is the device I tried, for reference:

ugen0.5: <Wacom Co.,Ltd. Intuos5 touch S> at usbus0

Maybe if you provide the exact error you got when trying the command we can help you further.
 
OP
R

rhysday

New Member


Messages: 14

Running dmesg | grep -i wacom
gives me ugen1.2<Wacm etc etc> at usbus1

Then when I run webcamd -d ugen1.2
I get:
webcamd 21474 - - webcamd: webcamd: illegal user name
 

Phishfry

Beastie's Twin

Reaction score: 2,646
Messages: 5,561

Sounds like your webcamd user/permissions are not correct.
When I look at the documents on the wacom site it says xf86-input-evdev is depreciated and they say use xf86-input-wacom. This is for Linux but I believe it is relevant.
 

dieselriot

Member

Reaction score: 23
Messages: 89

I can confirm that I don't have xf86-input-evdev on my system, only xf86-input-wacom. From that error, it really sounds like there's something wrong with your webcamd install because the user and group should be created automatically.

What I noticed with my tablet - it needs to be attached before the system boots. If I unplug it, no amount of plugging it back in helps - it doesn't get initialized properly anymore. Always needs a reboot to make it go again.

It's probable that in your setup webcamd is attaching to it at boot time. If you unplug it, manually reattaching should make it work after plugging it back.
 
OP
R

rhysday

New Member


Messages: 14

Yea it definitely seems to be a problem with webcamd. Someone had very similar problem in this thread:

So I tried the same fix:
cd /usr/ports/multimedia/webcamd
make deinstall
make "WITHOUT=HAL" "WITH=VT_CLIENT VT_SERVER" install clean

"The next command fixes the issue of user databases being out of sync."
/usr/sbin/pwd_mkdb -p /etc/master.passwd


But still not working! ...getting closer to the cause at least.
 
OP
R

rhysday

New Member


Messages: 14

When I run webcamd -d ugen1.2:
"webcamd 2243 - - webcamd: webcamd: illegal user name"

My user is added to webcamd, video, operator and wheel group
 

Tieks

Active Member

Reaction score: 107
Messages: 249

rhysday said:
webcamd: illegal user name

It says that webcamd is an illegal user name. Is webcamd indeed in /etc/passwd? Check with cat /etc/passwd | grep webcamd.
Normally you start webcamd as a daemon with webcamd_enable="YES" in /etc/rc.conf. What happens when you run it like this: /usr/local/sbin/webcamd -i 0 -d ugen1.4 -B -U webcamd -G webcamd?
 
OP
R

rhysday

New Member


Messages: 14

cat /etc/passwd | grep webcamd gives no result.

I already have webcamd_enable="YES" in /etc/rc/conf

/usr/local/sbin/webcamd -i 0 -d ugen1.4 -B -U webcamd -G webcamd gives the same illegal user name error
 

Tieks

Active Member

Reaction score: 107
Messages: 249

rhysday said:
cat /etc/passwd | grep webcamd gives no result

Then user webcamd does not exist. You need to create that user account first with something like # pw useradd -n webcamd -c 'webcamd user' -d /var/empty -s /usr/sbin/nologin -w no, see man pw for details. When finished, try running webcamd again.
 
OP
R

rhysday

New Member


Messages: 14

Then user webcamd does not exist. You need to create that user account first with something like # pw useradd -n webcamd -c 'webcamd user' -d /var/empty -s /usr/sbin/nologin -w no, see man pw for details. When finished, try running webcamd again.

This absolutely worked!

Sorry if this was an obvious step I missed. And thanks everyone for the help.

This is my first install of FreeBSD and I'm hoping it will make a viable workstation. I think it will now.
 
OP
R

rhysday

New Member


Messages: 14

Hmm I've noticed my mouse cursor is lagging/freezing every few seconds. It even locks up my left click if it happens mid press. Does it using both my wacom and mouse. My hardware is fast enough, Nivida 1070, 64GB memory and Ryzen 2700x. How would I troubleshoot such an issue? Seems to be some sort of interference on the usb bus.

If this is a separate problem I will start a new thread, I just wonder if setting up the wacom messed with something.
 

dieselriot

Member

Reaction score: 23
Messages: 89

Sorry if this was an obvious step I missed.
No, the webcamd user should be created automatically when you install webcamd. Whenever you install a package or port that requires such manual steps, there'll be post installation text telling you to do so. Sorry, but something is probably wrong with your system for you to have had this issue. You may have messed up somewhere. Since this is your first install, make sure you pay close attention to the Handbook.


Hmm I've noticed my mouse cursor is lagging/freezing every few seconds.
Have you installed nvidia drivers for your GPU?


This is my first install of FreeBSD and I'm hoping it will make a viable workstation. I think it will now.
I personally think FreeBSD is the best system for a workstation, as long as you have the time and patience to set everything up. I'll also leave a link to a page that describes in greater detail how to configure your wacom and set it up on some applications. The adjusting aspect ratios part is specially important, since the wacom's ratio won't fit either 16:9 or 4:3 monitors.

The page has directions for linux but most of it applies to FreeBSD. Though on FreeBSD xorg.conf.d is located at /usr/local/etc/X11/ and the libwacom directory is at /usr/local/share/.

 
Last edited:
OP
R

rhysday

New Member


Messages: 14

No, the webcamd user should be created automatically when you install webcamd. Whenever you install a package or port that requires such manual steps, there'll be post installation text telling you to do so. Sorry, but something is probably wrong with your system for you to have had this issue. You may have messed up somewhere. Since this is your first install, make sure you pay close attention to the Handbook.



Have you installed nvidia drivers for your GPU?



I personally think FreeBSD is the best system for a workstation, as long as you have the time and patience to set everything up. I'll also leave a link to a page that describes in greater detail how to configure your wacom and set it up on some applications. The adjusting aspect ratios is specially important, since the wacom's ratio won't fit either 16:9 or 4:3 monitors.

The page has directions for linux but most of it applies to FreeBSD. Though on FreeBSD xorg.conf.d is located at /usr/local/etc/X11/ and the libwacom directory is at /usr/local/share/.

I just reinstalled FreeBSD, and from what I learned from this thread it was a much easier setup this time. I didn't have to create the webcamd group as it was created like you said it should have been.

As for the mouse lag, I am still having this problem though it seems to be improved. The nvidia driver should be installed correctly. It doesn't seem to be related to my display/GPU anyway. It seems to be some sort of conflict on the USB bus, as it messes with the input signal at times. Strange. Maybe my motherboard doesn't play nice with freeBSD or need to play with powerd? as I've noticed my fans run a little differently than when I dual boot into Arch.
 

dieselriot

Member

Reaction score: 23
Messages: 89

If your CPU is supported by powerd, then you should probably turn it on. You can do that the same way you enable webcamd in /etc/rc.conf. There's usually no extra configuration. It probably doesn't have much to do with your mouse lag, though. I never had any similar issues, with or without the wacom setup.

Try using X11 with webcamd disabled and the wacom unplugged to see if it's really interfering with the mouse or if it's a separate issue. Maybe you should start a new thread regarding this problem. Good luck!
 

Phishfry

Beastie's Twin

Reaction score: 2,646
Messages: 5,561

as I've noticed my fans run a little differently than when I dual boot into Arch.
This is an APCI function. How our ACPI implementation works and Arch's might be different.
ACPI Thermal comes into play for the sensors.
 
Top