• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Volume scaling

dragon321

New Member

Thanks: 1
Messages: 14

#1
Hello everyone!

Last time i installed FreeBSD on my computer. It works pretty good, but there is one problem - volume scaling. Sound works without problems, but I have little problem with setting volume (i'm using Xfce). Volume at 50% in XFCE mixer is too silent and lower than 50% is completely inaudible. 100% volume level is good - same volume as I have on Windows and Linux in 100%. So it seems volume scale is from 50% to 100%, where 50% is 0. How can I correct this?

Sorry for any mistakes, English isn't my native language.
 

sidetone

Aspiring Daemon

Thanks: 308
Messages: 895

#2
Type mixer, to see the pcm, main and other volume settings, then use the mixer command again to adjust them.
 

scottro

Daemon

Thanks: 401
Messages: 1,179

#3
Your English is better than several native speakers I know. :)

In this case, the exact command is probably mixer volume 100
You might want to also increase speaker, and some of the other settings sidetone mentions. In practice, I find that just doing volume is enough for my needs and hardware
 

dragon321

New Member

Thanks: 1
Messages: 14

#4
Type mixer, to see the pcm, main and other volume settings, then use the mixer command again to adjust them.
This is the output of mixer command:
Code:
Mixer vol      is currently set to  51:51
Mixer pcm      is currently set to 100:100
Mixer speaker  is currently set to 100:100
Mixer mic      is currently set to   0:0
Mixer mix      is currently set to 100:100
Mixer rec      is currently set to   0:0
Mixer ogain    is currently set to 100:100
Recording source: mic
I try to adjust volume with rest set to 100%. In this level (vol 51%) volume is too silent - I can't hear it.

Your English is better than several native speakers I know. :)

In this case, the exact command is probably mixer volume 100
You might want to also increase speaker, and some of the other settings sidetone mentions. In practice, I find that just doing volume is enough for my needs and hardware
Thank You very much :)

As You can see, I have everything other than volume set to 100%. With volume set on 51% the sound is too silent. It's looks like it isn't 51% but 1%. Volume should be silent on 10-20%, not on 50%.
 

scottro

Daemon

Thanks: 401
Messages: 1,179

#5
I imagine that depends upon many factors, such as sound card, speakers or headphones, sound file, and so on.
If you can reproduce it on different machines, with different files, it might be worth filing a bug.
 

dragon321

New Member

Thanks: 1
Messages: 14

#6
It seems there is problem with xfce mixer or xfce mixer panel applet. On Linux I had similar issue and I solved it by installing PA volume applet and using it instead of xfce mixer applet.

I'll try install MATE and check if problem exist here (I haven't got similar issue with MATE on Linux).
 
Top