vlc

OP
OP
B

balanga

Daemon

Thanks: 95
Messages: 2,335

#3
Thanks for the info...

I decided to try and build multimedia/vlc3 and get:-

Code:
root@Vbox:/usr/ports/multimedia/vlc3 # make install
===>   vlc3-3.0.4_1,4 depends on package: ffmpeg>=3.4.1,1 - found
===>   vlc3-3.0.4_1,4 depends on executable: yasm - found
===>   vlc3-3.0.4_1,4 depends on package: v4l_compat>=0 - found
===>   vlc3-3.0.4_1,4 depends on executable: update-desktop-database - found
===>   vlc3-3.0.4_1,4 depends on executable: gmake - found
===>   vlc3-3.0.4_1,4 depends on executable: gtk-update-icon-cache - found
===>   vlc3-3.0.4_1,4 depends on package: libiconv>=1.14_11 - found
===>   vlc3-3.0.4_1,4 depends on package: pkgconf>=1.3.0_1 - found
===>   vlc3-3.0.4_1,4 depends on executable: msgfmt - found
===>   vlc3-3.0.4_1,4 depends on package: xorgproto>=0 - not found
===>  Installing for xorgproto-2018.4
===>  Checking if xorgproto already installed
===>   Registering installation for xorgproto-2018.4 as automatic
Installing xorgproto-2018.4...
pkg-static: xorgproto-2018.4 conflicts with glproto-1.4.17 (installs files into the same place).  Problematic file: /usr/local/include/GL/glxint.h
*** Error code 70

Stop.
make[2]: stopped in /usr/ports/x11/xorgproto
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/multimedia/vlc3
*** Error code 1

Stop.
make: stopped in /usr/ports/multimedia/vlc3

What to do?
 

ShelLuser

Son of Beastie

Thanks: 1,482
Messages: 3,248

#4
Paying better attention to /usr/ports/UPDATING ;)

Code:
$ make search name=glproto |less                                                
Port:   x11/glproto
Moved:  x11/xorgproto
Date:   2018-07-31
Reason: merged into x11/xorgproto
See 20180731 in /usr/ports/UPDATING.

(edit)

Though there seems to be something icky going on wrt. xorgproto (either that or I am overlooking the obvious):

Code:
peter@zefiris:/home/peter $ pkg updating -d 20180701 xorgproto
peter@zefiris:/home/peter $ pkg updating -d 20180701 | grep xorgproto
  x11/xorgproto.  This might cause issues with upgrading.  If you
  get conflicts between xorgproto and old *proto packages, please
  remove the old package and install xorgproto again.
peter@zefiris:/home/peter $ pkg updating -d 20180701 x11/xorgproto   
peter@zefiris:/home/peter $ pkg updating -d 20180701 x11\/xorgproto
peter@zefiris:/home/peter $
Seems pkg-updating(8) doesn't grok x11/xorgproto for some reason.
 
Top