• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

VirtualBox Windows guest freeses under FreeBSD 11.1 - is AIO a reason?...

Selin

New Member

Thanks: 3
Messages: 10

#1
Hi
I've met an issue with FreeBSD 11.1 Release and VirtualBox 5.2.6/5.2.8: Windows guests are freezing time-to-time. Under heavy load guest might fall into BSOD.
I've googled and read lot - tried different settings - no luck :(
Then I found an old bug: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=168298
And compared VBox guests logs from two different hosts: FreeBSD 10.3 and 11.1. Found the following:
On 11.1:
Code:
AIOMgr: Default manager type is 'Async'
AIOMgr: Default file backend is 'NonBuffered'
while on 10.3 I see:
Code:
Code: Select all   Expand viewAIO: Async I/O manager not supported (rc=VERR_NOT_SUPPORTED). Falling back to simple manager
As I know - AIO is built into kernel starting from 11.0.
Is there any way to turn it off?

Thank you.
 

robroy

Active Member

Thanks: 92
Messages: 158

#2
Selin, in the VirtualBox configuration user interface, find a check-box called something like, "Use host I/O cache," and enable it. I observed this same symptom, and this change resolved it for me. I didn't have to change anything in FreeBSD itself.
 

Snurg

Aspiring Daemon

Thanks: 324
Messages: 795

#4
Thank you robroy
I guess this might be the reason why my windows image died after transferring to 11.1.
It crashed a few times and then finally bent over:
repair.png
 

Selin

New Member

Thanks: 3
Messages: 10

#5
Selin, in the VirtualBox configuration user interface, find a check-box called something like, "Use host I/O cache,"
No luck.
I've tried this option, different controllers as well - no changes. log shows the following time-to-time:
Code:
00:11:04.819849 VMMDev: vmmDevHeartbeatFlatlinedTimer: Guest seems to be unresponsive. Last heartbeat received 60 seconds ago
00:11:05.173108 VMMDev: GuestHeartBeat: Guest is alive (gone 60 997 227 850 ns)
00:13:02.219718 TM: Giving up catch-up attempt at a 66 060 163 475 ns lag; new total: 66 060 163 475 ns
00:13:02.219830 VMMDev: vmmDevHeartbeatFlatlinedTimer: Guest seems to be unresponsive. Last heartbeat received 10 seconds ago
00:13:02.235941 VMMDev: GuestHeartBeat: Guest is alive (gone 10 243 936 925 ns)
Found this thread: https://forums.freebsd.org/threads/kernel-panic-after-upgrading-to-11-1.62499/
Tried to add put to sysctl:
Code:
kern.ipc.aio.max_procs=0
vfs.aio.max_aio_per_proc=0
vfs.aio.max_aio_queue=0
vfs.aio.target_aio_procs=0
vfs.aio.max_aio_procs=0
No help :(
 

pwr2srv

New Member

Thanks: 6
Messages: 16

#6
I had similar experiences. Having two Lenovo TS140's, one with the Xeon processor, purchased and used months earlier, the second with an i3, purchased much later, the Xeon ran Virtualbox vm's just fine. However, I could never get consistent operation on the i3 of Windows XP or FreeBSD vm's. Sometimes I could install OK, sometimes not. Sometimes the vm would run for a bit then hang. Sometimes they would not shut down. On the i3 the "Use Host I/O Cache" was not checked, but neither was it checked on the Xeon. OK, I gave it a try and bingo! Checking the box on the Xeon, which had been running vm's OK, appeared to speed them up considerably. Don't know how I missed that box, but it will be checked from now on.
 
Top