Solved virtualbox-ose port, problem with Python; Package problem with file size

nosferatu

Member

Reaction score: 9
Messages: 52

Hello,

I've been trying to install Virtual Box on my system.

When I try to install it from ports tree I got this error:

Code:
===>   virtualbox-ose-5.1.10 depends on executable: yasm - found
===>   virtualbox-ose-5.1.10 depends on executable: xsltproc - found
===>   virtualbox-ose-5.1.10 depends on executable: kmk - found
===>   virtualbox-ose-5.1.10 depends on executable: gtar - found
===>   virtualbox-ose-5.1.10 depends on executable: cdrecord - found
===>   virtualbox-ose-5.1.10 depends on file: /usr/local/share/xml/docbook/4.4/docbookx.dtd - found
===>   virtualbox-ose-5.1.10 depends on executable: soapcpp2 - found
===>   virtualbox-ose-5.1.10 depends on file: /usr/local/share/texmf-var/web2c/tex/tex.fmt - found
===>   virtualbox-ose-5.1.10 depends on executable: dvips - found
===>   virtualbox-ose-5.1.10 depends on package: libiconv>=1.14_9 - found
===>   virtualbox-ose-5.1.10 depends on package: pkgconf>=0.9.10 - found
===>   virtualbox-ose-5.1.10 depends on file: /usr/local/bin/python2.7 - found
===>   virtualbox-ose-5.1.10 depends on executable: gtk-update-icon-cache - found
===>   virtualbox-ose-5.1.10 depends on package: libGL>0 - found
===>   virtualbox-ose-5.1.10 depends on file: /usr/local/libdata/pkgconfig/inputproto.pc - found
===>   virtualbox-ose-5.1.10 depends on file: /usr/local/libdata/pkgconfig/glproto.pc - found
===>   virtualbox-ose-5.1.10 depends on file: /usr/local/libdata/pkgconfig/dri2proto.pc - found
===>   virtualbox-ose-5.1.10 depends on file: /usr/local/libdata/pkgconfig/xcb.pc - found
===>   virtualbox-ose-5.1.10 depends on file: /usr/local/libdata/pkgconfig/x11.pc - found
===>   virtualbox-ose-5.1.10 depends on file: /usr/local/libdata/pkgconfig/xcursor.pc - found
===>   virtualbox-ose-5.1.10 depends on file: /usr/local/libdata/pkgconfig/xext.pc - found
===>   virtualbox-ose-5.1.10 depends on file: /usr/local/libdata/pkgconfig/xinerama.pc - found
===>   virtualbox-ose-5.1.10 depends on file: /usr/local/libdata/pkgconfig/xmu.pc - found
===>   virtualbox-ose-5.1.10 depends on file: /usr/local/libdata/pkgconfig/xt.pc - found
===>   virtualbox-ose-5.1.10 depends on file: /usr/local/lib/qt5/bin/moc - found
===>   virtualbox-ose-5.1.10 depends on file: /usr/local/lib/qt5/bin/linguist - not found
===>   qt5-linguist-5.6.2 depends on file: /usr/local/lib/qt5/bin/moc - found
===>   qt5-linguist-5.6.2 depends on file: /usr/local/lib/qt5/bin/designer - not found
===>   qt5-designer-5.6.2 depends on file: /usr/local/lib/qt5/bin/moc - found
===>   qt5-designer-5.6.2 depends on file: /usr/local/lib/qt5/bin/qmake - found
===>   qt5-designer-5.6.2 depends on file: /usr/local/include/qt5/QtUiPlugin/QtUiPlugin - found
===>   qt5-designer-5.6.2 depends on shared library: libQt5Core.so - found (/usr/local/lib/libQt5Core.so)
===>   qt5-designer-5.6.2 depends on shared library: libQt5Gui.so - found (/usr/local/lib/libQt5Gui.so)
===>   qt5-designer-5.6.2 depends on shared library: libQt5Network.so - found (/usr/local/lib/libQt5Network.so)
===>   qt5-designer-5.6.2 depends on shared library: libQt5PrintSupport.so - found (/usr/local/lib/libQt5PrintSupport.so)
===>   qt5-designer-5.6.2 depends on shared library: libQt5Quick.so - found (/usr/local/lib/libQt5Quick.so)
===>   qt5-designer-5.6.2 depends on shared library: libQt5WebKit.so - not found
===>   qt5-webkit-5.6.2_1 depends on file: /usr/local/bin/flex - found
===>   qt5-webkit-5.6.2_1 depends on file: /usr/local/bin/ruby22 - found
===>   qt5-webkit-5.6.2_1 depends on executable: bison - found
===>   qt5-webkit-5.6.2_1 depends on file: /usr/local/bin/gperf - found
===>   qt5-webkit-5.6.2_1 depends on package: pkgconf>=0.9.10 - found
===>   qt5-webkit-5.6.2_1 depends on file: /usr/local/bin/python2.7 - found
===>   qt5-webkit-5.6.2_1 depends on package: libGL>0 - found
===>   qt5-webkit-5.6.2_1 depends on file: /usr/local/libdata/pkgconfig/glproto.pc - found
===>   qt5-webkit-5.6.2_1 depends on file: /usr/local/libdata/pkgconfig/dri2proto.pc - found
===>   qt5-webkit-5.6.2_1 depends on file: /usr/local/libdata/pkgconfig/x11.pc - found
===>   qt5-webkit-5.6.2_1 depends on file: /usr/local/libdata/pkgconfig/xcomposite.pc - found
===>   qt5-webkit-5.6.2_1 depends on file: /usr/local/libdata/pkgconfig/xrender.pc - found
===>   qt5-webkit-5.6.2_1 depends on package: gstreamer1-plugins>=1.4.0 - not found
===>   gstreamer1-plugins-1.8.0_1 depends on package: gstreamer1>=1.4.0 - found
===>   gstreamer1-plugins-1.8.0_1 depends on package: iso-codes>=0 - not found
===>   iso-codes-3.69 depends on executable: msgfmt - found
===>   iso-codes-3.69 depends on executable: gmake - found
===>   iso-codes-3.69 depends on file: /usr/local/bin/python3.5 - found
===>   iso-codes-3.69 depends on executable: python3 - not found
===>  Installing for python3-2_3
===>   python3-2_3 depends on file: /usr/local/bin/python2.7 - found
===>   python3-2_3 depends on file: /usr/local/bin/python2.7 - found
===>  Checking if python3 already installed
===>   Registering installation for python3-2_3 as automatic
Installing python3-2_3...
*** Error code 70

Stop.
make[8]: stopped in /usr/ports/lang/python3
*** Error code 1

Stop.
make[7]: stopped in /usr/ports/misc/iso-codes
*** Error code 1

Stop.
make[6]: stopped in /usr/ports/multimedia/gstreamer1-plugins
*** Error code 1

Stop.
make[5]: stopped in /usr/ports/www/webkit-qt5
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/www/webkit-qt5
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/devel/qt5-designer
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/devel/qt5-linguist
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/emulators/virtualbox-ose
*** Error code 1

Stop.
make: stopped in /usr/ports/emulators/virtualbox-ose
I tried to remove all Python's and tried again. Still no luck.

When I use pkg install I got file size error. Fetched file size not match.

Thank you for your help.
 
OP
OP
N

nosferatu

Member

Reaction score: 9
Messages: 52

I solved the problem for now with installing iso-codes via pkg install. If some other is interested. I will contact the port maintainer. Hope it gets fixed soon.
 
Top