virtualbox-ose-additions doesn't register mouse clicks?

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 11,000
Messages: 36,957

This is odd. I had a perfectly running FreeBSD guest running on the latest Virtualbox. The host is a Windows 7 but I don't think this matters.

Updated it last night (new Xorg and new virtualbox-ose-additions) and for some reason the mouse in X works but doesn't register any mouse clicks. Mouse integration is turned on, mouse works fully in console. But after I start XFCE mouse moves and correctly registers "mouse-over" (I can see the hints pop-up) but none of the mouse buttons work.

Is there anybody else having the same issue? Maybe this is due to the new Xorg (xorg-server 1.7.7_6,1)?
 

cpm@

Moderator
Staff member
Moderator
Developer

Reaction score: 949
Messages: 2,140

Have you tried to disable the "absolute pointing device"?
Enable absolute pointing device

If enabled, VirtualBox reports to the virtual machine that a USB tablet device is present and communicates mouse events to the virtual machine through this device. If disabled, mouse events are communicated through a traditional PS/2 virtual mouse device.
 

wblock@

Beastie Himself
Developer

Reaction score: 3,718
Messages: 13,851

Sometimes a FreeBSD guest has done that to me. It is not consistent. Sometimes it loses the first three mouse clicks, then works. Can't test it right now, but make sure the VirtualBox kernel modules have been rebuilt (and reloaded) on the host.
 

vermaden

Son of Beastie

Reaction score: 1,573
Messages: 3,000

@SirDice,

The virtualbox-ose-additions require hald and dbus to be enabled and running AND also moused to be disabled, its fscked up, but that's the way vboxmouse integration works.

You will also probably need to put this content below into the /usr/local/etc/hal/fdi/policy/90-vboxguest.fdi file:
Code:
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.subsystem" string="pci">
      <match key="info.product" string="VirtualBox Guest Service">
        <append key="info.capabilities" type="strlist">input</append>
        <append key="info.capabilities" type="strlist">input.mouse</append>
        <merge key="input.x11_driver" type="string">vboxmouse</merge>
        <merge key="input.device" type="string">/dev/vboxguest</merge>
      </match>
    </match>
  </device>
</deviceinfo>
 
Last edited by a moderator:

wblock@

Beastie Himself
Developer

Reaction score: 3,718
Messages: 13,851

vermaden said:
@SirDice,

The virtualbox-ose-additions require hald and dbus to be enabled and running AND also moused to be disabled, its fscked up, but that's the way vboxmouse integration works.

But... my FreeBSD VMs and host don't even have sysutils/hal installed.
 
Last edited by a moderator:

vermaden

Son of Beastie

Reaction score: 1,573
Messages: 3,000

wblock@ said:
But... my FreeBSD VMs and host don't even have sysutils/hal installed.

... and that is good approach. I also stay away as far as possible from HAL, but in moments like this I focus on 'get sh!t done' instead of sticking to what I prefer.

Remember that HAL and DBUS are required only for vboxmouse, vboxvideo works well without them.
 
OP
SirDice

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 11,000
Messages: 36,957

Move moves and correctly registers "mouse-over" events on the right places so I don't think relative/absolute is an issue.

The previous configuration worked without HAL. I always build Xorg without it. Enabling it doesn't do anything to improve the situation. I'm going to try without moused(8) but that was also enabled in the previous working configuration.
 

vermaden

Son of Beastie

Reaction score: 1,573
Messages: 3,000

SirDice said:
Move moves and correctly registers "mouse-over" events on the right places so I don't think relative/absolute is an issue.

The previous configuration worked without HAL. I always build Xorg without it. Enabling it doesn't do anything to improve the situation. I'm going to try without moused(8) but that was also enabled in the previous working configuration.
I also got proper movement, but no 'clicks', after changes I described in #4 post it started to work.
 

wblock@

Beastie Himself
Developer

Reaction score: 3,718
Messages: 13,851

Updated my Xfce4 VM to the latest ports, and it all works fine. Well, Firefox coredumps on close, but mouse and keyboard integration work. That's 9.1-STABLE amd64 from January, will update to the newest soon.

xorg.conf
Code:
Section "ServerLayout"
        Identifier "xfce"
        InputDevice "Mouse1"
EndSection

Section "InputDevice"
        Identifier "Mouse1"
        Driver "vboxmouse"
EndSection
 
OP
SirDice

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 11,000
Messages: 36,957

I'll see if I can test some of this today but I first need to get some work done ;)
 

NorbertB

New Member


Messages: 2

I am unable to install the guest additions. Running VirtualBox 4.2.12, I had the same issues as @SirDice had: under X11 the mouse was recognized but the mouse buttons did not work, though hald and dbus are enabled. I think I also tried moused on and off.

When I get running the guest additions again, I'll try what @wblock@ posted (if necessary). This leads to my problem after upgrading VirtualBox:

FreeBSD 9.1 as a guest in VirtualBox 4.2.16 (on Solaris 11.1 x86): unable to install the guest additions.

Just did a portsnap fetch update. Then trying to install the guest additions, i.e.
Code:
# cd /usr/ports/emulators/virtualbox-ose-additions
# make install clean
===>  Installing for virtualbox-ose-additions-4.2.16
and so on. Finally, the installation stops with the following message:

Code:
install  -o root -g wheel -m 555 /usr/ports/emulators/virtualbox-ose-additions/work/VirtualBox-4.2.16/out/freebsd.amd64/debug/bin/additions/vboxvideo.ko.symbols /boot/modules
install: /usr/ports/emulators/virtualbox-ose-additions/work/VirtualBox-4.2.16/out/freebsd.amd64/debug/bin/additions/vboxvideo.ko.symbols: No such file or directory
*** [do-install] Error code 71

Stop in /usr/ports/emulators/virtualbox-ose-additions.
*** [install] Error code 1

How can I work around these missing vboxvideo.ko.symbols?

Thanks

Norbert
 
Last edited by a moderator:

vermaden

Son of Beastie

Reaction score: 1,573
Messages: 3,000

Do that below and type make -C /usr/ports/emulators/virtualbox-ose-additions install again.
Code:
root# :> /usr/ports/emulators/virtualbox-ose-additions/work/VirtualBox-4.2.16/out/freebsd.amd64/debug/bin/additions/vboxvideo.ko.symbols
 

vermaden

Son of Beastie

Reaction score: 1,573
Messages: 3,000

@NorbertB,

Welcome. You can now safely remove the (probably empty) /boot/modules/vboxvideo.ko.symbols file ;)
 
Last edited by a moderator:
Top