Virtualbox guest not recieving traffic from bridge

dehrmann

Member

Thanks: 2
Messages: 43

#1
I have two bridged interfaces, each bridged to a different VLAN interface, and I'd like to have a Virtualbox guest (Linux) access both bridge interfaces. I set this up, but after some connectivity issues, I discovered that the guest can transmit fine (so I see traffic originating from the guest when doing tcpdump(1) on the host bridge), but the guest never gets traffic from the host. The guest's interface's packet recv bytes is even zero.

This isn't a guest issue because the same guest config worked when the interfaces were bridged to vlan interfaces (configured as cloned interfaces) directly.

I'm running virtualbox-ose-nox11-5.1.22_1.

Only look at bridge0, bridge1 is there for completeness, and I plan on using it, but right now, there's nothing else on that VLAN.

Here's the relevant bits of rc.conf:

Code:
cloned_interfaces="bridge0 bridge1"
vlans_em0="1000 1001"

ifconfig_bridge0="inet 10.0.0.10 netmask 255.255.0.0 addm em0.1000"

ifconfig_bridge1="addm em0.1001"
ifconfig_em0="up"
ifconfig_em0_1000="up"
ifconfig_em0_1001="up"

vboxdrv_load="YES"
vboxnet_enable="YES"

linux_enable="YES"
The output of ifconfig on the host:

Code:
em0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=4019b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,VLAN_HWTSO>
        ether 78:24:xx:xx:xx:xx
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: Ethernet autoselect (1000baseT <full-duplex>)
        status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
        inet6 ::1 prefixlen 128
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
        inet 127.0.0.1 netmask 0xff000000
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
        groups: lo
bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 02:9f:xx:xx:xx:xx
        inet 10.0.0.10 netmask 0xffff0000 broadcast 10.0.255.255
        nd6 options=9<PERFORMNUD,IFDISABLED>
        groups: bridge
        id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
        maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
        root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
        member: em0.1000 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
                ifmaxaddr 0 port 6 priority 128 path cost 2000000
bridge1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 02:9f:xx:xx:xx:xx
        nd6 options=9<PERFORMNUD,IFDISABLED>
        groups: bridge
        id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
        maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
        root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
        member: em0.1001 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
                ifmaxaddr 0 port 7 priority 128 path cost 2000000
em0.1000: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=103<RXCSUM,TXCSUM,TSO4>
        ether 78:24:xx:xx:xx:xx
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: Ethernet autoselect (1000baseT <full-duplex>)
        status: active
        vlan: 1000 vlanpcp: 0 parent interface: em0
        groups: vlan
em0.1001: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=103<RXCSUM,TXCSUM,TSO4>
        ether 78:24:xx:xx:xx:xx
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: Ethernet autoselect (1000baseT <full-duplex>)
        status: active
        vlan: 1001 vlanpcp: 0 parent interface: em0
        groups: vlan
vboxnet0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 0a:00:27:00:00:00
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: Ethernet autoselect
        status: active
And the Virtualbox interface config

Code:
NIC 1:           MAC: 0800273A8EB9, Attachment: Bridged Interface 'bridge0', Cable connected: on, Trace: off (file: none), Type: 82545EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 2:           MAC: 0800270B500F, Attachment: Bridged Interface 'bridge1', Cable connected: on, Trace: off (file: none), Type: 82545EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
 
Top