Solved VirtualBox FreeBSD 11.1 panics

Hi, have a test virtualbox FreePBX 11.1 vm. It has been running fine without panics. Today when trying to start it, it panics.

Booted into single user mode, ran #fsck -y rebooted, goes into panic. Reboot, go to single user mode. Tried to mount / but it fails with dirty file system. Ran #fsck -y again, rebooted to single user mode. # mount -u / and again says dirty file system. Again ran fsck. After fsck completes in a couple of secs. # mount -u / its ok. # mount -a its ok.

Reboot again and goes into panic


How to get this fixed??

After the initial posting above, tried running (in single user mode) # fsck -y 4 times. After the 4th run, ctrl+D to go multi-user. That was fine. # shutdown -r now rebooted properly.
It appears / was corrupted. Like mentioned in the original post, after running fsck -y 4 times in a row, (yes 1 or 2 times did not fix it), it finally was fixed and the server booted normally. Since I run the VM headless, it's possible the host was rebooted before shutting down the server. That's about the only thing that comes to mind.