Video problem with NVidia Geforce GT 750 M (Ideapad Y500)

decuser

Active Member

Reaction score: 74
Messages: 214

I'm trying to install FreeBSD to another laptop. This time, it's an Ideapad Y500. It has an NVidia Geforce GT 750 M card. When I boot the UEFI installer for FreeBSD 12.1, the boot menu shows up small and to the left, but when the install screen shows up, the screen is split into three unreadable skewed versions of the install screen along the top third of the screen. Is there a kernel option I can pass to get the screen to show up properly?

I am able to boot in legacy mode (which I'm not keen on), but even after installing nvidia-driver and adding kld_list="nvidia-modeset" to /etc/rc.conf, the console font is 800x600 - ick. I added kern.vty=vt into loader.conf, to no avail. What am I missing?

So please help on either question - UEFI mode screwy video or legacy mode console is 800x600, but native resolution is 1920x1080.

Thanks.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,653
Messages: 36,383

I added kern.vty=vt into loader.conf
This has zero effect because it's the default setting.

You can try setting kern.vt.fb.default_mode and change the resolution. But if you're going to boot straight to Xorg I wouldn't bother with the console settings.

Code:
     kern.vt.fb.default_mode
             Set this value to a graphic mode to override the default mode
             picked by the vt backend.  The mode is applied to all output
             connectors.  This is currently only supported by the vt_fb
             backend when it is paired with a KMS video driver.
See vt(4)
 

Terpentijn

Active Member

Reaction score: 10
Messages: 101

I'm trying to install FreeBSD to another laptop. This time, it's an Ideapad Y500. It has an NVidia Geforce GT 750 M card. When I boot the UEFI installer for FreeBSD 12.1, the boot menu shows up small and to the left, but when the install screen shows up, the screen is split into three unreadable skewed versions of the install screen along the top third of the screen. Is there a kernel option I can pass to get the screen to show up properly?

I am able to boot in legacy mode (which I'm not keen on), but even after installing nvidia-driver and adding kld_list="nvidia-modeset" to /etc/rc.conf, the console font is 800x600 - ick. I added kern.vty=vt into loader.conf, to no avail. What am I missing?

So please help on either question - UEFI mode screwy video or legacy mode console is 800x600, but native resolution is 1920x1080.

Thanks.
You’ve got an answer but not about this strange screen behavior. My laptop has an older model intel integrated chip and also scrambles the screen when booting FreeBSD in UEFI mode. I have no idea how to solve it. It’s kind of a problem because windows 10 is installed on one of my other drives and also runs in UEFI mode. So it would be nice to be able to choose from the bios startup which OS I want to boot. Installing FreeBSD in legacy mode and windows 10 in UEFI is a pain. Is there a setting that makes my FreeBSD boot up screen readable in UEFI mode, so I can setup the system?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,653
Messages: 36,383

Is there a setting that makes my FreeBSD boot up screen readable in UEFI mode, so I can setup the system?
EUFI boot FreeBSD, uefi(8). Search the forums, there should be some gop command or setting you can try.
 

Terpentijn

Active Member

Reaction score: 10
Messages: 101

EUFI boot FreeBSD, uefi(8). Search the forums, there should be some gop command or setting you can try.
Thanks. I will look it up. In the meantime I 'solved' it by booting FreeBSD in legacy mode and after this I installed FreeBSD on ZFS and changed the ZFS settings to GPT/UEFI. So FreeBSD and Windows now both start up in UEFI. The only thing that is still ugly is the bootup screen. FreeBSD takes up the left half of the screen. A little odd to the eye but no problem.
 
Top