• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved vidcontrol missing modes

h0m3

New Member


Messages: 6

#1
Hello,

I'm trying to change the console resolution to anything different from the default "640x400" and i have some problems.

When i run
Code:
vidcontrol -i mode
i got 511 different modes, all with the same resolution 671404428x671404428 but i cannot change to any of that.

Running
Code:
vidcontrol -i adapter
i got "Inappropriate ioctl for device".

I have the follow settings on my /boot/loader.conf:

Code:
kern.vty = vt
hw.vga.textmode = 1
kern.vt.fb.default_mode="1920x1080"
I see that the kernel enabled some sort of Framebuffer when i used
Code:
kern.vty = vt
, since a nicer font and colors support. But i cannot change the resolution.

I have an old machine here, AMD Atlhon XP-M 2800+, 1GB, S3 Unichrome Pro (VIA K8M800).
 

protocelt

Daemon

Thanks: 405
Messages: 1,253

#2
Changing the console resolution above 640x400 when using vt(4) is only supported when using kernel mode setting(KMS) and is unfortunately only available for AMD and Intel GPUs at this time.
 

h0m3

New Member


Messages: 6

#3
Changing the console resolution above 640x400 when using vt(4) is only supported when using kernel mode setting(KMS) and is unfortunately only available for AMD and Intel GPUs at this time.
There's any other option aside from vt(4) on FreeBSD? Sorry for the newbie question, I'm new to FreeBSD world :) Or there's really no way?
 

protocelt

Daemon

Thanks: 405
Messages: 1,253

#4
No need to apologize, We all were newbies at one time. :)

Yes, there is also the older sc(4) console driver. You can switch to it by changing kern.vty=vt to kern.vt=sc in your /boot/loader.conf file. That should allow you to change the console resolution with vidcontrol(1) to a supported mode.
 

h0m3

New Member


Messages: 6

#5
This worked like a charm. Perfectly.

Really Thanks, this solved all my problems related to Console Video. I will use sc until my AMD card arrives then i swithc back to vt.
 

Oliver Schonrock

New Member

Thanks: 4
Messages: 18

#6
Thanks, very useful!

Seems that FreeBSD 11 changed the default from sc(4) to vt(4). After upgrading some headless servers from 10.3 to 11.1 the onboard supermicro IPMI (ie KVM) unit was struggling to match the resolution of the console (last line half cut off).

this restores order!

In /boot/loader.conf:
Code:
kern.vty=sc
(note that there is a small typo in protocelt 's posts above, he has kern.vt=sc, missing the "y")
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,127
Messages: 27,000

#7
After upgrading some headless servers from 10.3 to 11.1 the onboard supermicro IPMI (ie KVM) unit was struggling to match the resolution of the console (last line half cut off).
Setting vt(4) to text mode helps.

In /boot/loader.conf:
Code:
hw.vga.textmode=1
 
Top