• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

[VIA Tech VGA] Xorg -configure doesn't work

lex90

New Member


Messages: 1

#1
Hi,
I'm a new with freebsd (i've never used a BSD).
Anyway i'm excited to try it.
I have installed all by net, and after gnome2 i have installed xorg (both by ports). To get informations about my vga (i have an integrated via graphic) i tried "pciconf -lv" obtaining some results, and VGA informations:
Code:
vgapci0@pci0:1:0:0: class=0x030000 card=0x70611462 chip=0x72051106 rev=0x01 hdr=0x00
vendor = "VIA Technologies Inc"
device = "VIA Technologies, Inc. VT8378 [S3 UniChrome] Graphic adapter (KM400)"
class = display
subclass = VGA
Trying "startx" i got:
Code:
Primary Device is not PCI
(==) Using default built-in configuration (21 lines)
(EE) Failed to load module "fbdevhw" (module doesn't exist, 0)
(EE) No devices detected

Fatal server error:
no screens found

Please consult [... -- i cut this part]

giving up.
xinit: no such file or directory (errno 2): unable to connect to X server
xinit: no such process (errno 3): server error.
So, i tried to run "Xorg -configure", following the "X11 Configuration" guide, i obtain a "No devices to configure. Configuration failed."

I tried to remake x11-drivers enabling all video drivers -exception for via that is conflicting with openchrome-.
I tried it again, with same result.

So now i don't know what should i do.

Have you any idea?

Thanks anyone,
greetings.

Alessandro.
 

BuSerD

Member

Thanks: 6
Messages: 75

#2
Be sure that vga is included in your kernel if you happen to be using a custom kernel (substitute your kernconf name if it is not GENERIC);

Code:
% grep vga /usr/src/sys/*/conf/GENERIC
/usr/src/sys/amd64/conf/GENERIC:device		vga		# VGA video card driver
/usr/src/sys/i386/conf/GENERIC:device		vga		# VGA video card driver
According to the error fbdevhw is missing. Grab a generic xorg.conf from somewhere and edit it as needed if you are unable to build one from scratch. Also in your xorg.conf set the driver as vesa to see if that will work for you. you can get a better driver after you determine that is the only issue by trying vesa.
 

zeiz

Aspiring Daemon

Thanks: 56
Messages: 691

#3
I'd better install xorg first, try it, if it's fine then install gnome.
"No devices to configure. Configuration failed."
Personally never seen something like this. # X -configure must create /root/xorg.conf.new file even if nothing work then.
This looks like a bug report but I would simply try to reinstall everything. FreeBSD first, then xorg and then try again # X -configure
BuSerD's advice to try vesa driver sounds very good to me. Below is "generic" xorg.conf. I would change HorizSync and VertRefresh in "Monitor" section to your monitor's data (please google it), as well as your monitor's default resolution and frequency in "Screen" section, "Display" subsection.
Code:
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/local/lib/xorg/modules"
	FontPath     "/usr/local/lib/X11/fonts/misc/"
	FontPath     "/usr/local/lib/X11/fonts/TTF/"
	FontPath     "/usr/local/lib/X11/fonts/OTF/"
	FontPath     "/usr/local/lib/X11/fonts/Type1/"
	FontPath     "/usr/local/lib/X11/fonts/100dpi/"
	FontPath     "/usr/local/lib/X11/fonts/75dpi/"
#	FontPath     "/usr/local/lib/X11/fonts/webfonts/"
#	FontPath     "/usr/local/lib/X11/fonts/terminus-font/"
#	FontPath     "/usr/local/lib/X11/fonts/dejavu/"
#	FontPath     "/usr/local/lib/X11/fonts/Liberation/"		
EndSection

Section "Module"
	Load  "extmod"
	Load  "dri2"
	Load  "dbe"
	Load  "dri"
	Load  "record"
	Load  "glx"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/sysmouse"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
	HorizSync	[color="Red"]30-82[/color]
	VertRefresh	[color="Red"]56-75[/color]
	[color="Red"]Option		"DPMS"[/color]
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "HWcursor"           	# [<bool>]
        #Option     "NoAccel"            	# [<bool>]
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "UseFBDev"           	# [<bool>]
        #Option     "Rotate"             	# [<str>]
        #Option     "VideoKey"           	# <i>
        #Option     "FlatPanel"          	# [<bool>]
        #Option     "FPDither"           	# [<bool>]
        #Option     "CrtcNumber"         	# <i>
        #Option     "FPScale"            	# [<bool>]
        #Option     "FPTweak"            	# <i>
        #Option     "DualHead"           	# [<bool>]
	Identifier  "Card0"
	Driver      "[B]vesa[/B]"
	VendorName  "nVidia Corporation"
	BoardName   "C77 [GeForce 8200]"
	BusID       "[color="Red"]PCI:1:0:0[/color]"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes	"[color="Red"]1680x1050_60[/color]"
	EndSubSection
EndSection
If that works, I would try substitute vesa with the following (one at a time):
openchrome
s3
s3virge
via
 
Top