/usr/ports/net-im/ejabberd & diabla-caffe-freebsd7

paulfrottawa

Active Member

Thanks: 22
Messages: 241

#1
I'm trying to install jabber (/usr/ports/net-im/ejabberd/ ) for my phpbb3. I don't know if this is the right one to use. I'm just playing with it.

When I tried to install the package I relized I don't have a package.


pkg_add diablo-caffe-freebsd7-i386-1.6.0_07-b02.tar.bz2
| pkg_add: unable to open table of contents file '+CONTENTS' - not a
package?
Can some one tell me what to do?

Here is the link:

http://www.FreeBSDFoundation.org/cg...ablo-caffe-freebsd7-i386-1.6.0_07-b02.tar.bz2

____________________
Because of licensing restrictions, you must fetch the distribution
manually.
 

ale

Daemon

Thanks: 166
Messages: 1,059

#3
It seems that you are trying to download the distfile tarball and trying to install it as a package.
You can visit the page at the URL above and download the correct package (Packages section) or move the tar.bz2 file in /usr/ports/distfiles and run cd /usr/ports/java/diablo-jdk16 && make install clean.

http://www.freebsdfoundation.org/downloads/java.shtml

p.s.
the link in post #2 is broken
 
OP
OP
paulfrottawa

paulfrottawa

Active Member

Thanks: 22
Messages: 241

#4
Thanks the port is ready to build. The default config looked like this.
defaultconfig.gif

Just by chance I thought you may comment on this unlimited strength policy?

I'm going to keep the defaults for now.
 

ale

Daemon

Thanks: 166
Messages: 1,059

#5
That should be something that have to do with the key size used for encryption.
AFAIK in the USA there are some limitations in exporting high strength encryption technologies as they are considered sensitive in terms of national security or something like that.
So I think that you should manually download the file from the java.sun.com website and move it in /usr/ports/distfiles before reinstalling
("Java SE" on the "Popular download" box on the right->"Other Downloads" on the bottom of the page)
 
OP
OP
paulfrottawa

paulfrottawa

Active Member

Thanks: 22
Messages: 241

#6
Thanks it now installs fine.

However I have another problem because I wanted this for a jail. I can not find the right combination to put these file a /usr/ports/disfiles and get my jails to know its there.

Here another thread:
http://forums.freebsd.org/showthread.php?t=962

I tried what DocSlice suggested but those commands didn't work. I'm looking into more before I report there. I didn't want to swamp you with the jail too.
 
Top