USB Keyboard does not react right on keypress

tvladyslav

New Member


Messages: 3

Hello.

I bought new keyboard, and had strange behavior with it.
Keyboard works well on bootmenu, till FreeBSD start booting process.

So, in console (without X running):

pressing q giving m
pressing w -> a
pressiong e -> nothing
pressing r -> 3
pressing t -> m
pressing u -> nothing
i -> m
backspace -> a
in general all keys giving me a,m,nothing,~

dmesg:

Code:
ugen2.4: <SONiX> at usbus2
ukbd0: <SONiX USB Keyboard, class 0/0, rev 2.00/1.05, addr 4> on usbus2
kbd2 at ukbd0
ukbd1: <SONiX USB Keyboard, class 0/0, rev 2.00/1.05, addr 4> on usbus2
kbd3 at ukbd1

kbdcontrol() response that device is busy when I try to change keymap.


Code:
# kbdcontrol -k /dev/kbd1
kbdcontrol: cannot open /dev/kbd1: Device busy

In general I get lost, problem does not looks like wrong keymap...
 

bsdkeith

Active Member


Messages: 120

Is your BIOS set to legacy for usb(?). Have you tried unplugging/plugging in again(?).
 
OP
T

tvladyslav

New Member


Messages: 3

bsdkeith said:
Is your BIOS set to legacy for usb(?). Have you tried unplugging/plugging in again(?).

- Legacy for USB in BIOS disabled (and it looks like it does not have any sens if its on/off)
- Unpluggin/pluggin - yes, i'm. I had tryed all usbs - they all give me the same result
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,266
Messages: 38,773

Try the keyboard on a different computer. Either the keyboard is broken or there's something weird going on in your PC.
 
OP
T

tvladyslav

New Member


Messages: 3

SirDice said:
Try the keyboard on a different computer. Either the keyboard is broken or there's something weird going on in your PC.

Write down this comment with that keyboard from Mac note book.

On my FreeBSD computer keyboard are working in BIOS and working during boot process, on boot menu I can press space and add some parameters to kernel for example. But after 10-15 seconds after booting keyboard stops working properly.

Maybe problem in /dev/devd.conf ....
 
Top