usb install fails with location of sets

I'm trying to install FreeBSD from usb using the memstick.img but it fails with location of sets. It goes with the default which is cd0 but that doesn't work. I've tried using the number for the root partition but it doesn't recognize it. I've googled with all sorts of terms but nothing comes up. Any help greatly appreciated. I want to get FreeBSD up and running again. Thanks
I have had that situation, too.
It's been a while but if I remember right, I fixed it by playing with USB compatibility options in the BIOS.
USB-device got somehow detached or inaccessable after the memstick image was fully loaded.

I'm up and running with 11.1, revisited my install process just to see if I could get it to fail. Image resides on my Linux box, I did dd if=FreeBSD.img of=dev/sdh bs=64k. Rebooted, pointed BIOS to USB and away it went. Everything detected, USB drive became da5 (I have a few drives). Got to the blue install screen no problem. Make sure you are not specifying a partition you may have created on your USB drive, give it the whole drive. Try another drive if you have a spare.
Well I'm having a new problem with my usb stick so I have to get a new one. I'll get back with you as soon as I can try again. Thanks
I was finally able to solve my problem with the usb stick. It has
System Volume Information usb0
on it besides FreeBSD. Do I need to delete this? Sorry for my ignorance but I've only installed from usb once.
That is a more or less useless Windows folder on a usb-device, FreeBSD doesn't need it and Windows will recreate it anyway when you access the device on a Windows computer.
Just delete it..
I don't really understand what that has to do with your original problem?
Because When I tried to install I realized it was installing OpenBSD which makes no sense. I checked boot order in BIOS and set it to boot from USB like I did before. I had tried using a dvd but my optical drive is broken so I was using an external one but there is no option in bios to boot from an external drive and I got the message that it couldn't find a cd. In my other computers it gives me the option to boot from an external drive but I don't have that option. At this point I'm completely lost.
Yeah, that can be really hard.
If you have compatibility options for USB in your BIOS try playing with those. I have one computer myself where I have to change USB compatibility options all the time when I try to use an USB-pendrive or boot from a USB-DVD-drive. Than those options break other things like keyboard not working anymore and such, really annoying.

Search for USB-compatibility options and USB-compatibility patch like options and see if you external DVD appears.
I can't get FreeBSD on a usb stick no matter what I try. I've tried every version of dd I can find and no luck. Any suggestions?
If you have another computer (or a friend of yours) you could move the harddisk to that one, after you finished installing FreeBSD on it, just move it back.
Unplugg all other harddisks in the other computer.

I Installed FreeBSD that way on my computer I told you about in my last message :)
Problem is this is a notebook and everything is welded in. I also has kubuntu and it doesn't recognize the "of" command in dd. My only other computer is a laptop which is going into the shop. I expect it has the same problem as the notebook. They build these computers so that they have to be replaced. But just spent $700 for that laptop and I got it in January. I have no idea what to try next. Thanks for the suggestions.
Are you sure about this part: 'kubuntu and it doesn't recognize the "of" command in dd'?
If have never seen an non-standard dd command, no matter which operating system; if it has 'dd' it works the same way.
Things that varies are the names of devices. What FreeBSD call /dev/ada0, /dev/ada1 and so on is often called /dev/sda, /dev/sdb and so on in Linux. If you have a machine with a built-in flash chip it is often called /dev/mmc* something. USB memory sticks are often called /dev/da0, /dev/da1 and so on in FreeBSD.
Thanks for the help. I got freeBSD installed. Now to get internet working. But that's for another thread. Thanks again. I really appreciate the support