USB Glass Keyboard

knightjp

Active Member

Reaction score: 27
Messages: 167

I'm trying to find a solution with getting my Bastron USB Glass keyboard working.
It works out of the box on other operating systems just like plugging in a standard USB device. Just not on FreeBSD. Any ideas?
 

olli@

Well-Known Member
Developer

Reaction score: 315
Messages: 375

Did your keyboard come with mandatory drivers for certain operating systems (Windows, Mac)? If so, it likely uses a proprietary protocol that won't work with other operating systems, including FreeBSD.

Some background on the topic of USB keyboards:
Standard USB keyboards use the so-called HID protocol (human interface device). FreeBSD includes a HID keyboard driver that works with every standard USB keyboard out of the box. If your keyboard is not recognized when you connect it, it probably does not use that protocol. You can look at the console messages ( dmesg -a) or use the usbconfig(8) command to see details about the device.

You might also try to post the details to the freebsd-usb mailing list. There's probably a better chance to get help than on this forum.
 
OP
OP
knightjp

knightjp

Active Member

Reaction score: 27
Messages: 167

olli@ The keyboard came just as is.. There weren't any drivers with it. So far it works on all the systems including Linux. It is just on a FreeBSD installation that I'm having issues. I guess you are right in the sense that the keyboard does not support the standard protocols.
 

olli@

Well-Known Member
Developer

Reaction score: 315
Messages: 375

Well, in that case it might be worth trying to dig a little deeper. Maybe it's just a small issue preventing the keyboard from working. A good start is to look at the kernel messages when you plug the device in ( dmesg -a) and look at the list of USB devices ( usbconfig, requires root privileges). Every USB device will cause some messages, even if there is no specialized driver to support it.

Basically there are two cases:
(a) The device is recognized and attached as a HID keyboard. In this case, the question is why it still doesn't work (maybe it can be attached manually with kbdcontrol(1)).
(b) The device is not recognized as a HID keyboard. In this case the question is why. The USB experts on the freebsd-usb mailing list (see my previous reply) probably know how debug the issue further.
 
OP
OP
knightjp

knightjp

Active Member

Reaction score: 27
Messages: 167

Here is my
Code:
dmesg -a
IMG_2679.JPG

IMG_2680.JPG

IMG_2681.JPG


IMG_2682.JPG

IMG_2683.JPG


Why do the pictures come out sideways when they're straight on my desktop.
 

olli@

Well-Known Member
Developer

Reaction score: 315
Messages: 375

Can you please post that as plain text (via copy&paste), not as images? (a) It's easier to read (for me and for others that might want to help you). (b) It can be selectively (partially) quoted when replying. (c) It can be picked up by search engines, so others will have a better chance to find this thread, too.
 
OP
OP
knightjp

knightjp

Active Member

Reaction score: 27
Messages: 167

olli@ Thank you for the suggestion. My apologies.

Please see my "dmesg -a" below: (Part 1)
Code:
Copyright (c) 1992-2018 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 12.0-RELEASE r341666 GENERIC amd64
FreeBSD clang version 6.0.1 (tags/RELEASE_601/final 335540) (based on LLVM 6.0.1)
VT(vga): resolution 640x480
CPU: Intel(R) Core(TM) i5-3330 CPU @ 3.00GHz (3009.88-MHz K8-class CPU)
  Origin="GenuineIntel"  Id=0x306a9  Family=0x6  Model=0x3a  Stepping=9
  Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
  Features2=0x7fbae3bf<SSE3,PCLMULQDQ,DTES64,MON,DS_CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,TSCDLT,AESNI,XSAVE,OSXSAVE,AVX,F16C,RDRAND>
  AMD Features=0x28100800<SYSCALL,NX,RDTSCP,LM>
  AMD Features2=0x1<LAHF>
  Structured Extended Features=0x281<FSGSBASE,SMEP,ERMS>
  XSAVE Features=0x1<XSAVEOPT>
  VT-x: (disabled in BIOS) PAT,HLT,MTF,PAUSE,EPT,UG,VPID
  TSC: P-state invariant, performance statistics
real memory  = 25769803776 (24576 MB)
avail memory = 24974344192 (23817 MB)
---<<BOOT>>---
Copyright (c) 1992-2018 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 12.0-RELEASE r341666 GENERIC amd64
FreeBSD clang version 6.0.1 (tags/RELEASE_601/final 335540) (based on LLVM 6.0.1)
VT(vga): resolution 640x480
CPU: Intel(R) Core(TM) i5-3330 CPU @ 3.00GHz (3009.89-MHz K8-class CPU)
  Origin="GenuineIntel"  Id=0x306a9  Family=0x6  Model=0x3a  Stepping=9
  Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
  Features2=0x7fbae3bf<SSE3,PCLMULQDQ,DTES64,MON,DS_CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,TSCDLT,AESNI,XSAVE,OSXSAVE,AVX,F16C,RDRAND>
  AMD Features=0x28100800<SYSCALL,NX,RDTSCP,LM>
  AMD Features2=0x1<LAHF>
  Structured Extended Features=0x281<FSGSBASE,SMEP,ERMS>
  XSAVE Features=0x1<XSAVEOPT>
  VT-x: (disabled in BIOS) PAT,HLT,MTF,PAUSE,EPT,UG,VPID
  TSC: P-state invariant, performance statistics
real memory  = 25769803776 (24576 MB)
avail memory = 24974340096 (23817 MB)
Event timer "LAPIC" quality 600
ACPI APIC Table: <ALASKA A M I>
FreeBSD/SMP: Multiprocessor System Detected: 4 CPUs
FreeBSD/SMP: 1 package(s) x 4 core(s)
random: unblocking device.
ioapic0 <Version 2.0> irqs 0-23 on motherboard
Launching APs: 3 2 1
Timecounter "TSC-low" frequency 1504942592 Hz quality 1000
random: entropy device external interface
kbd1 at kbdmux0
netmap: loaded module
[ath_hal] loaded
module_register_init: MOD_LOAD (vesa, 0xffffffff810f9770, 0) error 19
random: registering fast source Intel Secure Key RNG
random: fast provider: "Intel Secure Key RNG"
nexus0
vtvga0: <VT VGA driver> on motherboard
cryptosoft0: <software crypto> on motherboard
acpi0: <ALASKA A M I> on motherboard
acpi0: Power Button (fixed)
cpu0: <ACPI CPU> on acpi0
hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
Timecounter "HPET" frequency 14318180 Hz quality 950
Event timer "HPET" frequency 14318180 Hz quality 550
Event timer "HPET1" frequency 14318180 Hz quality 440
Event timer "HPET2" frequency 14318180 Hz quality 440
Event timer "HPET3" frequency 14318180 Hz quality 440
Event timer "HPET4" frequency 14318180 Hz quality 440
atrtc0: <AT realtime clock> port 0x70-0x77 irq 8 on acpi0
atrtc0: Warning: Couldn't map I/O.
atrtc0: registered as a time-of-day clock, resolution 1.000000s
Event timer "RTC" frequency 32768 Hz quality 0
attimer0: <AT timer> port 0x40-0x43,0x50-0x53 irq 0 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
Event timer "i8254" frequency 1193182 Hz quality 100
Timecounter "ACPI-safe" frequency 3579545 Hz quality 850
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
acpi_ec0: <Embedded Controller: GPE 0x18> port 0x62,0x66 on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> irq 16 at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
vgapci0: <VGA-compatible display> port 0xe000-0xe07f mem 0xf6000000-0xf6ffffff,0xe0000000-0xefffffff,0xf0000000-0xf1ffffff irq 16 at device 0.0 on pci1
vgapci0: Boot video device
hdac0: <NVIDIA (0x0fb9) HDA Controller> mem 0xf7080000-0xf7083fff irq 17 at device 0.1 on pci1
pci0: <simple comms> at device 22.0 (no driver attached)
em0: <Intel(R) PRO/1000 Network Connection> port 0xf040-0xf05f mem 0xf7600000-0xf761ffff,0xf7629000-0xf7629fff irq 20 at device 25.0 on pci0
em0: attach_pre capping queues at 1
em0: using 1024 tx descriptors and 1024 rx descriptors
em0: msix_init qsets capped at 1
em0: Unable to map MSIX table
em0: Using an MSI interrupt
em0: allocated for 1 tx_queues
em0: allocated for 1 rx_queues
em0: Ethernet address: c8:60:00:73:40:da
em0: netmap queues/slots: TX 1/1024, RX 1/1024
ehci0: <Intel Cougar Point USB 2.0 controller> mem 0xf7628000-0xf76283ff irq 16 at device 26.0 on pci0
usbus0: EHCI version 1.0
usbus0 on ehci0
usbus0: 480Mbps High Speed USB v2.0
hdac1: <Intel Cougar Point HDA Controller> mem 0xf7620000-0xf7623fff irq 22 at device 27.0 on pci0
pcib2: <ACPI PCI-PCI bridge> irq 16 at device 28.0 on pci0
pcib2: [GIANT-LOCKED]
pcib3: <ACPI PCI-PCI bridge> irq 17 at device 28.1 on pci0
pci2: <ACPI PCI bus> on pcib3
xhci0: <ASMedia ASM1042 USB 3.0 controller> mem 0xf7500000-0xf7507fff irq 17 at device 0.0 on pci2
xhci0: 32 bytes context size, 32-bit DMA
xhci0: Unable to map MSI-X table
usbus1 on xhci0
usbus1: 5.0Gbps Super Speed USB v3.0
pcib4: <ACPI PCI-PCI bridge> irq 19 at device 28.3 on pci0
pci3: <ACPI PCI bus> on pcib4
atapci0: <JMicron JMB362 SATA300 controller> port 0xd040-0xd047,0xd030-0xd033,0xd020-0xd027,0xd010-0xd013,0xd000-0xd00f mem 0xf7410000-0xf74101ff irq 19 at device 0.0 on pci3
ahci0: <JMicron JMB362 AHCI SATA controller> at channel -1 on atapci0
ahci0: AHCI v1.10 with 2 3Gbps ports, Port Multiplier supported
ahcich0: <AHCI channel> at channel 0 on ahci0
ahcich1: <AHCI channel> at channel 1 on ahci0
pcib5: <ACPI PCI-PCI bridge> irq 16 at device 28.4 on pci0
pci4: <ACPI PCI bus> on pcib5
xhci1: <ASMedia ASM1042 USB 3.0 controller> mem 0xf7300000-0xf7307fff irq 16 at device 0.0 on pci4
xhci1: 32 bytes context size, 32-bit DMA
xhci1: Unable to map MSI-X table
usbus2 on xhci1
usbus2: 5.0Gbps Super Speed USB v3.0
pcib6: <ACPI PCI-PCI bridge> irq 18 at device 28.6 on pci0
pci5: <ACPI PCI bus> on pcib6
pcib7: <ACPI PCI-PCI bridge> irq 18 at device 0.0 on pci5
pci6: <ACPI PCI bus> on pcib7
pci6: <serial bus, FireWire> at device 2.0 (no driver attached)
pcib8: <ACPI PCI-PCI bridge> irq 19 at device 28.7 on pci0
pci7: <ACPI PCI bus> on pcib8
ahci1: <Marvell 88SE9172 AHCI SATA controller> port 0xb040-0xb047,0xb030-0xb033,0xb020-0xb027,0xb010-0xb013,0xb000-0xb00f mem 0xf7110000-0xf71101ff irq 19 at device 0.0 on pci7
ahci1: AHCI v1.00 with 2 6Gbps ports, Port Multiplier supported with FBS
ahcich2: <AHCI channel> at channel 0 on ahci1
ahcich3: <AHCI channel> at channel 1 on ahci1
ehci1: <Intel Cougar Point USB 2.0 controller> mem 0xf7627000-0xf76273ff irq 23 at device 29.0 on pci0
usbus3: EHCI version 1.0
usbus3 on ehci1
usbus3: 480Mbps High Speed USB v2.0
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
ahci2: <Intel Cougar Point AHCI SATA controller> port 0xf090-0xf097,0xf080-0xf083,0xf070-0xf077,0xf060-0xf063,0xf020-0xf03f mem 0xf7626000-0xf76267ff irq 19 at device 31.2 on pci0
ahci2: AHCI v1.30 with 6 6Gbps ports, Port Multiplier not supported
ahcich6: <AHCI channel> at channel 2 on ahci2
ahciem0: <AHCI enclosure management bridge> on ahci2
acpi_button0: <Power Button> on acpi0
acpi_tz0: <Thermal Zone> on acpi0
acpi_tz1: <Thermal Zone> on acpi0
orm0: <ISA Option ROM> at iomem 0xce800-0xd17ff pnpid ORM0000 on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbdc0: non-PNP ISA device will be removed from GENERIC in FreeBSD 12.
est0: <Enhanced SpeedStep Frequency Control> on cpu0
Timecounters tick every 1.000 msec
hdacc0: <NVIDIA (0x0080) HDA CODEC> at cad 0 on hdac0
hdaa0: <NVIDIA (0x0080) Audio Function Group> at nid 1 on hdacc0
pcm0: <NVIDIA (0x0080) (HDMI/DP 8ch)> at nid 4 on hdaa0
pcm1: <NVIDIA (0x0080) (HDMI/DP 8ch)> at nid 5 on hdaa0
pcm2: <NVIDIA (0x0080) (HDMI/DP 8ch)> at nid 6 on hdaa0
hdacc1: <Realtek ALC892 HDA CODEC> at cad 0 on hdac1
hdaa1: <Realtek ALC892 Audio Function Group> at nid 1 on hdacc1
pcm3: <Realtek ALC892 (Rear Analog 7.1/2.0)> at nid 20,22,21,23 and 24,26 on hdaa1
pcm4: <Realtek ALC892 (Front Analog)> at nid 27 and 25 on hdaa1
pcm5: <Realtek ALC892 (Rear Digital)> at nid 30 on hdaa1
pcm6: <Realtek ALC892 (Onboard Digital)> at nid 17 on hdaa1
ugen3.1: <Intel EHCI root HUB> at usbus3
ugen1.1: <0x1b21 XHCI root HUB> at usbus1
ugen2.1: <0x1b21 XHCI root HUB> at usbus2
ugen0.1: <Intel EHCI root HUB> at usbus0
uhub0: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus3
uhub1: <0x1b21 XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus1
uhub2: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus0
uhub3: <0x1b21 XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus2
ada0 at ahcich6 bus 0 scbus4 target 0 lun 0
ada0: <WDC WD5000AAKX-60U6AA0 18.01H18> ATA8-ACS SATA 3.x device
ada0: Serial Number WD-WCC2EPD09762
ada0: 300.000MB/s transfers (SATA 2.x, UDMA5, PIO 8192bytes)
ada0: Command Queueing enabled
ada0: 476940MB (976773168 512 byte sectors)
ses0 at ahciem0 bus 0 scbus5 target 0 lun 0
ses0: <AHCI SGPIO Enclosure 1.00 0001> SEMB S-E-S 2.00 device
ses0: SEMB SES Device
cd0 at ahcich3 bus 0 scbus3 target 0 lun 0
cd0: <HL-DT-ST DVDRAM GH24NSC0 LK00> Removable CD-ROM SCSI device
cd0: Serial Number K4BE6ME3405
cd0: 150.000MB/s transfers (SATA 1.x, UDMA6, ATAPI 12bytes, PIO 8192bytes)
cd0: 0MB (1 0 byte sectors)
Trying to mount root from ufs:/dev/ada0s1a [rw]...
WARNING: / was not properly dismounted
uhub3: 4 ports with 4 removable, self powered
uhub1: 4 ports with 4 removable, self powered
uhub2: 2 ports with 2 removable, self powered
uhub0: 2 ports with 2 removable, self powered
ugen0.2: <vendor 0x8087 product 0x0024> at usbus0
uhub4 on uhub2
uhub4: <vendor 0x8087 product 0x0024, class 9/0, rev 2.00/0.00, addr 2> on usbus0
ugen3.2: <vendor 0x8087 product 0x0024> at usbus3
uhub5 on uhub0
uhub5: <vendor 0x8087 product 0x0024, class 9/0, rev 2.00/0.00, addr 2> on usbus3
uhub4: 6 ports with 6 removable, self powered
uhub5: 8 ports with 8 removable, self powered
ugen3.3: <Logitech USB Receiver> at usbus3
ukbd0 on uhub5
ukbd0: <Logitech USB Receiver, class 0/0, rev 2.00/12.03, addr 3> on usbus3
kbd2 at ukbd0
ugen0.3: <Generic USB2.0-CRW> at usbus0
umass0 on uhub4
umass0: <Bulk-In, Bulk-Out, Interface> on usbus0
umass0:  SCSI over Bulk-Only; quirks = 0x4000
umass0:6:0: Attached to scbus6
da0 at umass-sim0 bus 0 scbus6 target 0 lun 0
da0: <Generic- Compact Flash 1.00> Removable Direct Access SCSI device
da0: Serial Number 20060413092100000
da0: 40.000MB/s transfers
da0: Attempt to query device size failed: NOT READY, Medium not present
da0: quirks=0x2<NO_6_BYTE>
da1 at umass-sim0 bus 0 scbus6 target 0 lun 1
da1: <Generic- SM/xD-Picture 1.00> Removable Direct Access SCSI device
da1: Serial Number 20060413092100000
da1: 40.000MB/s transfers
da1: Attempt to query device size failed: NOT READY, Medium not present
da1: quirks=0x2<NO_6_BYTE>
da2 at umass-sim0 bus 0 scbus6 target 0 lun 2
da2: <Generic- SD/MMC 1.00> Removable Direct Access SCSI device
da2: Serial Number 20060413092100000
da2: 40.000MB/s transfers
da2: Attempt to query device size failed: NOT READY, Medium not present
da2: quirks=0x2<NO_6_BYTE>
da3 at umass-sim0 bus 0 scbus6 target 0 lun 3
da3: <Generic- MS/MS-Pro/HG 1.00> Removable Direct Access SCSI device
da3: Serial Number 20060413092100000
da3: 40.000MB/s transfers
da3: Attempt to query device size failed: NOT READY, Medium not present
da3: quirks=0x2<NO_6_BYTE>
da4 at umass-sim0 bus 0 scbus6 target 0 lun 4
da4: <Generic- SD/MMC/MS/MSPRO 1.00> Removable Direct Access SCSI device
da4: Serial Number 20060413092100000
da4: 40.000MB/s transfers
da4: Attempt to query device size failed: NOT READY, Medium not present
da4: quirks=0x2<NO_6_BYTE>
lo0: link state changed to UP
ugen3.4: <vendor 0x046d HD Webcam C615> at usbus3
ugen0.4: <Razer Razer BlackWidow Refresh Tournament Edition> at usbus0
ukbd1 on uhub4
ukbd1: <Razer Razer BlackWidow Refresh Tournament Edition, class 0/0, rev 2.00/2.00, addr 4> on usbus0
kbd3 at ukbd1
ukbd2 on uhub4
ukbd2: <Razer Razer BlackWidow Refresh Tournament Edition, class 0/0, rev 2.00/2.00, addr 4> on usbus0
kbd4 at ukbd2
ugen3.5: <vendor 0x0409 product 0x005a> at usbus3
uhub6 on uhub5
uhub6: <vendor 0x0409 product 0x005a, class 9/0, rev 2.00/1.00, addr 5> on usbus3
uhub6: 2 ports with 2 removable, self powered
ugen3.6: <Kensington Kensington USB/PS2 Orbit> at usbus3
ugen3.7: <Bastron Technology Bastron KeyBoard> at usbus3
ukbd3 on uhub5
ukbd3: <Bastron Technology Bastron KeyBoard, class 0/0, rev 2.00/1.00, addr 7> on usbus3
kbd5 at ukbd3
em0: link state changed to UP
ugen3.8: <vendor 0x0cf3 product 0x3000> at usbus3
ums1 on uhub5
ums1: <Logitech USB Receiver, class 0/0, rev 2.00/12.03, addr 3> on usbus3
ums0 on uhub4
ums0: <Razer Razer BlackWidow Refresh Tournament Edition, class 0/0, rev 2.00/2.00, addr 4> on usbus0
ums1: 16 buttons and [XYZT] coordinates ID=2
ums0: 3 buttons and [XYZ] coordinates ID=0
uhid0 on uhub5
uhid0: <Logitech USB Receiver, class 0/0, rev 2.00/12.03, addr 3> on usbus3
ums2 on uhub5
ums2: <Kensington Kensington USB/PS2 Orbit, class 0/0, rev 1.10/5.00, addr 6> on usbus3
ums2: 2 buttons and [XY] coordinates ID=0
uaudio0 on uhub5
uaudio0: <vendor 0x046d HD Webcam C615, class 239/2, rev 2.00/0.11, addr 4> on usbus3
 
OP
OP
knightjp

knightjp

Active Member

Reaction score: 27
Messages: 167

Part 2
Code:
uaudio0: No playback.

uaudio0: Record: 48000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.

uaudio0: Record: 32000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.

uaudio0: Record: 24000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.

uaudio0: Record: 16000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.

uaudio0: No MIDI sequencer.

pcm7: <USB audio> on uaudio0

uaudio0: No HID volume keys found.

pid 10376 (kglobalaccel5), uid 1001: exited on signal 6 (core dumped)

Waiting (max 60 seconds) for system process `vnlru' to stop... done

Waiting (max 60 seconds) for system process `syncer' to stop...

Syncing disks, vnodes remaining... 4 0 done

Waiting (max 60 seconds) for system thread `bufdaemon' to stop... done

Waiting (max 60 seconds) for system thread `bufspacedaemon-1' to stop... done

Waiting (max 60 seconds) for system thread `bufspacedaemon-2' to stop... done

Waiting (max 60 seconds) for system thread `bufspacedaemon-3' to stop... done

Waiting (max 60 seconds) for system thread `bufspacedaemon-0' to stop... done

Waiting (max 60 seconds) for system thread `bufspacedaemon-4' to stop... done

Waiting (max 60 seconds) for system thread `bufspacedaemon-5' to stop... done

Waiting (max 60 seconds) for system thread `bufspacedaemon-6' to stop... done

All buffers synced.

---<<BOOT>>---

Copyright (c) 1992-2018 The FreeBSD Project.

Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994

        The Regents of the University of California. All rights reserved.

FreeBSD is a registered trademark of The FreeBSD Foundation.

FreeBSD 12.0-RELEASE r341666 GENERIC amd64

FreeBSD clang version 6.0.1 (tags/RELEASE_601/final 335540) (based on LLVM 6.0.1)

VT(vga): resolution 640x480

CPU: Intel(R) Core(TM) i5-3330 CPU @ 3.00GHz (3009.88-MHz K8-class CPU)

  Origin="GenuineIntel"  Id=0x306a9  Family=0x6  Model=0x3a  Stepping=9

  Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>

  Features2=0x7fbae3bf<SSE3,PCLMULQDQ,DTES64,MON,DS_CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,TSCDLT,AESNI,XSAVE,OSXSAVE,AVX,F16C,RDRAND>

  AMD Features=0x28100800<SYSCALL,NX,RDTSCP,LM>

  AMD Features2=0x1<LAHF>

  Structured Extended Features=0x281<FSGSBASE,SMEP,ERMS>

  XSAVE Features=0x1<XSAVEOPT>

  VT-x: (disabled in BIOS) PAT,HLT,MTF,PAUSE,EPT,UG,VPID

  TSC: P-state invariant, performance statistics

real memory  = 25769803776 (24576 MB)

avail memory = 24974340096 (23817 MB)

Event timer "LAPIC" quality 600

ACPI APIC Table: <ALASKA A M I>

FreeBSD/SMP: Multiprocessor System Detected: 4 CPUs

FreeBSD/SMP: 1 package(s) x 4 core(s)

random: unblocking device.

ioapic0 <Version 2.0> irqs 0-23 on motherboard

Launching APs: 1 3 2

Timecounter "TSC-low" frequency 1504940916 Hz quality 1000

random: entropy device external interface

kbd1 at kbdmux0

netmap: loaded module

[ath_hal] loaded

module_register_init: MOD_LOAD (vesa, 0xffffffff810f9770, 0) error 19

random: registering fast source Intel Secure Key RNG

random: fast provider: "Intel Secure Key RNG"

nexus0

vtvga0: <VT VGA driver> on motherboard

cryptosoft0: <software crypto> on motherboard

acpi0: <ALASKA A M I> on motherboard

acpi0: Power Button (fixed)

cpu0: <ACPI CPU> on acpi0

hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0

Timecounter "HPET" frequency 14318180 Hz quality 950

Event timer "HPET" frequency 14318180 Hz quality 550

Event timer "HPET1" frequency 14318180 Hz quality 440

Event timer "HPET2" frequency 14318180 Hz quality 440

Event timer "HPET3" frequency 14318180 Hz quality 440

Event timer "HPET4" frequency 14318180 Hz quality 440

atrtc0: <AT realtime clock> port 0x70-0x77 irq 8 on acpi0

atrtc0: Warning: Couldn't map I/O.

atrtc0: registered as a time-of-day clock, resolution 1.000000s

Event timer "RTC" frequency 32768 Hz quality 0

attimer0: <AT timer> port 0x40-0x43,0x50-0x53 irq 0 on acpi0

Timecounter "i8254" frequency 1193182 Hz quality 0

Event timer "i8254" frequency 1193182 Hz quality 100

Timecounter "ACPI-safe" frequency 3579545 Hz quality 850

acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0

acpi_ec0: <Embedded Controller: GPE 0x18> port 0x62,0x66 on acpi0

pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0

pci0: <ACPI PCI bus> on pcib0

pcib1: <ACPI PCI-PCI bridge> irq 16 at device 1.0 on pci0

pci1: <ACPI PCI bus> on pcib1

vgapci0: <VGA-compatible display> port 0xe000-0xe07f mem 0xf6000000-0xf6ffffff,0xe0000000-0xefffffff,0xf0000000-0xf1ffffff irq 16 at device 0.0 on pci1

vgapci0: Boot video device

hdac0: <NVIDIA (0x0fb9) HDA Controller> mem 0xf7080000-0xf7083fff irq 17 at device 0.1 on pci1

pci0: <simple comms> at device 22.0 (no driver attached)

em0: <Intel(R) PRO/1000 Network Connection> port 0xf040-0xf05f mem 0xf7600000-0xf761ffff,0xf7629000-0xf7629fff irq 20 at device 25.0 on pci0

em0: attach_pre capping queues at 1

em0: using 1024 tx descriptors and 1024 rx descriptors

em0: msix_init qsets capped at 1

em0: Unable to map MSIX table

em0: Using an MSI interrupt

em0: allocated for 1 tx_queues

em0: allocated for 1 rx_queues

em0: Ethernet address: c8:60:00:73:40:da

em0: netmap queues/slots: TX 1/1024, RX 1/1024

ehci0: <Intel Cougar Point USB 2.0 controller> mem 0xf7628000-0xf76283ff irq 16 at device 26.0 on pci0

usbus0: EHCI version 1.0

usbus0 on ehci0

usbus0: 480Mbps High Speed USB v2.0

hdac1: <Intel Cougar Point HDA Controller> mem 0xf7620000-0xf7623fff irq 22 at device 27.0 on pci0

pcib2: <ACPI PCI-PCI bridge> irq 16 at device 28.0 on pci0

pcib2: [GIANT-LOCKED]

pcib3: <ACPI PCI-PCI bridge> irq 17 at device 28.1 on pci0

pci2: <ACPI PCI bus> on pcib3

xhci0: <ASMedia ASM1042 USB 3.0 controller> mem 0xf7500000-0xf7507fff irq 17 at device 0.0 on pci2

xhci0: 32 bytes context size, 32-bit DMA

xhci0: Unable to map MSI-X table

usbus1 on xhci0

usbus1: 5.0Gbps Super Speed USB v3.0

pcib4: <ACPI PCI-PCI bridge> irq 19 at device 28.3 on pci0

pci3: <ACPI PCI bus> on pcib4

atapci0: <JMicron JMB362 SATA300 controller> port 0xd040-0xd047,0xd030-0xd033,0xd020-0xd027,0xd010-0xd013,0xd000-0xd00f mem 0xf7410000-0xf74101ff irq 19 at device 0.0 on pci3

ahci0: <JMicron JMB362 AHCI SATA controller> at channel -1 on atapci0

ahci0: AHCI v1.10 with 2 3Gbps ports, Port Multiplier supported

ahcich0: <AHCI channel> at channel 0 on ahci0

ahcich1: <AHCI channel> at channel 1 on ahci0

pcib5: <ACPI PCI-PCI bridge> irq 16 at device 28.4 on pci0

pci4: <ACPI PCI bus> on pcib5

xhci1: <ASMedia ASM1042 USB 3.0 controller> mem 0xf7300000-0xf7307fff irq 16 at device 0.0 on pci4

xhci1: 32 bytes context size, 32-bit DMA

xhci1: Unable to map MSI-X table

usbus2 on xhci1

usbus2: 5.0Gbps Super Speed USB v3.0

pcib6: <ACPI PCI-PCI bridge> irq 18 at device 28.6 on pci0

pci5: <ACPI PCI bus> on pcib6

pcib7: <ACPI PCI-PCI bridge> irq 18 at device 0.0 on pci5

pci6: <ACPI PCI bus> on pcib7

pci6: <serial bus, FireWire> at device 2.0 (no driver attached)

pcib8: <ACPI PCI-PCI bridge> irq 19 at device 28.7 on pci0

pci7: <ACPI PCI bus> on pcib8

ahci1: <Marvell 88SE9172 AHCI SATA controller> port 0xb040-0xb047,0xb030-0xb033,0xb020-0xb027,0xb010-0xb013,0xb000-0xb00f mem 0xf7110000-0xf71101ff irq 19 at device 0.0 on pci7

ahci1: AHCI v1.00 with 2 6Gbps ports, Port Multiplier supported with FBS

ahcich2: <AHCI channel> at channel 0 on ahci1

ahcich3: <AHCI channel> at channel 1 on ahci1

ehci1: <Intel Cougar Point USB 2.0 controller> mem 0xf7627000-0xf76273ff irq 23 at device 29.0 on pci0

usbus3: EHCI version 1.0

usbus3 on ehci1

usbus3: 480Mbps High Speed USB v2.0

isab0: <PCI-ISA bridge> at device 31.0 on pci0

isa0: <ISA bus> on isab0

ahci2: <Intel Cougar Point AHCI SATA controller> port 0xf090-0xf097,0xf080-0xf083,0xf070-0xf077,0xf060-0xf063,0xf020-0xf03f mem 0xf7626000-0xf76267ff irq 19 at device 31.2 on pci0

ahci2: AHCI v1.30 with 6 6Gbps ports, Port Multiplier not supported

ahcich6: <AHCI channel> at channel 2 on ahci2

ahciem0: <AHCI enclosure management bridge> on ahci2

acpi_button0: <Power Button> on acpi0

acpi_tz0: <Thermal Zone> on acpi0

acpi_tz1: <Thermal Zone> on acpi0

orm0: <ISA Option ROM> at iomem 0xce800-0xd17ff pnpid ORM0000 on isa0

atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0

atkbd0: <AT Keyboard> irq 1 on atkbdc0

kbd0 at atkbd0

atkbd0: [GIANT-LOCKED]

atkbdc0: non-PNP ISA device will be removed from GENERIC in FreeBSD 12.

est0: <Enhanced SpeedStep Frequency Control> on cpu0

Timecounters tick every 1.000 msec

hdacc0: <NVIDIA (0x0080) HDA CODEC> at cad 0 on hdac0

hdaa0: <NVIDIA (0x0080) Audio Function Group> at nid 1 on hdacc0

pcm0: <NVIDIA (0x0080) (HDMI/DP 8ch)> at nid 4 on hdaa0

pcm1: <NVIDIA (0x0080) (HDMI/DP 8ch)> at nid 5 on hdaa0

pcm2: <NVIDIA (0x0080) (HDMI/DP 8ch)> at nid 6 on hdaa0

hdacc1: <Realtek ALC892 HDA CODEC> at cad 0 on hdac1

hdaa1: <Realtek ALC892 Audio Function Group> at nid 1 on hdacc1

pcm3: <Realtek ALC892 (Rear Analog 7.1/2.0)> at nid 20,22,21,23 and 24,26 on hdaa1

pcm4: <Realtek ALC892 (Front Analog)> at nid 27 and 25 on hdaa1

pcm5: <Realtek ALC892 (Rear Digital)> at nid 30 on hdaa1

pcm6: <Realtek ALC892 (Onboard Digital)> at nid 17 on hdaa1

ugen1.1: <0x1b21 XHCI root HUB> at usbus1

ugen3.1: <Intel EHCI root HUB> at usbus3

ugen2.1: <0x1b21 XHCI root HUB> at usbus2

ugen0.1: <Intel EHCI root HUB> at usbus0

uhub0: <0x1b21 XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus1

uhub1: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus3

uhub2: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus0

uhub3: <0x1b21 XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus2

ada0 at ahcich6 bus 0 scbus4 target 0 lun 0

ada0: <WDC WD5000AAKX-60U6AA0 18.01H18> ATA8-ACS SATA 3.x device

ada0: Serial Number WD-WCC2EPD09762

ada0: 300.000MB/s transfers (SATA 2.x, UDMA5, PIO 8192bytes)

ada0: Command Queueing enabled

ada0: 476940MB (976773168 512 byte sectors)

ses0 at ahciem0 bus 0 scbus5 target 0 lun 0

ses0: <AHCI SGPIO Enclosure 1.00 0001> SEMB S-E-S 2.00 device

ses0: SEMB SES Device

cd0 at ahcich3 bus 0 scbus3 target 0 lun 0

cd0: <HL-DT-ST DVDRAM GH24NSC0 LK00> Removable CD-ROM SCSI device

cd0: Serial Number K4BE6ME3405

cd0: 150.000MB/s transfers (SATA 1.x, UDMA6, ATAPI 12bytes, PIO 8192bytes)

cd0: 0MB (1 0 byte sectors)

Trying to mount root from ufs:/dev/ada0s1a [rw]...

uhub0: 4 ports with 4 removable, self powered

uhub3: 4 ports with 4 removable, self powered

uhub1: 2 ports with 2 removable, self powered

uhub2: 2 ports with 2 removable, self powered

ugen3.2: <vendor 0x8087 product 0x0024> at usbus3

uhub4 on uhub1

uhub4: <vendor 0x8087 product 0x0024, class 9/0, rev 2.00/0.00, addr 2> on usbus3

ugen0.2: <vendor 0x8087 product 0x0024> at usbus0

uhub5 on uhub2

uhub5: <vendor 0x8087 product 0x0024, class 9/0, rev 2.00/0.00, addr 2> on usbus0

nvidia0: <GeForce GTX 1050> on vgapci0

vgapci0: child nvidia0 requested pci_enable_io

vgapci0: child nvidia0 requested pci_enable_io

nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  390.87  Tue Aug 21 15:53:31 PDT 2018

uhub5: 6 ports with 6 removable, self powered

lo0: link state changed to UP

uhub4: 8 ports with 8 removable, self powered

ugen3.3: <Logitech USB Receiver> at usbus3

ukbd0 on uhub4

ukbd0: <Logitech USB Receiver, class 0/0, rev 2.00/12.03, addr 3> on usbus3

kbd2 at ukbd0

ugen0.3: <Generic USB2.0-CRW> at usbus0

umass0 on uhub5

umass0: <Bulk-In, Bulk-Out, Interface> on usbus0

umass0:  SCSI over Bulk-Only; quirks = 0x4000

umass0:6:0: Attached to scbus6

da0 at umass-sim0 bus 0 scbus6 target 0 lun 0

da0: <Generic- Compact Flash 1.00> Removable Direct Access SCSI device

da0: Serial Number 20060413092100000

da0: 40.000MB/s transfers

da0: Attempt to query device size failed: NOT READY, Medium not present

da0: quirks=0x2<NO_6_BYTE>

da1 at umass-sim0 bus 0 scbus6 target 0 lun 1

da1: <Generic- SM/xD-Picture 1.00> Removable Direct Access SCSI device

da1: Serial Number 20060413092100000

da1: 40.000MB/s transfers

da1: Attempt to query device size failed: NOT READY, Medium not present

da1: quirks=0x2<NO_6_BYTE>

da2 at umass-sim0 bus 0 scbus6 target 0 lun 2

da2: <Generic- SD/MMC 1.00> Removable Direct Access SCSI device

da2: Serial Number 20060413092100000

da2: 40.000MB/s transfers

da2: Attempt to query device size failed: NOT READY, Medium not present

da2: quirks=0x2<NO_6_BYTE>

da3 at umass-sim0 bus 0 scbus6 target 0 lun 3

da3: <Generic- MS/MS-Pro/HG 1.00> Removable Direct Access SCSI device

da3: Serial Number 20060413092100000

da3: 40.000MB/s transfers

da3: Attempt to query device size failed: NOT READY, Medium not present

da3: quirks=0x2<NO_6_BYTE>

da4 at umass-sim0 bus 0 scbus6 target 0 lun 4

da4: <Generic- SD/MMC/MS/MSPRO 1.00> Removable Direct Access SCSI device

da4: Serial Number 20060413092100000

da4: 40.000MB/s transfers

da4: Attempt to query device size failed: NOT READY, Medium not present

da4: quirks=0x2<NO_6_BYTE>

ugen3.4: <vendor 0x046d HD Webcam C615> at usbus3

ugen0.4: <Razer Razer BlackWidow Refresh Tournament Edition> at usbus0

ukbd1 on uhub5

ukbd1: <Razer Razer BlackWidow Refresh Tournament Edition, class 0/0, rev 2.00/2.00, addr 4> on usbus0

kbd3 at ukbd1

ukbd2 on uhub5

ukbd2: <Razer Razer BlackWidow Refresh Tournament Edition, class 0/0, rev 2.00/2.00, addr 4> on usbus0

kbd4 at ukbd2

ugen3.5: <vendor 0x0409 product 0x005a> at usbus3

uhub6 on uhub4

uhub6: <vendor 0x0409 product 0x005a, class 9/0, rev 2.00/1.00, addr 5> on usbus3

uhub6: 2 ports with 2 removable, self powered

em0: link state changed to UP

ugen3.6: <Kensington Kensington USB/PS2 Orbit> at usbus3

ugen3.7: <Bastron Technology Bastron KeyBoard> at usbus3

ukbd3 on uhub4

ukbd3: <Bastron Technology Bastron KeyBoard, class 0/0, rev 2.00/1.00, addr 7> on usbus3

kbd5 at ukbd3

ugen3.8: <vendor 0x0cf3 product 0x3000> at usbus3

ums1 on uhub4

ums1: <Logitech USB Receiver, class 0/0, rev 2.00/12.03, addr 3> on usbus3

ums0 on uhub5

ums0: <Razer Razer BlackWidow Refresh Tournament Edition, class 0/0, rev 2.00/2.00, addr 4> on usbus0

ums1: 16 buttons and [XYZT] coordinates ID=2

ums0: 3 buttons and [XYZ] coordinates ID=0

uhid0 on uhub4

uhid0: <Logitech USB Receiver, class 0/0, rev 2.00/12.03, addr 3> on usbus3

ums2 on uhub4

ums2: <Kensington Kensington USB/PS2 Orbit, class 0/0, rev 1.10/5.00, addr 6> on usbus3

ums2: 2 buttons and [XY] coordinates ID=0

uaudio0 on uhub4

uaudio0: <vendor 0x046d HD Webcam C615, class 239/2, rev 2.00/0.11, addr 4> on usbus3

uaudio0: No playback.

uaudio0: Record: 48000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.

uaudio0: Record: 32000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.

uaudio0: Record: 24000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.

uaudio0: Record: 16000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.

uaudio0: No MIDI sequencer.

pcm7: <USB audio> on uaudio0

uaudio0: No HID volume keys found.
 
OP
OP
knightjp

knightjp

Active Member

Reaction score: 27
Messages: 167

Here is my "usbconfig"
Code:
ugen1.1: <0x1b21 XHCI root HUB> at usbus1, cfg=0 md=HOST spd=SUPER (5.0Gbps) pwr=SAVE (0mA)
ugen3.1: <Intel EHCI root HUB> at usbus3, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE (0mA)
ugen2.1: <0x1b21 XHCI root HUB> at usbus2, cfg=0 md=HOST spd=SUPER (5.0Gbps) pwr=SAVE (0mA)
ugen0.1: <Intel EHCI root HUB> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE (0mA)
ugen3.2: <vendor 0x8087 product 0x0024> at usbus3, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE (0mA)
ugen0.2: <vendor 0x8087 product 0x0024> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE (0mA)
ugen3.3: <Logitech USB Receiver> at usbus3, cfg=0 md=HOST spd=FULL (12Mbps) pwr=ON (98mA)
ugen0.3: <Generic USB2.0-CRW> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON (500mA)
ugen3.4: <vendor 0x046d HD Webcam C615> at usbus3, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON (500mA)
ugen0.4: <Razer Razer BlackWidow Refresh Tournament Edition> at usbus0, cfg=0 md=HOST spd=FULL (12Mbps) pwr=ON (100mA)
ugen3.5: <vendor 0x0409 product 0x005a> at usbus3, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE (100mA)
ugen3.6: <Kensington Kensington USB/PS2 Orbit> at usbus3, cfg=0 md=HOST spd=LOW (1.5Mbps) pwr=ON (100mA)
ugen3.7: <Bastron Technology Bastron KeyBoard> at usbus3, cfg=0 md=HOST spd=FULL (12Mbps) pwr=ON (500mA)
ugen3.8: <vendor 0x0cf3 product 0x3000> at usbus3, cfg=0 md=HOST spd=FULL (12Mbps) pwr=ON (100mA)
At the moment, I'm making MacOS my primary until I can find a solution to this. Can't be all bad. It's got BSD code as a base. Plus it works with my keyboard and the trackballs.
 

olli@

Well-Known Member
Developer

Reaction score: 315
Messages: 375

Your keyboard is recognized fine:
Code:
ukbd3: <Bastron Technology Bastron KeyBoard, class 0/0, rev 2.00/1.00, addr 7> on usbus3
Have you tried attaching it? Please see the kbdcontrol(1) manual page, it explains everything you need to know. You can either change the console keyboard from the standard AT keyboard to the USB keyboard, or you can even use both at the same time. I think the manual page even contains an example for the latter.
 
OP
OP
knightjp

knightjp

Active Member

Reaction score: 27
Messages: 167

olli@ I read the manual you suggested. But I cannot make sense of it. Perhaps it will take some time for me to figure it out.
 

RichardM

Member

Reaction score: 19
Messages: 48

Try the following to attach your keyboard:
Code:
/usr/sbin/kbdcontrol -a /dev/ukbd3 < /dev/kbdmux0
and the following to detach:
Code:
/usr/sbin/kbdcontrol -A /dev/ukbd3 < /dev/kbdmux0
Once you have it working you can then create devd rules in /usr/local/etc/devd so devd attaches and detaches when the keyboard is plugged in.

However, I notice you have webcamd running - it may be possible webcamd is trying to attach to the keyboard first, so please could you try restarting without webcamd running? You may also have to rename /usr/local/etc/devd/webcamd.conf temporarily to stop devd from trying to run webcamd when the keyboard is plugged in.
 
Top