usb and dvd mount issues

S

Sante

Guest


Hello to everyone, salvaged one pc (intel dual core 2.6 ghz, old but not ancient, with a nvidia 8300gs card and an asus mb, no hd) from being literally tossed into a pile of metal rubbish so I thought time was right to learn a new system: the Right Honorable FreeBSD. I needed a pc to get rsync backups in my lan and that's what i did. Also, installed KDE cause I'm a fan :) but soon realized it's an entirely new world from Linux.
In my first install (11.2) I attempted to get r/w access to usb sticks and use k3b to burn dvds.Let's say I had a hard luck, at first succeeded partially having kde mount my sticks (can't fathom how) but later dealing with k3b a series of crashes and no proper knowledge about how to fix a corrupted fs doomed my install. Ok let's do it all again.

2nd install- this time release 12, (the first attempt also doomed by a 2 hr total power outage :\ ...forgot to hook it to a ups. curses start kicking in) I am back with a working system. Then I managed to gain proper permissions on /dev/usb/* , /dev/cd0 , /dev/pass* and /dev /xpt0 editing /etc/devfs.rules and /etc/devfs.conf ). I am in groups wheel and operator and all of them have 660 permissions for root-operator . All right ? no. Even when my usb sticks show up in the device notification area, kde says i don't have permissions to mount them. I can have some dvd mounted by kde, others cannot even be mounted manually by root because it says "operation not supported by device" WHT ? it is a knoppix live cd , it is iso9660 not even UDF.

First important question: So, I realize that da0 and da0s1 yes, now belong to group operator but only the owner (root) has rw access and I cannot understand how to apply a rule that makes them permission 660 . Now I at least can mount a stick as root into a directory in my home, not the best. my devfs.rules configuration is below. How can I get da0, da0s1 to be created with rw permissions for group operator ? Is there another conf file that is conflicting with this ? I'm as clueless as Terry Davis' cockatoo watching his pc screen. Except for the bird thoughts.

So I grasp the fact that even with kde (an hald and the rest) running, mounting those pendrives can be done in different ways , using HAL or automount but I am having a hard time understanding :1) which one should i use ? 2) what is my situation right now ? I fear that applying practically every hint I found around now my system is an unholy mix of both worlds.
my rc.conf:
Code:
clear_tmp_enable="YES"
...
sshd_enable="YES"
moused_enable="YES"
ntpd_enable="YES"
powerd_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
hald_enable="YES"
linux_enable="YES"
devd_enable="YES"
powerd_enable="YES"
devfs_system_ruleset="localrules"
dbus_enable="YES"
sddm_enable="yes"
devfs.conf:
Code:
...
own     /dev/da0        root:operator
perm    /dev/da00       0666                        [B]   ---> (da00 ? shouldn't be something like /dev/da0* ? what syntax is that? )[/B]

# permetti anche di montare /dev/cd0
own     /dev/cd0        root:operator
perm    /dev/cd0        0660
own     /dev/xpt0       root:operator
perm    /dev/xpt0       0660
devfs.rules:
Code:
...
[localrules=5]
add path 'da*' mode 0660 group operator               [B]----> (tried da*, da*s*, no effect)[/B]
[localrules=10]
add path 'usb/*' mode 0660 group operator
add path 'msdosfs/*' mode 0660 group operator
add path 'pass*' mode 0660 group operator
(btw, those localrules numbers... how are them supposed to be ? found nothing anywhere)

auto_master:
Code:
#/media         -media          -nosuid   ----> commented back this attempting to only use hal
#/-             -noauto
devd.conf contains:
Code:
notify 100 {
        match "system" "GEOM";
        match "subsystem" "DEV";
        action "/usr/sbin/automount -c";
};
And now to the really painful issue: the dvd drive sucks at reading disks, but that's all about it. but if I try to write a disk it gets stuck in continuous read errors that freeze the system so bad, I can't even issue a reboot command from another machine with ssh. In a futile attempt to break the evil loop I even pin-ejected the disk , but in the end a hard reset was the only option. So the filesystem broke again but this time I knew how to *properly* fsck as single user. Now the machine is again operative and taking those damn snapshots of my computers, kde is there, i can somewhat use an usb stick, but I find baffling that k3b (configured as suggested with cdrecord and cdrdao suid) can pull the entire system down in flames just for daring to access a dvd.
Is this... normal for FreeBSD or due to failing hardware , misconfiguration ? Also that drive is not a normal drive but a LG GH22NS50 , a damned drive in which his wretched creator inserted a virtual disk that pops up when the tray is closed but empty, showing exe files that are in fact only bloatware and spam: bluebirds.exe and other stupid demo games. Yes I know, it is preposterous. I suspect that this particular drive could be the reason for all the havoc and maybe there is a reason why the previous owner tossed it into a truck heading to the dump... maybe it has devils in it.
Sounds like a cheesy plot for a geek horror movie.

Sorry for the lenghty post. I tried hard to keep it compact.
 
Last edited by a moderator:

Trihexagonal

Daemon

Reaction score: 1,013
Messages: 1,684

I manually mount my devices as root. This is what I have:

/etc/devfs.conf
Code:
# Allow all users to access CD's
perm    /dev/acd0    0666
perm    /dev/acd1    0666
perm    /dev/cd0    0666
perm    /dev/cd1    0666

# Allow all USB Devices to be mounted
perm    /dev/da0    0666
perm    /dev/da1    0666
perm    /dev/da2    0666
perm    /dev/da3    0666
/etc/devfs.rules
Code:
[devfsrules_common=7]
add path 'acd*' mode 0666 group operator
add path 'cd*' mode 0666 group operator
add path 'da*' mode 0666 group operator
add path 'usb*' mode 0666 group operator
add path 'video*' mode 0666 group operator
/etc/rc.conf
Code:
devd_enable="YES"
devfs_system_ruleset="devfsrules_common"
 
OP
OP
S

Sante

Guest


Well I can do that too. The point is that i'm trying to have them mounted without going su and also how to change those permissions.
 

Trihexagonal

Daemon

Reaction score: 1,013
Messages: 1,684

Well I can do that too. The point is that i'm trying to have them mounted without going su and also how to change those permissions.
I provided the correct syntax for the files in question and an example of how to format your posts in doing so. Neither of which you had done correctly.
 
Top