• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Upgrading apache22 to apache24

ProServ

Member

Thanks: 1
Messages: 76

#1
The fix was very simple. Enable ssl module in http.conf

The .conf we use for apache22 seems to have problems with the following
Code:
SSLRandomSeed startup file:/dev/random  512
SSLRandomSeed connect file:/dev/urandom 512
SSLPassPhraseDialog  builtin
SSLSessionCache         dbm:/var/run/ssl_scache
SSLSessionCacheTimeout  300
SSLMutex  file:/var/run/ssl_mutex
SSLEngine on
There are probably more since this all relates to SSL. There is no mod_ssl in /usr/ports.

When building apache24, SSL was checked.

What might we need to do?
Thanks for your help.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 5,476
Messages: 25,636

#2
Enable mod_ssl, the module is there, just not enabled.

Create a /usr/local/etc/apache24/modules.d/000_ssl.conf:
Code:
LoadModule ssl_module libexec/apache24/mod_ssl.so