upgrade xorg from ports on freebsd

ccc

Aspiring Daemon

Reaction score: 13
Messages: 621

hi

howto upgrade xorg from ports on freebsd 7.0-RELEASE ?
I have xorg-7.3_2 installed.
 
OP
C

ccc

Aspiring Daemon

Reaction score: 13
Messages: 621

thx, I'll try the following:
Code:
20070519:
  AFFECTS: users of Xorg
  AUTHOR: kris@FreeBSD.org

  Welcome, fearless user!  You are about to embark upon a mystical
  journey to the world of xorg 7.2.

  This upgrade procedure is for users of portupgrade.  Users of other
  upgrade tools should contact the author for the corresponding upgrade
  method for that tool.

  It is recommended that you run the xorg 7.2 upgrade inside a script(1)
  session.  This way, if something goes wrong, you will have hopefully
  saved enough information for the developers to debug the problem.
  Make sure you choose a filesystem with lots of space for the script
  output.

	# script xorg-upgrade

  You may wish to set BATCH=yes in the environment to avoid interactive
  dialogue boxes.

  You may want to consider using portupgrade-devel, which fixes some
  annoying bugs that cause upgrades to incorrectly be marked as failed
  when they actually completed successfully.  To switch to
  portupgrade-devel:

	# portupgrade -f -o ports-mgmt/portupgrade-devel portupgrade
	# rm -f /usr/ports/INDEX*.db /var/db/pkg/pkgdb.db
	# pkgdb -fu

  If you have changed your ports environment in /etc/make.conf,
  /usr/local/etc/pkgtools.conf or similar you need to rebuild INDEX:

	# cd /usr/ports && make index

  If you have not changed your ports environment you can save some
  time and just fetch the latest INDEX:

	# cd /usr/ports && make fetchindex

  It is necessary to set the XORG_UPGRADE environment variable while
  updating from xorg 6.9 to 7.2.  Once the upgrade is complete this
  is no longer be required.

  For users of csh-like shells:
  # setenv XORG_UPGRADE yes

  For users of sh-like shells:
  # export XORG_UPGRADE=yes

  Unfortunately portupgrade (nor portupgrade-devel) cannot yet handle
  the rigors of the xorg upgrade without a small bit of help:

	# portupgrade -Rf libXft

  If your machine does NOT have any gstreamer ports installed, you can then
  run:

	# portupgrade -a

  However, if you DO have gstreamer ports installed, you must run:

	# portupgrade -a -x 'gstreamer*'

  Followed by:

	# portupgrade -Rr 'gstreamer*'

  When packages are available (wait for the announcement on ports@), you
  may prefer to use precompiled packages to speed up the process:

	# portupgrade -aP

  Once the upgrade completes successfully, you can delete the
  xorg-manpages package, which is now orphaned.

	# pkg_delete xorg-manpages\*

  The final step is to merge remaining files from /usr/X11R6 into
  /usr/local (/usr/X11R6 is no longer used with xorg 7.2) and replace
  /usr/X11R6 with a symlink.

  A script is provided for your convenience (or you may choose to do
  this by hand): it will first attempt to back up your /usr/X11R6 into
  /usr/tmp/mergebase in case something goes wrong, then look for
  conflicts (files in /usr/X11R6 that would overwrite files in
  /usr/local).  Depending on your system configuration you may have to
  resolve some of these conflicts by hand first (if in doubt, ask for
  help on freebsd-x11@FreeBSD.org).  You may also need to edit the
  script if the default locations are not correct on your system.

  If your /usr/X11R6 is a file system, you will also need to modify the
  script to pause after /usr/X11R6 is backed up, but before the symlink is
  created.

  # sh /usr/ports/Tools/scripts/mergebase.sh

  When the merge operation completes successfully, the /usr/X11R6
  directory hierarchy will be removed and replaced by a symlink to
  /usr/local.  This symlink is necessary because some binary ports (and
  some remaining source ports) have hard-coded references to /usr/X11R6.

  Congratulations, you are done!

  # exit
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 2,954
Messages: 11,351

Because 7.2 was a major and drastic upgrade due to changing the default path for xorg and having to rebuild almost everything depending on it or pointing to it.
 
OP
C

ccc

Aspiring Daemon

Reaction score: 13
Messages: 621

then what can I do ?

I have some problems to install gui packages like wireshark.

after portupgrade -faP , I'm getting the following:
Code:
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        - security/pecl-hash (marked as IGNORE)
        - devel/pecl-json (marked as IGNORE)
        - x11-drivers/xf86-video-vga (marked as IGNORE)
        - x11-drivers/xf86-video-via (marked as IGNORE)
        - x11/xphelloworld (port directory error)
        [color="Red"]! devel/linux-glib2     (port directory error)
        ! devel/autoconf261     (port directory error)[/color]
        * devel/autoconf261
        * devel/autoconf261
        * devel/autoconf261
        * devel/autoconf261
        * devel/autoconf261
        * devel/autoconf261
        [color="Red"][color="Red"]! x11/libX11 (libX11-1.1.3_1,1) (configure error)[/color][/color]
        * x11/libxkbfile (libxkbfile-1.0.4)
        * x11/mkcomposecache (mkcomposecache-1.2_1)
        * x11/libXext (libXext-1.0.3,1)
        * x11/libXxf86vm (libXxf86vm-1.0.1)
        * x11/libXxf86dga (libXxf86dga-1.0.2)
        * x11/rgb (rgb-1.0.1)
        * x11-toolkits/tk84 (tk-8.4.19,2)
        * devel/dbus (dbus-1.2.1)
        * x11-fonts/libXfontcache (libXfontcache-1.0.4)
        * x11/xrefresh (xrefresh-1.0.2)
        * x11/libXtst (libXtst-1.0.3_1)
        * x11-fonts/xfs (xfs-1.0.5_1,1)
        * x11/libXv (libXv-1.0.3_1,1)
        * x11-toolkits/libXt (libXt-1.0.5_1)
        * x11-fonts/fslsfonts (fslsfonts-1.0.1)
        * x11/appres (appres-1.0.1)
        * x11/libXScrnSaver (libXScrnSaver-1.1.2)
        * devel/dbus-glib (dbus-glib-0.74_1)
        * graphics/libflash (libflash-0.4.13_3)
        * x11/sessreg (sessreg-1.0.3)
        * x11/libXi (libXi-1.1.3,1)
        * x11/libXxf86misc (libXxf86misc-1.0.1)
        * x11/xkbevd (xkbevd-1.0.2)
        * print/ghostscript8 (ghostscript-gpl-8.62_2)
        * x11/xinit (xinit-1.0.7)
        * sysutils/policykit (policykit-0.8_2)
        * sysutils/consolekit (consolekit-0.2.10_1)
        * x11/xgamma (xgamma-1.0.2)
        * x11/xkbprint (xkbprint-1.0.1)
        * x11/fstobdf (fstobdf-1.0.2)
        * x11-toolkits/libXmu (libXmu-1.0.3,1)
        * x11/xsetpointer (xsetpointer-1.0.1)
        * x11/libXpm (libXpm-3.5.7)
        * sysutils/hal (hal-0.5.11_1)
        * x11/trapproto (trapproto-3.4.3)
        * x11/libXvMC (libXvMC-1.0.4_1)
        * www/flashplugin-mozilla (flashplugin-mozilla-0.4.13_2)
        * x11/libXinerama (libXinerama-1.0.2,1)
        * x11/libXevie (libXevie-1.0.2)
        * x11/xkill (xkill-1.0.1)
        * x11/libdmx (libdmx-1.0.2_1)
        * x11/xwud (xwud-1.0.1)
        * x11/xwd (xwd-1.0.1)
        * x11/ico (ico-1.0.2)
        * x11/xwininfo (xwininfo-1.0.3)
        * x11/xset (xset-1.0.3)
        * x11/xlsclients (xlsclients-1.0.1)
        * x11/rstart (rstart-1.0.2)
        * x11/libXp (libXp-1.0.0,1)
        * x11/xprop (xprop-1.0.3)
        * x11/oclock (oclock-1.0.1)
        * x11/setxkbmap (setxkbmap-1.0.4)
        * x11/libXprintUtil (libXprintUtil-1.0.1)
        * x11/xsetmode (xsetmode-1.0.0)
        * x11/xev (xev-1.0.2)
        * x11/xkbcomp (xkbcomp-1.0.3)
        * x11/xvinfo (xvinfo-1.0.2)
        * x11/libXrender (libXrender-0.9.4_1)
        * x11/xrdb (xrdb-1.0.4)
        * x11/xhost (xhost-1.0.2)
        * x11-fonts/xlsfonts (xlsfonts-1.0.2)
        * x11-fonts/libXft (libXft-2.1.13)
        * x11/libXres (libXres-1.0.3_3)
        * x11/libxkbui (libxkbui-1.0.2_1)
        * x11/xdpyinfo (xdpyinfo-1.0.2_1)
        * x11/libXrandr (libXrandr-1.2.2_1)
        * x11/xfindproxy (xfindproxy-1.0.1)
        * x11/xsetroot (xsetroot-1.0.2)
        * x11/xrandr (xrandr-1.2.2)
        * x11/xauth (xauth-1.0.2)
        * x11/luit (luit-1.0.2_2)
        * net/rdesktop (rdesktop-1.6.0)
        * graphics/libwmf (libwmf-0.2.8.4_2)
        * graphics/cairo (cairo-1.6.4_3,1)
        * x11-toolkits/pango (pango-1.20.5)
        * graphics/poppler (poppler-0.6.4_1)
        * x11/libXprintAppUtil (libXprintAppUtil-1.0.1)
        * x11-toolkits/libXaw (libXaw-1.0.4_1,1)
        * graphics/py-cairo (py25-cairo-1.4.12)
        * x11/listres (listres-1.0.1)
        * x11/beforelight (beforelight-1.0.2)
        * x11/xfd (xfd-1.0.1)
        * x11/xload (xload-1.0.2)
        * x11/viewres (viewres-1.0.1)
        * x11/bitmap (bitmap-1.0.3)
        * x11/xmag (xmag-1.0.2)
        * x11/xlogo (xlogo-1.0.1)
        * x11/smproxy (smproxy-1.0.2)
        * x11/xedit (xedit-1.0.2)
        * databases/rrdtool (rrdtool-1.3.3)
        * net-mgmt/cacti (cacti-0.8.7b.2_2)
        * x11-toolkits/open-motif (open-motif-2.2.3_5)
        * x11/xconsole (xconsole-1.0.3)
        * x11/xlsatoms (xlsatoms-1.0.1)
        * x11/xmodmap (xmodmap-1.0.3)
        * x11/xvidtune (xvidtune-1.0.1)
        * java/jdk16 (jdk-1.6.0.3p4_2)
        * x11/xmessage (xmessage-1.0.2)
        * x11/xgc (xgc-1.0.1)
        * x11-fonts/xfsinfo (xfsinfo-1.0.1)
        * x11/x11perf (x11perf-1.4.1)
        * x11/xsm (xsm-1.0.1)
        * x11/liboldX (liboldX-1.0.1)
        * x11/xdm (xdm-1.1.6_3)
        * x11/xmore (xmore-1.0.1)
        * x11/editres (editres-1.0.3)
        * x11/xprehashprinterlist (xprehashprinterlist-1.0.1)
        * x11/xf86dga (xf86dga-1.0.2)
        * x11/xcmsdb (xcmsdb-1.0.1)
        * x11/xpr (xpr-1.0.2)
        * lang/php5-extensions (php5-extensions-1.1)
        * x11/xclipboard (xclipboard-1.0.1)
        * x11/xterm (xterm-235)
        * x11/xdbedizzy (xdbedizzy-1.0.2)
        * x11/xstdcmap (xstdcmap-1.0.1)
        * graphics/graphviz (graphviz-2.20.2)
        * devel/t1lib (t1lib-5.1.2,1)
        * print/teTeX-base (teTeX-base-3.0_13)
        * x11/scripts (scripts-1.0.1)
        * graphics/php5-gd (php5-gd-5.2.6)
        * x11/xkbutils (xkbutils-1.0.1_1)
        * x11-fonts/xfontsel (xfontsel-1.0.2)
        * x11/xcalc (xcalc-1.0.2)
        * x11/xeyes (xeyes-1.0.1)
        * x11/xman (xman-1.0.3)
        * x11/xditview (xditview-1.0.1)
        * x11/libXTrap (libXTrap-1.0.0)
        * x11/xplsprinters (xplsprinters-1.0.1)
        * x11/xtrap (xtrap-1.0.2)
        * net/ntop (ntop-3.3.8)
        * x11/libXfixes (libXfixes-4.0.3_1)
        * x11-clocks/xclock (xclock-1.0.3)
        * x11/libXcomposite (libXcomposite-0.4.0,1)
        * x11/xbiff (xbiff-1.0.1)
        * x11/libXdamage (libXdamage-1.1.1)
        * x11/xrx (xrx-1.0.1_1)
        * graphics/libGL (libGL-7.0.3)
        * graphics/libGLU (libGLU-7.0.3)
        * graphics/libglut (libglut-7.0.1_1)
        * graphics/GraphicsMagick (GraphicsMagick-1.1.12)
        * x11/libXcursor (libXcursor-1.1.9_1)
        * x11-toolkits/gtk20 (gtk-2.14.7)
        * x11/xorg-libraries (xorg-libraries-7.3_2)
        * x11/xdriinfo (xdriinfo-1.0.2)
        * x11/xcursorgen (xcursorgen-1.0.2)
        * devel/gconf2 (gconf2-2.22.0_1)
        * ftp/gftp (gftp-2.0.18_7)
        * net/wireshark (wireshark-1.0.5)
        * www/seamonkey (seamonkey-1.1.9_1)
        * devel/libglade2 (libglade2-2.6.2_1)
        * audio/nas (nas-1.8_1)
        * x11-toolkits/py-gtk2 (py25-gtk-2.12.1_1)
        * www/nspluginwrapper (nspluginwrapper-0.9.91.5_1)
        * graphics/dri (dri-7.0.3_1,2)
        * security/zenmap (py25-zenmap-4.62_1)
        * x11-servers/xorg-server (xorg-server-1.4_10,1)
        * x11-drivers/xf86-input-keyboard (xf86-input-keyboard-1.2.2_2)
        * x11-drivers/xf86-video-ati (xf86-video-ati-6.8.0_2)
        * x11-drivers/xf86-input-mouse (xf86-input-mouse-1.2.3_2)
        * x11-drivers/xf86-video-intel (xf86-video-intel-2.2.1_1)
        * x11-drivers/xf86-video-radeonhd (xf86-video-radeonhd-1.2.1_1)
        * x11/xfwp (xfwp-1.0.1)
        * x11-drivers/xf86-video-nv (xf86-video-nv-2.1.8_1)
        * x11-toolkits/qt33 (qt-3.3.8_9)
        * graphics/poppler-qt (poppler-qt-0.6.4_1)
        * devel/dbus-qt3 (dbus-qt3-0.70_2)
        * audio/arts (arts-1.5.10_1,1)
        * x11/kdelibs3 (kdelibs-3.5.10)
        * sysutils/kdeadmin3 (kdeadmin-3.5.10)
        * multimedia/kdemultimedia3 (kdemultimedia-3.5.10)
        * net/tightvnc (tightvnc-1.3.9_1)
        * accessibility/kdeaccessibility (kdeaccessibility-3.5.10_1)
        * graphics/kdegraphics3 (kdegraphics-3.5.8_2)


        * x11-wm/kompmgr (kdebase-kompmgr-3.5.10)
        * x11/kdebase3 (kdebase-3.5.10_2)
        * x11/xbacklight (xbacklight-1.1)
        * x11-wm/twm (twm-1.0.3_3)
        * net/kdenetwork3 (kdenetwork-3.5.10)
        * print/pecl-pdflib (pecl-pdflib-2.1.5)
        * deskutils/kdepim3 (kdepim-3.5.10_2)
        * x11-drivers/xf86-video-vesa (xf86-video-vesa-1.3.0_2)
        * x11-drivers/xorg-drivers (xorg-drivers-7.3_2)
        * databases/phpmyadmin (phpMyAdmin-2.11.6)
        * x11/xorg-apps (xorg-apps-7.3)
        * misc/kdeutils3 (kdeutils-3.5.10)
        * x11/xorg (xorg-7.3_2)
        * x11-themes/kdeartwork3 (kdeartwork-3.5.10_1)
        * x11/kde-lite (kde-lite-3.5.8_2)
 

ale

Daemon

Reaction score: 166
Messages: 1,059

Is your ports tree updated?
Can you see the entries for 20090124 and 20090123?
And about linux-glib2, 20090121?
Is a fresh 7.0 install/a 7.0 install on which the ports has never been updated?
 
OP
C

ccc

Aspiring Daemon

Reaction score: 13
Messages: 621

ale said:
Is your ports tree updated?
yes, I have done portsnap fetch update

ale said:
Can you see the entries for 20090124 and 20090123?
And about linux-glib2, 20090121?
Is a fresh 7.0 install/a 7.0 install on which the ports has never been updated?
howto check this ?
 

ale

Daemon

Reaction score: 166
Messages: 1,059

Type $ view /usr/ports/UPDATING
While you are viewing the file, type /20090123
 
OP
C

ccc

Aspiring Daemon

Reaction score: 13
Messages: 621

ale said:
Type $ view /usr/ports/UPDATING
While you are viewing the file, type /20090123
so then I will try:
Code:
20090123:
  AFFECTS: users of x11/libxcb
  AUTHOR: flz@FreeBSD.org

  Libxcb shared library version was bumped from 1 to 2.  You need to
  rebuild any consumer of libxcb.so.1 or some applications will be
  linked against two versions of libxcb once libX11 is upgraded.

  For portupgrade users:

    # portupgrade -rf libxcb
 
OP
C

ccc

Aspiring Daemon

Reaction score: 13
Messages: 621

hydra said:
Also read 20090123 and 20090124.
Code:
20090124:
  AFFECTS: users of x11-servers/xorg-server, sysutils/hal
  AUTHOR: rnoland@FreeBSD.org

  sysutils/hal has been updated and should now properly detect
  mice for use in Xorg.  Use of AllowEmptyInput should no longer
  be needed for most users and moused should now work fine.
thx, then I'll try to update sysutils/hal.
is it correct this way ?
Code:
# portupgrade -f sysutils/hal
 

hydra

Well-Known Member

Reaction score: 27
Messages: 272

The note says that HAL got updated, so no need to specify -f (force).
 
OP
C

ccc

Aspiring Daemon

Reaction score: 13
Messages: 621

thx, now xorg seems to be updated:
Code:
# pkg_info | grep xorg
linux-xorg-libs-6.8.2_5 Xorg libraries, linux binaries
[B]xorg-7.4 [/B]           X.Org complete distribution metaport
xorg-cf-files-1.0.2_3 X.org cf files for use with imake builds
xorg-docs-1.4,1     X.org documentation files
xorg-fonts-100dpi-7.4 X.Org 100dpi bitmap fonts
xorg-fonts-7.4      X.org fonts meta-port
xorg-fonts-75dpi-7.4 X.Org 75dpi bitmap fonts
xorg-fonts-cyrillic-7.4 X.Org Cyrillic bitmap fonts
xorg-fonts-miscbitmaps-7.4 X.Org miscellaneous bitmap fonts
xorg-fonts-truetype-7.4 X.Org TrueType fonts
xorg-fonts-type1-7.4 X.Org Type1 fonts
xorg-libraries-7.4  X.org libraries meta-port
xorg-server-1.5.3_5,1 X.Org X server and related programs
p.s
btw. portupgrade -a is clean:
Code:
# portupgrade -a
#
greetings
ccc
 
Top