Upgrade to 12.0 with NVIDIA driver segfaults Firefox and Thunderbird

JayArr

Member

Reaction score: 3
Messages: 39

Just a warning to those still using old nvidia cards that the upgrade to 12 will break firefox and thunderbird.

Here's what I did:

Load 12.0 from a boot cd and then update and upgrade everything, I think I ended up with 12.0 P3.
pkg install desktop-installer, desktop-installer, chose XFCE and it loaded. My nvidia processor was recognized by the install script and I chose driver version 304. (I have a GeForce6600PCIe). Once the install script finished I rebooted and confirmed that the desktop worked.

pkg install firefox, it ran fine, no errors.
switch to F9 and try to launch it in the gui and nothing happens, open a terminal in the gui and type firefox and I get a segmentation fault.

I get the same thing with thunderbird.

Searching the internet I found I wasn't the only one. Bug 235077 at FreeBSD Bugzilla is basically the same thing. The poster of the bug says they had to revert back to 11.2 so I've abandoned 12.0 and installed 11.2, everything seems to work in 11.2.

I'll monitor bugzilla for a fix and post here when it works again.

Mostly I wanted to try to save people the hour of their life they would lose if they have nvidia and thing an upgrade to 12.0 might be good.
 

Trihexagonal

Daemon

Reaction score: 847
Messages: 1,465

Just a warning to those still using old nvidia cards that the upgrade to 12 will break firefox and thunderbird.
snip
Mostly I wanted to try to save people the hour of their life they would lose if they have nvidia and thing an upgrade to 12.0 might be good.
This my 11 year old Thinkpad T61 running FreeBSD 12.0-RELEASE-p3 with Nvidia Quadro NVS 140M using x11/nvidia-driver-304 and www/firefox-esr to post this now.

6045

I haven't had any problems with FreeBSD 12 I couldn't sort out and everything is running as it should.
 
OP
OP
J

JayArr

Member

Reaction score: 3
Messages: 39

Odd, I know I'm not the only one with this problem so it seems strange to me that your setup works.

Could you run:
pkg info -o firefox
and
pkg which /usr/local/lib/libnvidia-tls.so.1

The bug report specifies firefox-64.0_33,1 and nvidia-driver-304-304.137_2

Also, did you get to this release through updates or a clean install of 12.0-RELEASE?

I just threw the drives I was loading 12.0 on into my spare server to check and I get

firefox 65.0_2,1
nvidia-driver-304-304.137_3

Since the firefox versions are different between the bug report and my machine, maybe the problem is with nvidia-driver-304-304.137_3

I find it odd that on my 11.2 system I'm running nvidia-driver-304-304.137_3.
 

Trihexagonal

Daemon

Reaction score: 847
Messages: 1,465

I'm having it compile the latest version of www/firefox-esr and it will be busy several hours before I can run the commands you requested.

However, the FreeBSD 12.0-RELEASE Release Notes shows it was last modified on 2018-12-10 22:56:48. The last time the 304 driver was updated was 2018-12-14 16:24:02 to version 304.137_2. That would have been the one I built from ports as I waited a few days after the release of FreeBSD 12 to build to the box but will run the commands when it's done to confirm it.

I always do a clean install even with version bumps. It's the only one of my machines I've built FreeBSD 12 on so far since everybody appeared to be having issues but it's ran fine in the 2-3 weeks I had it up. I can only have so many running at once and had more powerful machines up lately and just fired it up again tonight.

It will automagically update to the latest driver available in ports or as pkg when you install it. The are commands to update it if already installed.
 
OP
OP
J

JayArr

Member

Reaction score: 3
Messages: 39

The last time the 304 driver was updated was 2018-12-14 16:24:02 to version 304.137_2.
I've got 304-1.37_3 on my machines so it's been updated since 14Dec18.

I just tried firefox esr in place of firefox but still getting segfaults.

There are so many variables 😕, maybe I'll just wait for 12.1 before leaving 11.2.
 

Trihexagonal

Daemon

Reaction score: 847
Messages: 1,465

It was updated 18 Jan 2019 17:52:59 but I'm certain I built it before then.

I still have this and the other machines I use daily running FreeBSD 11.2-RELEASE-p9. It's not been a priority to update them and when I do will rebuild 5 from ports at once so it's an all day job.
 
OP
OP
J

JayArr

Member

Reaction score: 3
Messages: 39

my database server is still running 11.1 but doesn't use a gui so maybe I'll upgrade it to 12 first then come back to the gui machine later.

Thanks for your help.
 

trev

Aspiring Daemon

Reaction score: 141
Messages: 752

Just a warning to those still using old nvidia cards that the upgrade to 12 will break firefox and thunderbird.
o Late 2009 Mac mini
o FreeBSD citadel 12.0-STABLE FreeBSD 12.0-STABLE #5 r343948: Sun Feb 10 18:45:07 AEDT 2019
o firefox-65.0_2,1 Web browser based on the browser portion of Mozilla
o nvidia0: <GeForce 9400> on vgapci0
o nvidia-driver-340-340.107_3 NVidia graphics card binary drivers for hardware OpenGL rendering

Works for me.
 

Trihexagonal

Daemon

Reaction score: 847
Messages: 1,465

This is what it gave me and am using it now:

Code:
$ pkg which /usr/local/lib/libnvidia-tls.so.1
/usr/local/lib/libnvidia-tls.so.1 was installed by package nvidia-driver-304-304.137_2

$ pkg info -o firefox-esr
firefox-esr-60.5.0_3,1         www/firefox-esr
 

cabriofahrer

Active Member

Reaction score: 8
Messages: 142

I have the same problem after a fresh install of i386 FreeBSD 12.0 on an Aspire 5610 (Nvidia Geforce Go 7300) with nvidia-driver-304 and Firefox and Seamonkey. Opera and chromium work though and no other problems with any other software so far. Kodi works, which is most important to me. Everything installed from packages just a few days ago.

But I would like seamonkey to work, especially because I use it as e-mail client. So what is the solution? Is this issue being fixed?
 
OP
OP
J

JayArr

Member

Reaction score: 3
Messages: 39

Hi Cabrio

I never found a solution, I'm still back on 11.2

Are you using NVidia 304-1.37_3?

I wonder if it's specific to that version because Trihexagonal has success using 304-1.37_2 and Trev is working using NVidia 340.107_3

Nobody has reported the same combination I had as working anywhere else, it's always a slightly different recipe.
 
OP
OP
J

JayArr

Member

Reaction score: 3
Messages: 39

Have you tried removing it and then forcing 304-304.137_2 to be installed?

I thought of this but never tried it. It seems to be working for Trihex.
 

cabriofahrer

Active Member

Reaction score: 8
Messages: 142

How would I do that when ver. 304-304.137_3 is in the packages? Also, if a previous version does not have that error, then this must be a regression, which is hopefully being fixed for the next version.
 
OP
OP
J

JayArr

Member

Reaction score: 3
Messages: 39

Good question, I'm not sure of the answer. You may need to build the earlier version from ports?? I don't have a lot of experience in this area, I only do a few installations a year. Your right, the easiest thing may be to wait for 304-304.137_4 to see if it fixes the segmentation faults. It's also possible that the problem is in Mozilla/thunderbird and the next upgrade from them will solve it.
 

shkhln

Well-Known Member

Reaction score: 171
Messages: 463

Top