Upgrade from 12 to 12.1 Failed - stuck in single user mode.

bsdnoob

Member

Reaction score: 3
Messages: 34

I tried to upgrade to 12.1 but all had gone wrong and now I'm stuck in single user mode where no command is working. Please let me state what I did.
In my first attempt, my p4 system suddenly hung when downloaded 45060 patches were being applied so I had to reboot and start the from scratch by issuing #freebsd-update -r 12.1-RELEASE upgrade. This time all the patches were downloaded and applied, I was asked to install the upgrade and reboot. When it came up to complete the upgrade installation, I was getting a series of following error messages;
Code:
gunzip: (stdin): unexpected end of file

,,,,,


Failed to fully fault in a core file segment at VA 0 to be written at atleast 0x20669000 with size 0x35000 for process sh

...
The aforementioned messages repeated many times ended. Finally I landed in single user mode.
Nothing worked in it. Whatever I tried in single user mode; I got the following messages;
Code:
pid 24 (sh), jid 0, uid 0, exited on signal 11
What do I do now?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,085
Messages: 33,642

Is the /rescue in installation disk?
No, it's always available. And you don't need to cd to it. Just run /rescue/sh for example. Or /rescue/ls, /rescue/ps, etc. There are a whole bunch of commands in /rescue, specifically for situations like this.
 
Top