Updated FreeBSD 12.0-RELEASE and rebooted, and now it isn't booting, seems to not be loading ZFS?

puppyboy

Member

Reaction score: 4
Messages: 51

The server is a Dell Poweredge T720 with 8x disks in RAID10 using ZFS. It was originally installed a few weeks ago, and was done pretty generically through the installer - no tweaks were made besides those asked for in the install process itself. The server is just used as a file share and for hosting a number of jails.

Everything worked fine up until yesterday, when I installed the recent patches in the usual manner - freebsd-update fetch install. It completed and I rebooted, and now,it goes straight to this BTX bootloader menu that I've never seen before. I tried to run a few commands to see if it does anything, but I couldn't get anything that seemed useful (to me at least). I've put online five pictures of the boot process and the screen showing the menu and some of the output from what seemed like relevant options: https://imgur.com/a/C8OS9oe

I loaded the freebsd installer again hoping I'd be able to just tell it to install again using my existing pool (which would have been annoying to re-create my jail.conf and such but it would have been acceptable to get things running again quickly), but I didn't see a way to do this. I did attempt to mount the zfs pool under the terminal mode from the installer and it worked fine, and as far as I can tell there's nothing wrong with the pool itself.

I don't really get what's going on here, or what I need to do to fix it. Any input would be appreciated. I'll keep an eye on this thread and try to answer any questions you might have that could help.
 
Top