Update MySQL 8.0.30 error

run service mysql-server start error:
Code:
ld-elf.so.1: /lib/libc.so.7: version FBSD_1.7 required by /usr/local/libexec/mysqld not found
/usr/local/etc/rc.d/mysql-server: WARNING: failed precmd routine for mysql
 

SirDice

Administrator
Staff member
Administrator
Moderator
No, you only upgraded the kernel. You haven't upgraded the rest of the system yet. So you only ran freebsd-update install once. It should be ran twice.
 
No, you only upgraded the kernel. You haven't upgraded the rest of the system yet. So you only ran freebsd-update install once. It should be ran twice.
Execution prompt
Code:
root@freebsd:~ # freebsd-update install
src component not installed, skipped
No updates are available to install.
Run '/usr/sbin/freebsd-update fetch' first.
How should I fix it now?
 

SirDice

Administrator
Staff member
Administrator
Moderator
You managed to mess it up. You can try starting over again; freebsd-update -r 13.1-RELEASE --currently-running 13.0-RELEASE upgrade. The --currently-running is necessary as you've already done a partial upgrade.
 
You managed to mess it up. You can try starting over again; freebsd-update -r 13.1-RELEASE --currently-running 13.0-RELEASE upgrade. The --currently-running is necessary as you've already done a partial upgrade.
Thanks, I'll try first!
 
install mysql 8.0.29 error
ld-elf.so.1: /lib/libc.so.7: version FBSD_1.7 required by /usr/local/libexec/mysqld not found
/usr/local/etc/rc.d/mysql-server: WARNING: failed precmd routine for mysql
 
I reinitialize the cloud system and install the lower version
No need to re-install. You just have to complete the FreeBSD update to 13.1 properly as described in the manual. After you upgraded both the kernel and world successfully, you can update your packages. This should ultimately resolve your issue.

freebsd-version -k -u reporting different versions is a give-away for an incomplete update procedure.
 
Top