update issues on FreeBSD 11 on RPI2

andrewm659

Active Member

Reaction score: 4
Messages: 152

So no matter what I do get the following on my RasPi 2 using FreeBSD 11. Tried doing what it said to fix it. Is there something else I could do?

Code:
pkg update
pkg: Warning: Major OS version upgrade detected.  Running "pkg-static install -f pkg" recommended
Updating FreeBSD repository catalogue...
Fetching meta.txz: 100%    944 B   0.9kB/s    00:01
Fetching packagesite.txz: 100%    4 MiB   1.5MB/s    00:03
pkg: rsa verify failed: error:04091077:rsa routines:INT_RSA_VERIFY:wrong signature length
pkg: No trusted certificate has been used to sign the repository
Unable to update repository FreeBSD

pkg search noip
pkg: Warning: Major OS version upgrade detected.  Running "pkg-static install -f pkg" recommended
pkg: Repository FreeBSD missing. 'pkg update' required
pkg: rsa verify failed: error:04091077:rsa routines:INT_RSA_VERIFY:wrong signature length
pkg: No trusted certificate has been used to sign the repository
pkg: Repository FreeBSD cannot be opened. 'pkg update' required

pkg-static install -f pkg
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg-static install -f pkg" recommended
Updating FreeBSD repository catalogue...
Fetching meta.txz: 100%    944 B   0.9kB/s    00:01
Fetching packagesite.txz: 100%    4 MiB   1.5MB/s    00:03
pkg-static: rsa verify failed: error:04091077:rsa routines:INT_RSA_VERIFY:wrong signature length
pkg-static: No trusted certificate has been used to sign the repository
Unable to update repository FreeBSD
All repositories are up-to-date.
pkg-static: Repository FreeBSD cannot be opened. 'pkg update' required
Checking integrity... done (0 conflicting)
The most recent version of packages are already installed
 
Top