Solved Unknown option MFS error when compiling the kernel

I get unknown option MFS error when I try to compile kernel with option MFS. Here is config:

# MT7628_FDT -- Kernel configuration file for FreeBSD/MIPS MT7628 and MT7688
# SoCs
# This includes all the configurable parts of the kernel.
# $FreeBSD: head/sys/mips/conf/MT7628_FDT 315141 2017-03-12 07:09:50Z manu $


# FDT_DTS_FILE should be modified to suit the target board type.
#makeoptions     FDT_DTS_FILE=LINKIT7688.dts

# Start with a base configuration
include     "../mediatek/std.mediatek"

ident         MT7628
cpu         CPU_MIPS24K

# Don't build any modules by default
makeoptions     MODULES_OVERRIDE=""

# Default rootfs device configuration, should be changed to suit target board
options     ROOTDEVNAME=\"ufs:md0.uzip\"

# Support geom_uzip(4) compressed disk images
device         geom_uzip
options     GEOM_UZIP

# Support md(4) and md-based rootfs
device         md
option        MFS
options     MD_ROOT

# Interrupt controller support
device         mtk_intr_v2

# UART device support is compiled in when uart_ns8250 is selected (default)

# SPI and SPI flash support
device         mtk_spi_v2
device         spibus
device         mx25l

# GPIO and gpioled support
device         mtk_gpio_v2
device         gpio
device         gpioled

# PCI support
device         pci

# USB (ehci, ohci) support
device         usb
device         mtk_usb_phy
device         ehci
device         ohci

# USB umass(4) storage and da(4) support
device         umass
device         da

# CAM support, required if umass(4) is enabled above
device         pass
device         scbus

# Ethernet, BPF and bridge support
device         rt
device         bpf
device         if_bridge

# Extres
options        EXT_RESOURCES
device         clk

Note: I tried options instead of option too.

And I found this:

But when I compile with device md instead I got this error:

*** Target Done.
*** Target        : mfsroot
*** Deleting old file system..
*** Creating new filesystem...
*** Populating filesystem...
*** Target Done.
*** Target        : fsimage
*** Running makefs to build compressed image ..
*** from /data/freebsd/head/src/../mfsroot/ralink ..
Calculated size of `/data/freebsd/head/src/../img//mfsroot-ralink.img': 17899520 bytes, 1266 inodes
Extent size set to 4096
/data/freebsd/head/src/../img//mfsroot-ralink.img: 17.1MB (34960 sectors) block size 4096, fragment size 512
   using 2 cylinder groups of 12.92MB, 3308 blks, 992 inodes.
super-block backups (for fsck -b #) at:
    32, 26496,
Populating `/data/freebsd/head/src/../img//mfsroot-ralink.img'
Image `/data/freebsd/head/src/../img//mfsroot-ralink.img' complete
*** Running mkuzip to create a compressed filesystem ..
*** Target Done.
*** Target        : netboot
Can't locate mfs section within kernel

Edit: Solved the problem. Changed the script so it does not create mfsroot image.