Solved unbound error: could not open root.zone.tmp*: Permission denied

sdf

Active Member

Reaction score: 3
Messages: 170

When I started unbound, I received 3 errors message:

Code:
error: could not open root.zone.tmp*: Permission denied
error: could not rename(root.zone.tmp*, root .zone): No such file or directory
error: ./services/authzone.c at 4804 could not pthread_rwlock_unlock(&z->lock): Operation not permitted
What went wrong? Thanks.


unbound.conf
Code:
auth-zone:
    name: "."
    url: "http://www.internic.net/domain/root.zone"
    fallback-enabled: yes
    for-downstream: no
    for-upstream: yes
    zonefile: "root.zone"
 
Last edited by a moderator:

ShelLuser

Son of Beastie

Reaction score: 1,726
Messages: 3,546

Error messages such as "Operation not permitted" seem obvious enough: it tried to do something but wasn't allowed to do so. Then you get a cascading problem because other actions depended on the first, which didn't succeed and then you run into this.

I'd start by checking directory permissions, in specific the directory in which your datafiles are kept (I'm assuming something such as /var/unbound (I think, not sure from mind). Either way, check the permission bits and see if the unbound user still has write access, I'm guessing that this got changed somehow.
 
Top