Unbearable scp speeds on gigabit network.

Hello dear fellow BSD superusers.

I come before you today to ask a question that has been killing me for the last 15 hours of my life. Situation is as follows:

1VPS on proxmox latest version node running Freebsd 9.3/10.2/10.3 amd64 (I put 3 ver. here because I tried with 3)
1VPS on proxmox latest version node running Debian amd64

BSD VPS has ~1000mbps on speedtest. Fetching an iso from bsd official yields similar results (around 70mb/s download)
Debian VPS has ~1000mbps on speedtest. wget is similar just like on BSD.

HOWEVER, when using filezilla or similar scp/sftp/etc client to transfer files to those 2 VPS, BSD only goes 1mb/s while debian easily goes 70mb/s+ and all that on fresh installs of both OSs

What I have tried so far:

Increase window size
Increase buffer
Check if card is full duplex (it is)
Set max mtu
Tried with upgraded openssh

(Basically all the things listed in the forums or in the mailing lists)

And the problem is still here ... only getting around 1mb/s when transfering files.

I also changed encryption algorithm and still no results.

Btw the machine is specced as follows:

16Gb of DDR4 RAM
20vCores of Xeon E5 E5-2650v3 20C/40T
4x 800gb SSD in raid5

Please if you have any ideea help because I am losing my mind.

I listed the debian symptoms to rule out any proxmox issues as there are none.

Also tried with e1000 and virtio card and same.

Thank you!
I'd try turning off TSO/LRO on the interface, it sometimes causes problems on virtualized hardware.
Any sort of hardware offload on virtualized platform is likely to be a slowdown unless you're using drivers (such as vtnet(4)) that are aware of the fact that there is no real hardware present.